]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
- cvs snap 20030329
[packages/valgrind.git] / valgrind.spec
1 %define         snap    20030329
2 Summary:        An open-source memory debugger for x86-GNU/Linux
3 Summary(pl):    Otwarty odpluskwiacz pamiêci dla Linuksa x86
4 Name:           valgrind
5 Version:        1.9.4
6 Release:        1.%{snap}.1
7 License:        GPL
8 ExclusiveArch:  %{ix86}
9 Group:          Networking/Utilities
10 #Source0:       http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
11 Source0:        %{name}-%{snap}.tar.bz2
12 URL:            http://developer.kde.org/~sewardj/
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 # Valgrind binaries should _never_ be stripped
18 %define         no_install_post_strip   1
19
20 # Same name as libpthread
21 %define         _noautoprovfiles %{_libdir}/%{name}/libpthread.so.0 %{_libdir}/%{name}/libpthread.so %{_libdir}/%{name}/valgrind.so %{_libdir}/%{name}/valgrinq.so
22
23 %description
24 Valgrind is a GPL'd tool to help you find memory-management problems
25 in your programs. When a program is run under Valgrind's supervision,
26 all reads and writes of memory are checked, and calls to
27 malloc/new/free/delete are intercepted. As a result, Valgrind can
28 detect problems such as:
29
30 - Use of uninitialised memory
31 - Reading/writing memory after it has been free'd
32 - Reading/writing off the end of malloc'd blocks
33 - Reading/writing inappropriate areas on the stack
34 - Memory leaks -- where pointers to malloc'd blocks are lost forever
35 - Passing of uninitialised and/or unaddressible memory to system calls
36 - Mismatched use of malloc/new/new [] vs free/delete/delete []
37 - Some misuses of the POSIX pthreads API
38
39 %description -l pl
40 Valgrind jest narzêdziem rozwi±zuj±cym problemy zwi±zane z zarz±dzaniem
41 pamiêci± w programach. Gdy program zostaje uruchomiony pod nadzorem
42 Valgrinda wszystkie odczyty i zapisy do pamiêci s± sprawdzane.
43 Przechwytywane s± te¿ odwo³ania do malloc/new/free/delete. Dziêki temu
44 mo¿na wykryæ nastêpuj±ce problemy:
45
46 - U¿ycie niezainicjalizowanej pamiêci
47 - Odczytywanie/zapisywanie do obszaru pamiêci, który zosta³ zwolniony
48 - Odczytywanie/zapisywanie na koñcach zaalokowanych bloków
49 - Odczytywanie/zapisywanie niew³a¶ciwych obszarów na stosie
50 - Wycieki pamiêci -- gdy wska¼niki do zaalokowanych bloków s± stracone na
51   zawsze
52 - Przekazywanie niezainicjalizowanej i/lub nieadresowalnej pamiêci do
53   odwo³añ systemowych
54 - Niekonsekwencja w u¿ywaniu malloc/new/new [] kontra free/delete/delete []
55 - Niektóre nadu¿ycia API POSIX pthreads
56
57 %prep
58 %setup -q -n %{name}
59
60 # pthread_atfork() not found (?)
61 echo "main(){}" > corecheck/tests/pth_atfork1.c
62
63 %build
64 rm -f missing
65 %{__aclocal}
66 %{__autoheader}
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         LDFLAGS="" # no strip!
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
84 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
85 %doc $RPM_BUILD_ROOT%{_docdir}/valgrind/*.html
86 %attr(755,root,root) %{_bindir}/*
87 %{_includedir}/*
88 %{_libdir}/%{name}
This page took 0.032597 seconds and 4 git commands to generate.