]> git.pld-linux.org Git - packages/valgrind.git/blob - valgrind.spec
17c9fe8defeb4a52aac85e69dbb7b135a8b0c0d0
[packages/valgrind.git] / valgrind.spec
1 Summary:        An open-source memory debugger for x86-GNU/Linux
2 Name:           valgrind
3 Version:        1.0.0
4 Release:        1
5 License:        GPL
6 ExclusiveArch:  %{ix86}
7 Group:          Networking/Utilities
8 Source0:        http://developer.kde.org/~sewardj/%{name}-%{version}.tar.bz2
9 URL:            http://developer.kde.org/~sewardj/
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
13
14 # valgrind binaries should _never_ be stripped
15 # anyone knows better solution?
16 %define         debug   1
17
18 %description
19 Valgrind is a GPL'd tool to help you find memory-management problems
20 in your programs. When a program is run under Valgrind's supervision,
21 all reads and writes of memory are checked, and calls to
22 malloc/new/free/delete are intercepted. As a result, Valgrind can
23 detect problems such as:
24
25 - Use of uninitialised memory
26 - Reading/writing memory after it has been free'd
27 - Reading/writing off the end of malloc'd blocks
28 - Reading/writing inappropriate areas on the stack
29 - Memory leaks -- where pointers to malloc'd blocks are lost forever
30 - Passing of uninitialised and/or unaddressible memory to system calls
31 - Mismatched use of malloc/new/new [] vs free/delete/delete []
32 - Some misuses of the POSIX pthreads API
33
34 %prep
35 %setup -q
36
37 %build
38 rm -f missing
39 aclocal
40 %{__autoconf}
41 %{__automake}
42 %configure
43 %{__make}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc ACKNOWLEDGEMENTS AUTHORS ChangeLog PATCHES_APPLIED
56 %doc README README_MISSING_SYSCALL_OR_IOCTL TODO
57 %doc docs/*.html
58 %attr(755,root,root) %{_bindir}/*
59 %{_includedir}/*
60 %{_libdir}/%{name}
This page took 0.026022 seconds and 3 git commands to generate.