]> git.pld-linux.org Git - packages/valgrind.git/blame - valgrind.spec
on %{arm} ensure valgrind is built in arm mode
[packages/valgrind.git] / valgrind.spec
CommitLineData
23a3ecde
AM
1# TODO:
2# - fix CC detection in configure, so CC=gcc won't be needed
9ab8af97
JB
3#
4# Conditional build:
5%bcond_with mpi # MPI wrapper module
6#
9fd66024 7Summary: An open-source memory debugger
81257f7b 8Summary(pl.UTF-8): Otwarty odpluskwiacz pamięci
cccdc142 9Name: valgrind
fe37a336 10Version: 3.20.0
13ff9b64 11Release: 1
9ab8af97 12License: GPL v2+
c5631d09 13Group: Development/Tools
644f5b95 14Source0: https://sourceware.org/pub/valgrind/%{name}-%{version}.tar.bz2
fe37a336 15# Source0-md5: e3ca8e03c6c527e80e7da5135a1b6beb
5beaf085
KK
16Patch0: %{name}-native-cpuid.patch
17Patch1: %{name}-ld_linux_strlen.patch
a3b52c72 18Patch2: %{name}-datadir.patch
09b8d42f 19URL: https://www.valgrind.org/
9ab8af97
JB
20BuildRequires: autoconf >= 2.50
21BuildRequires: automake >= 1:1.10
54375cc9 22BuildRequires: gcc >= 5:3.0
a8c253df
JB
23%ifarch x32
24BuildRequires: gcc-multilib-64 >= 5:3.0
25%endif
2ea65fbf 26# check in configure.ac:882 AC_MSG_CHECKING([the GLIBC_VERSION version])
3a93a74d 27BuildRequires: glibc-devel >= 6:2.2
1abb996b 28BuildRequires: libgomp-devel
54375cc9 29BuildRequires: libstdc++-devel
9ab8af97 30%{?with_mpi:BuildRequires: mpi-devel}
4c3298eb 31BuildRequires: rpmbuild(macros) >= 2.007
09b8d42f
JB
32Obsoletes: valgrind-callgrind < 0.11
33Obsoletes: valgrind-calltree < 0.10
4c3298eb 34ExclusiveArch: %{ix86} %{x8664} %{armv7} ppc ppc64 s390x x32 aarch64
cccdc142
JK
35BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
9fd66024 37%define _noautostrip .*/vgpreload.*\\.so
4dd60bb4 38%define filterout_c -fstack-protector-strong
79e9a7b2
ER
39# ld portion broken
40%undefine with_ccache
a803692b 41
179d7896
JP
42%define specflags_arm -marm
43
cccdc142 44%description
9fd66024 45Valgrind is a GPL'd system for debugging and profiling Linux programs.
46With the tools that come with Valgrind, you can automatically detect
6b924c54
JP
47many memory management and threading bugs, avoiding hours of
48frustrating bug-hunting, making your programs more stable. You can
49also perform detailed profiling to help speed up your programs.
cccdc142 50
f86a5f7e
JR
51%description -l pl.UTF-8
52Valgrind jest systemem służącym do odpluskwiania i profilowania
53programów na Linuksie. Używając dostarczanych z nim narzędzi można
6b924c54
JP
54automatycznie wykrywać wiele błędów związanych z zarządzaniem pamięcią
55i wątkowaniem, dzięki czemu unika się frustrującego polowania na
56błędy, a także czyni się programy bardziej stabilnymi. Możliwe jest
57również dokładne profilowanie, dzięki któremu programy zaczną szybciej
58pracować.
a3b1e5f5 59
cccdc142 60%prep
4ff172b5 61%setup -q
5beaf085 62%patch0 -p1
1dc3004f 63%patch1 -p1
a3b52c72 64%patch2 -p1
68bd9ee3 65
cccdc142 66%build
c594fc71 67%{__aclocal}
cccdc142 68%{__autoconf}
9ab8af97 69%{__autoheader}
cccdc142 70%{__automake}
e7968d53
PS
71
72ac_cv_path_GDB=/usr/bin/gdb \
9eb4ec2b 73%configure \
1abb996b 74 --enable-tls \
6d4c7c59 75 %{!?with_mpi:--with-mpicc=/bin/false} \
157676c9 76%if "%{_lib}" != "lib"
68bd9ee3 77 --enable-only64bit \
644f5b95 78%endif \
09b8d42f 79 --enable-lto \
9eb4ec2b 80 LDFLAGS="" # no strip!
e7968d53 81
cccdc142
JK
82%{__make}
83
84%install
85rm -rf $RPM_BUILD_ROOT
86
a273c144
JB
87%{__make} install \
88 DESTDIR=$RPM_BUILD_ROOT
cccdc142 89
54375cc9 90%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/doc
ef1230c9
AM
91cp -p docs/index.pdf docs/valgrind_manual.pdf
92cp -p docs/index.ps docs/valgrind_manual.ps
6b924c54 93
cccdc142
JK
94%clean
95rm -rf $RPM_BUILD_ROOT
96
97%files
98%defattr(644,root,root,755)
a15e5165 99%doc AUTHORS NEWS README README_MISSING_SYSCALL_OR_IOCTL
6b924c54 100%doc docs/html docs/valgrind_manual.pdf docs/valgrind_manual.ps
54375cc9
JB
101%attr(755,root,root) %{_bindir}/callgrind_annotate
102%attr(755,root,root) %{_bindir}/callgrind_control
103%attr(755,root,root) %{_bindir}/cg_annotate
104%attr(755,root,root) %{_bindir}/cg_diff
105%attr(755,root,root) %{_bindir}/cg_merge
106%attr(755,root,root) %{_bindir}/ms_print
107%attr(755,root,root) %{_bindir}/valgrind
ef1230c9 108%attr(755,root,root) %{_bindir}/valgrind-di-server
54375cc9
JB
109%attr(755,root,root) %{_bindir}/valgrind-listener
110%attr(755,root,root) %{_bindir}/vgdb
f1c36ddf 111%dir %{_libdir}/%{name}
157676c9 112%{_libdir}/%{name}/lib*-linux.a
9ab8af97
JB
113%if %{with mpi}
114# TODO: subpackage?
115%attr(755,root,root) %{_libdir}/%{name}/libmpiwrap-*-linux.so
116%endif
09b8d42f 117%if "%{_libexecdir}" != "%{_libdir}"
157676c9 118%dir %{_libexecdir}/%{name}
09b8d42f 119%endif
157676c9
JP
120%attr(755,root,root) %{_libexecdir}/%{name}/*-linux
121%attr(755,root,root) %{_libexecdir}/%{name}/vgpreload_*-linux.so
122%{_libexecdir}/%{name}/*.xml
123%{_libexecdir}/%{name}/default.supp
a3b52c72 124%{_datadir}/%{name}
54375cc9
JB
125%{_includedir}/valgrind
126%{_mandir}/man1/callgrind_annotate.1*
127%{_mandir}/man1/callgrind_control.1*
128%{_mandir}/man1/cg_annotate.1*
ef1230c9
AM
129%{_mandir}/man1/cg_diff.1*
130%{_mandir}/man1/cg_merge.1*
54375cc9
JB
131%{_mandir}/man1/ms_print.1*
132%{_mandir}/man1/valgrind.1*
6d4c7c59 133%{_mandir}/man1/valgrind-di-server.1*
ef1230c9
AM
134%{_mandir}/man1/valgrind-listener.1*
135%{_mandir}/man1/vgdb.1*
54375cc9 136%{_pkgconfigdir}/valgrind.pc
This page took 0.081275 seconds and 4 git commands to generate.