]> git.pld-linux.org Git - packages/vagrant.git/commitdiff
lib/pre-rubygems.rb is gone master auto/th/vagrant-2.1.2-4
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 22 Feb 2019 21:46:58 +0000 (23:46 +0200)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 22 Feb 2019 21:46:58 +0000 (23:46 +0200)
see https://github.com/hashicorp/vagrant/pull/7793

vagrant.sh
vagrant.spec

index f738eaf78004350f4955a978989cfae2fd9cc15e..0c64e367b24be7740a13fcedca54bd62bf5e6572 100755 (executable)
@@ -22,16 +22,12 @@ unset RUBYLIB
 
 # Find the Vagrant executable
 for needle in "${GEM_PATH}/gems/vagrant-"*; do
-       if [ -f "${needle}/lib/vagrant/pre-rubygems.rb" ]; then
+       if [ -f "${needle}/lib/vagrant/version.rb" ]; then
                VAGRANT_GEM_PATH="${needle}"
        fi
 done
 
 VAGRANT_EXECUTABLE="${VAGRANT_GEM_PATH}/bin/vagrant"
-VAGRANT_LAUNCHER="${VAGRANT_GEM_PATH}/lib/vagrant/pre-rubygems.rb"
-
-# Export the VAGRANT_EXECUTABLE so that pre-rubygems can optimize a bit
-export VAGRANT_EXECUTABLE
 
 # Call the actual Vagrant bin with our arguments
-exec "${RUBY_EXECUTABLE}" "${VAGRANT_LAUNCHER}" "$@"
+exec "$RUBY_EXECUTABLE" -r rubygems "$VAGRANT_EXECUTABLE" "$@"
index fed3858971f47bcb68b4c0d31361477446b26655..7ea417f9122aea90fb53a9bb3b94ff8a45629d51 100644 (file)
@@ -3,7 +3,7 @@
 Summary:       Provisioning and deployment of virtual instances
 Name:          vagrant
 Version:       2.1.2
-Release:       3
+Release:       4
 License:       MIT
 Group:         Applications/Emulators
 Source0:       https://github.com/mitchellh/vagrant/archive/v%{version}/%{name}-%{version}.tar.gz
This page took 0.124651 seconds and 4 git commands to generate.