]> git.pld-linux.org Git - packages/util-linux.git/commitdiff
- up to 2.20; builds only without dietlibc
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 29 Aug 2011 14:03:08 +0000 (14:03 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    util-linux-diet.patch -> 1.4
    util-linux-fdformat-ide.patch -> 1.4
    util-linux-ng-ppc.patch -> 1.2
    util-linux.spec -> 1.311

util-linux-diet.patch
util-linux-fdformat-ide.patch
util-linux-ng-ppc.patch [deleted file]
util-linux.spec

index 3118a25ed80851e98d32d99a4398f1deff329448..888bb533f66caca3a4235a039a6d68404ddd1c16 100644 (file)
@@ -1,5 +1,5 @@
---- util-linux-ng-2.18/shlibs/mount/src/fs.c~  2010-06-08 10:44:20.000000000 +0200
-+++ util-linux-ng-2.18/shlibs/mount/src/fs.c   2010-08-26 11:12:31.326572794 +0200
+--- util-linux-ng-2.18/libmount/src/fs.c~      2010-06-08 10:44:20.000000000 +0200
++++ util-linux-ng-2.18/libmount/src/fs.c       2010-08-26 11:12:31.326572794 +0200
 @@ -17,6 +17,9 @@
  #include <errno.h>
  #include <blkid.h>
  
  #include "nls.h"
  #include "mountP.h"
---- util-linux-ng-2.18/shlibs/mount/src/tab_parse.c~   2010-06-07 12:35:06.000000000 +0200
-+++ util-linux-ng-2.18/shlibs/mount/src/tab_parse.c    2010-08-26 11:16:35.762572782 +0200
+--- util-linux-ng-2.18/libmount/src/tab_parse.c~       2010-06-07 12:35:06.000000000 +0200
++++ util-linux-ng-2.18/libmount/src/tab_parse.c        2010-08-26 11:16:35.762572782 +0200
 @@ -9,6 +9,9 @@
+ #include <limits.h>
  #include <dirent.h>
  #include <fcntl.h>
- #include <unistd.h>
 +#ifdef __dietlibc__
 +#include <sys/stat.h> /* for makedev macro */
 +#endif
  
- #include "nls.h"
+ #include "at.h"
  #include "mangle.h"
---- util-linux-ng-2.18/lib/tt.c~       2010-06-07 11:44:06.000000000 +0200
-+++ util-linux-ng-2.18/lib/tt.c        2010-08-26 11:32:34.886572774 +0200
-@@ -54,7 +54,7 @@
- };
- #else /* !HAVE_WIDECHAR */
--# define mbs_width       strlen(_s)
-+# define mbs_width(_s)        strlen(_s)
- #endif /* !HAVE_WIDECHAR */
- #define is_last_column(_tb, _cl) \
 --- util-linux-2.19/lib/strutils.c~    2011-01-31 16:43:47.000000000 +0100
 +++ util-linux-2.19/lib/strutils.c     2011-02-10 12:49:12.221843465 +0100
 @@ -12,6 +12,9 @@
@@ -45,8 +34,8 @@
  
  static int do_scale_by_power (uintmax_t *x, int base, int power)
  {
---- util-linux-2.19/shlibs/mount/src/utils.c~  2011-01-24 23:46:29.000000000 +0100
-+++ util-linux-2.19/shlibs/mount/src/utils.c   2011-02-10 20:12:00.499611392 +0100
+--- util-linux-2.19/libmount/src/utils.c~      2011-01-24 23:46:29.000000000 +0100
++++ util-linux-2.19/libmount/src/utils.c       2011-02-10 20:12:00.499611392 +0100
 @@ -398,7 +398,11 @@
        int rc = -1;
          struct passwd pwd;
        char *buf;
  
        if (!groupname || !gid)
---- util-linux-2.19/shlibs/mount/src/tab_update.c~     2011-02-09 14:23:48.000000000 +0100
-+++ util-linux-2.19/shlibs/mount/src/tab_update.c      2011-02-10 20:26:15.846797059 +0100
-@@ -653,7 +653,12 @@
-       sigfillset(&sigs);
-       sigprocmask(SIG_BLOCK, &sigs, &upd->oldsigmask);
--      upd->utab_lock = open(lfile, O_RDONLY|O_CREAT|O_CLOEXEC, S_IWUSR|
-+      upd->utab_lock = open(lfile, O_RDONLY|
-+#ifdef O_CLOEXEC
-+                      O_CLOEXEC|
-+#endif
-+                      O_CREAT,
-+                      S_IWUSR|
-                                    S_IRUSR|S_IRGRP|S_IROTH);
-       free(lfile);
 --- util-linux-2.19/lib/at.c~  2011-01-31 16:43:47.000000000 +0100
 +++ util-linux-2.19/lib/at.c   2011-02-10 20:30:37.336797058 +0100
 @@ -7,6 +7,7 @@
 --- util-linux-2.19/misc-utils/findmnt.c~      2011-01-31 16:43:47.000000000 +0100
 +++ util-linux-2.19/misc-utils/findmnt.c       2011-02-10 20:54:23.100130391 +0100
 @@ -30,6 +30,9 @@
- #include <sys/ioctl.h>
  #endif
  #include <assert.h>
+ #include <poll.h>
 +#ifdef __dietlibc__
 +#include <sys/stat.h> /* for major and minor macros */
 +#endif
  
- #define USE_UNSTABLE_LIBMOUNT_API
  #include <libmount.h>
 --- util-linux-2.19/fsck/fsck.c~       2011-02-07 16:19:29.000000000 +0100
 +++ util-linux-2.19/fsck/fsck.c        2011-02-10 21:09:27.024658725 +0100
 @@ -270,7 +270,13 @@
  #include "nls.h"
  
  static void __attribute__((__noreturn__)) usage(int rc)
---- util-linux-2.19/misc-utils/scriptreplay.c~ 2011-01-31 16:43:47.000000000 +0100
-+++ util-linux-2.19/misc-utils/scriptreplay.c  2011-02-10 22:26:22.019069258 +0100
+--- util-linux-2.19/term-utils/scriptreplay.c~ 2011-01-31 16:43:47.000000000 +0100
++++ util-linux-2.19/term-utils/scriptreplay.c  2011-02-10 22:26:22.019069258 +0100
 @@ -28,6 +28,7 @@
  #include <unistd.h>
  #include <err.h>
  #include "nls.h"
  
  #define SCRIPT_MIN_DELAY 0.0001               /* from original sripreplay.pl */
---- util-linux-2.19/shlibs/mount/src/tab_parse.c~      2011-02-10 23:28:02.091461025 +0100
-+++ util-linux-2.19/shlibs/mount/src/tab_parse.c       2011-02-10 23:29:04.934794359 +0100
+--- util-linux-2.19/libmount/src/tab_parse.c~  2011-02-10 23:28:02.091461025 +0100
++++ util-linux-2.19/libmount/src/tab_parse.c   2011-02-10 23:29:04.934794359 +0100
 @@ -422,7 +422,13 @@
  
        /* TODO: it would be nice to have a scandir() implementaion that
index 80ea0b600dc2d094fcbbb920b15d0fe4d45fea00..8222098f4cfefdc995b9d82e1456a14da41510a9 100644 (file)
@@ -1,16 +1,17 @@
 --- util-linux-2.12p/disk-utils/fdformat.8.ide 2005-04-25 11:39:19.528340384 +0200
 +++ util-linux-2.12p/disk-utils/fdformat.8     2005-04-25 11:44:07.189609224 +0200
-@@ -45,6 +45,10 @@
+@@ -43,6 +43,11 @@
+ autodetected earlier.  In this case, use
  .BR setfdprm (8)
  to load the disk parameters.
++
 +For ATAPI IDE floppy driver (also known as LS-120 drives or "Superdisk"
-+drives) you have to use the 
++drives) you have to use the
 +.BR floppy (8).
 +
  .SH OPTIONS
  .TP
- .B \-n
+ \fB\-n\fR, \fB\-\-no\-verify\fR
 @@ -54,6 +58,7 @@
  .BR fd (4),
  .BR setfdprm (8),
diff --git a/util-linux-ng-ppc.patch b/util-linux-ng-ppc.patch
deleted file mode 100644 (file)
index 20bed49..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- ./hwclock/clock-ppc.c.org  2007-08-28 09:58:10.336900636 +0200
-+++ ./hwclock/clock-ppc.c      2007-08-28 09:58:22.769681100 +0200
-@@ -31,7 +31,8 @@
- #include <getopt.h>
- #include <sys/time.h>
--#include <asm/cuda.h>
-+#include <linux/cuda.h>
-+#include <linux/adb.h>
- /*
-  * Adapted for Power Macintosh by Paul Mackerras.
index 8446595c62e33a771d2dad62d6a4a8510e9e9cf9..6979bcbd8155a9d15cfb41d8c3f82bee5d23966b 100644 (file)
@@ -29,18 +29,17 @@ Summary(ru.UTF-8):  Набор базовых системных утилит д
 Summary(tr.UTF-8):     Temel sistem araçları
 Summary(uk.UTF-8):     Набір базових системних утиліт для Linux
 Name:          util-linux
-Version:       2.19.1
-Release:       1
+Version:       2.20
+Release:       0.1
 License:       GPL
 Group:         Applications/System
-Source0:       http://ftp.kernel.org/pub/linux/utils/util-linux/v2.19/%{name}-%{version}.tar.bz2
-# Source0-md5: 3eab06f05163dfa65479c44e5231932c
+Source0:       http://ftp.kernel.org/pub/linux/utils/util-linux/v2.20/%{name}-%{version}.tar.bz2
+# Source0-md5: 4dcacdbdafa116635e52b977d9d0e879
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 3c940c7e7fe699eaa2ddb1bffb3de2fe
 Source2:       login.pamd
 Source3:       %{name}-blockdev.init
 Source4:       %{name}-blockdev.sysconfig
-Patch0:                %{name}-ng-ppc.patch
 Patch1:                %{name}-ng-union-mount.patch
 Patch2:                %{name}-ctrlaltdel-man.patch
 Patch3:                %{name}-fdformat-ide.patch
@@ -614,13 +613,12 @@ etykietę lub UUID - statycznie skonsolidowane na potrzeby initrd.
 
 %prep
 %setup -q -a1
-%patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
+#%patch6 -p1
 %patch7 -p1
 %patch8 -p1
 %patch9 -p1
@@ -670,7 +668,7 @@ sed -i -e 's/#define HAVE_WIDECHAR 1//' config.h
 
 sed -i -e 's/ cal\$(EXEEXT) / /; s/ lsblk\$(EXEEXT)//' misc-utils/Makefile
 
-for dir in shlibs/* disk-utils misc-utils fsck fdisk schedutils hwclock; do
+for dir in libblkid libmount libuuid disk-utils misc-utils fsck fdisk schedutils hwclock; do
        %{__make} -C $dir \
        %if %{with uClibc}
                LDFLAGS="-Wl,-static"
@@ -693,6 +691,8 @@ done
        --disable-silent-rules \
        --disable-use-tty-group \
        --disable-wall \
+       --enable-ddate \
+       --enable-line \
        --enable-kill \
        --enable-login-chown-vcs \
        --enable-login-utils \
@@ -765,7 +765,7 @@ install -p initrd%{_sbindir}/* $RPM_BUILD_ROOT%{_libdir}/initrd/
 ln -s fsck $RPM_BUILD_ROOT%{_libdir}/initrd/e2fsck
 
 # We don't need those
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/initrd/{chkdupexe,ddate,uuidd,mcookie,whereis,mkfs*,fsck.minix,isosize,logger}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/initrd/{chkdupexe,uuidd,mcookie,whereis,mkfs*,fsck.minix,isosize,logger}
 
 %if %{with dietlibc}
 cp -a initrd%{_libdir}/lib*.a $RPM_BUILD_ROOT%{dietlibdir}
@@ -1223,11 +1223,14 @@ fi
 %files -n mount
 %defattr(644,root,root,755)
 %attr(4755,root,root) /bin/mount
+%attr(755,root,root) /bin/mountpoint
 %attr(4755,root,root) /bin/umount
 %attr(755,root,root) /sbin/pivot_root
 %attr(755,root,root) /sbin/swapon
 %attr(755,root,root) /sbin/swapoff
 
+%{_mandir}/man1/mountpoint.1*
+
 %{_mandir}/man5/fstab.5*
 
 %{_mandir}/man8/mount.8*
This page took 0.074668 seconds and 4 git commands to generate.