]> git.pld-linux.org Git - packages/util-linux.git/commitdiff
- updated to 2.13-pre7
authorJan Rękorajski <baggins@pld-linux.org>
Thu, 22 Mar 2007 23:23:29 +0000 (23:23 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    util-linux-amd64.patch -> 1.2
    util-linux-dm_crypt.patch -> 1.4
    util-linux-fhs.patch -> 1.6
    util-linux-raw.patch -> 1.6

util-linux-amd64.patch
util-linux-dm_crypt.patch
util-linux-fhs.patch
util-linux-raw.patch

index 01b5216aaa8291f326dd45949f3b07812a357d89..eb6da062f88e69424da56e9d6ed3e4055e2f9a9f 100644 (file)
@@ -1,15 +1,3 @@
-diff -urN util-linux-2.12.org/fdisk/llseek.c util-linux-2.12/fdisk/llseek.c
---- util-linux-2.12.org/fdisk/llseek.c 2003-11-16 15:32:12.000000000 +0100
-+++ util-linux-2.12/fdisk/llseek.c     2003-11-16 15:32:36.000000000 +0100
-@@ -19,7 +19,7 @@
- #else /* HAVE_LLSEEK */
--#if defined(__alpha__) || defined(__ia64__) || defined(__s390x__)
-+#if defined(__alpha__) || defined(__ia64__) || defined(__s390x__) || defined(__x86_64__)
- #define my_llseek lseek
 diff -urN util-linux-2.12.org/misc-utils/whereis.c util-linux-2.12/misc-utils/whereis.c
 --- util-linux-2.12.org/misc-utils/whereis.c   2003-11-16 15:32:12.000000000 +0100
 +++ util-linux-2.12/misc-utils/whereis.c       2003-11-16 15:32:43.000000000 +0100
index cddfbeae31e6639437ee01cf54512430e9530388..8483b36786a56095b6db68be331f85a62db783dd 100644 (file)
@@ -226,32 +226,31 @@ diff -urN util-linux-2.12q.org/mount/cryptsetup.h util-linux-2.12q/mount/cryptse
 +extern int set_crypt(char **, const char *, int, char **,
 +                   int, int *);
 +extern int del_crypt(const char *);
-diff -urN util-linux-2.12q.org/mount/Makefile util-linux-2.12q/mount/Makefile
---- util-linux-2.12q.org/mount/Makefile        2005-02-27 19:25:37.000000000 +0100
-+++ util-linux-2.12q/mount/Makefile    2005-02-27 19:27:21.000000000 +0100
-@@ -30,6 +30,7 @@
- MAYBE = pivot_root swapoff
+diff -urN util-linux-2.12q.org/mount/Makefile.am util-linux-2.12q/mount/Makefile.am
+--- util-linux-2.12q.org/mount/Makefile.am     2005-02-27 19:25:37.000000000 +0100
++++ util-linux-2.12q/mount/Makefile.am 2005-02-27 19:27:21.000000000 +0100
+@@ -9,17 +9,17 @@
  
- LO_OBJS = lomount.o $(LIB)/xstrncpy.o
-+CRYPT_OBJS = cryptsetup.o -lcryptsetup
- NFS_OBJS = nfsmount.o nfsmount_xdr.o nfsmount_clnt.o
- GEN_FILES = nfsmount.h nfsmount_xdr.c nfsmount_clnt.c
+ mount_SOURCES = mount.c fstab.c sundries.c xmalloc.c realpath.c mntent.c \
+       get_label_uuid.c mount_by_label.c mount_blkid.c mount_guess_fstype.c \
+-      getusername.c \
++      getusername.c cryptsetup.c \
+       nfsmount.c nfsmount_xdr.c nfsmount_clnt.c \
+       lomount.c
  
-@@ -49,12 +50,12 @@
+-mount_LDADD = $(top_srcdir)/lib/libenv.a $(top_srcdir)/lib/libsetproctitle.a
++mount_LDADD = $(top_srcdir)/lib/libenv.a $(top_srcdir)/lib/libsetproctitle.a -lcryptsetup
  
- mount: mount.o fstab.o sundries.o xmalloc.o realpath.o mntent.o version.o \
-        get_label_uuid.o mount_by_label.o mount_blkid.o mount_guess_fstype.o \
--       getusername.o $(LIB)/setproctitle.o $(LIB)/env.o $(NFS_OBJS) $(LO_OBJS)
-+       getusername.o $(LIB)/setproctitle.o $(LIB)/env.o $(NFS_OBJS) $(LO_OBJS) $(CRYPT_OBJS)
-       $(LINK) $^ -o $@ $(BLKID_LIB)
+ umount_SOURCES = umount.c fstab.c sundries.c xmalloc.c realpath.c mntent.c \
+       getusername.c get_label_uuid.c mount_by_label.c mount_blkid.c \
+-      lomount.c
++      lomount.c cryptsetup.c
  
- umount: umount.o fstab.o sundries.o xmalloc.o realpath.o mntent.o \
-       getusername.o get_label_uuid.o mount_by_label.o mount_blkid.o \
--      version.o $(LIB)/env.o $(LO_OBJS)
-+      version.o $(LIB)/env.o $(LO_OBJS) $(CRYPT_OBJS)
-       $(LINK) $^ -o $@ $(BLKID_LIB)
+-umount_LDADD = $(top_srcdir)/lib/libenv.a
++umount_LDADD = $(top_srcdir)/lib/libenv.a -lcryptsetup
  
- swapon:       swapon.o version.o xmalloc.o \
+ swapon_SOURCES = swapon.c xmalloc.c \
+       get_label_uuid.c mount_by_label.c mount_blkid.c
 diff -urN util-linux-2.12q.org/mount/mount.c util-linux-2.12q/mount/mount.c
 --- util-linux-2.12q.org/mount/mount.c 2004-12-21 23:00:36.000000000 +0100
 +++ util-linux-2.12q/mount/mount.c     2005-02-27 19:29:40.000000000 +0100
index 5b4f110899fbe0413f8de68a9b6ae1f80ed6dfea..24efd45765a937e90fd1ce31a49ec979b55d0822 100644 (file)
@@ -1,33 +1,12 @@
-diff -urN util-linux-2.11d.org/lib/pathnames.h util-linux-2.11d/lib/pathnames.h
---- util-linux-2.11d.org/lib/pathnames.h       Sun Jun  3 21:48:00 2001
-+++ util-linux-2.11d/lib/pathnames.h   Sun Jun  3 21:48:47 2001
-@@ -86,6 +86,10 @@
- #define LOGDIR                  "/var/log"
- #endif
-+#ifndef DATAMISCDIR
-+#define DATAMISCDIR              "/usr/share/misc"
-+#endif
-+
- #ifndef VARPATH
- #define VARPATH                       "/var"
- #endif
+diff -urN util-linux-2.11d.org/include/pathnames.h util-linux-2.11d/include/pathnames.h
+--- util-linux-2.11d.org/include/pathnames.h   Sun Jun  3 21:48:00 2001
++++ util-linux-2.11d/include/pathnames.h       Sun Jun  3 21:48:47 2001
 @@ -101,7 +105,7 @@
  #define SECURETTY             "/etc/securetty"
- #define _PATH_UTMP            "/var/run/utmpx"
- #define _PATH_WTMP            LOGDIR "/wtmpx"
+ #define _PATH_UTMP            "/var/run/utmp"
+ #define _PATH_WTMP            LOGDIR "/wtmp"
 -#define _PATH_WTMPLOCK                "/etc/wtmplock"
 +#define _PATH_WTMPLOCK                VARPATH "/lock/wtmplock"
  
  /* no more . in DEFPATH */
  #define       _PATH_DEFPATH           "/usr/local/bin:/bin:/usr/bin"
-@@ -110,7 +114,7 @@
- #define       _PATH_LASTLOG           LOGDIR "/lastlog"
- #ifndef _PATH_MAILDIR
--#define       _PATH_MAILDIR           VARPATH "/spool/mail"
-+#define       _PATH_MAILDIR           VARPATH "/mail"
- #endif
- #define       _PATH_MOTDFILE          "/etc/motd"
- #define       _PATH_NOLOGIN           "/etc/nologin"
-
index 8ccc49a7295f874f1b458aa914fb922d4e54eae2..5ebec01928381221b90fe4de0e1429ed80db8820 100644 (file)
@@ -1,28 +1,3 @@
-diff -ur util-linux-2.12q.org/configure util-linux-2.12q/configure
---- util-linux-2.12q.org/configure     2004-12-20 23:20:35.000000000 +0100
-+++ util-linux-2.12q/configure 2005-02-27 19:22:06.000000000 +0100
-@@ -45,6 +45,7 @@
- # 13. For nfsmount: does the output of rpcgen compile?
- # 14. For fsck.cramfs, mkfs.cramfs: do we have libz?
- # 15. For mount, do we have blkid?
-+# 16. For raw.c: does <sys/raw.h> exist?
- rm -f make_include defines.h
-@@ -662,6 +663,13 @@
- rm -f conftest conftest.c
- #
-+# 16. For raw.c: does <sys/raw.h> exist?
-+#
-+if ./testincl "sys/raw.h"; then
-+       echo "ADD_RAW=yes" >> make_include
-+fi
-+
-+#
- # 13. For nfsmount: does the output of rpcgen compile?
- #
- # On some systems the output of rpcgen compiles with warnings
 diff -ur util-linux-2.12q.org/disk-utils/raw.c util-linux-2.12q/disk-utils/raw.c
 --- util-linux-2.12q.org/disk-utils/raw.c      2002-03-08 23:58:37.000000000 +0100
 +++ util-linux-2.12q/disk-utils/raw.c  2005-02-27 19:21:29.000000000 +0100
This page took 0.105141 seconds and 4 git commands to generate.