]> git.pld-linux.org Git - packages/util-linux.git/commitdiff
- up to 2.21; initrd build fails with finding -lcompat
authorElan Ruusamäe <glen@pld-linux.org>
Mon, 5 Mar 2012 19:41:06 +0000 (19:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    util-linux-ctrlaltdel-man.patch -> 1.4
    util-linux-diet.patch -> 1.5
    util-linux-fhs.patch -> 1.9
    util-linux-login-lastlog.patch -> 1.4
    util-linux-pl.po-update.patch -> 1.5
    util-linux-swaponsymlink.patch -> 1.4
    util-linux.spec -> 1.337

util-linux-ctrlaltdel-man.patch [deleted file]
util-linux-diet.patch
util-linux-fhs.patch
util-linux-login-lastlog.patch
util-linux-pl.po-update.patch
util-linux-swaponsymlink.patch
util-linux.spec

diff --git a/util-linux-ctrlaltdel-man.patch b/util-linux-ctrlaltdel-man.patch
deleted file mode 100644 (file)
index 02f48b8..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
-- Non-existant simpleinit(8) mentioned in ctrlaltdel(8)
-
---- util-linux-2.13-pre6/sys-utils/ctrlaltdel.8.kzak   2006-08-10 12:23:53.000000000 +0200
-+++ util-linux-2.13-pre6/sys-utils/ctrlaltdel.8        2006-08-10 12:24:08.000000000 +0200
-@@ -32,7 +32,6 @@
- .SH FILES
- .I /etc/rc.local
- .SH "SEE ALSO"
--.BR simpleinit (8),
- .BR init (8)
- .SH AUTHOR
- Peter Orbaek (poe@daimi.aau.dk)
index 888bb533f66caca3a4235a039a6d68404ddd1c16..6e1930a840bc6d60b7d8deb9d20d24c82853a41b 100644 (file)
  
  static int do_scale_by_power (uintmax_t *x, int base, int power)
  {
---- util-linux-2.19/libmount/src/utils.c~      2011-01-24 23:46:29.000000000 +0100
-+++ util-linux-2.19/libmount/src/utils.c       2011-02-10 20:12:00.499611392 +0100
-@@ -398,7 +398,11 @@
-       int rc = -1;
-         struct passwd pwd;
-       struct passwd *pw;
-+#ifdef _SC_GETPW_R_SIZE_MAX
-       size_t sz = sysconf(_SC_GETPW_R_SIZE_MAX);
-+#else
-     size_t sz = 0;
-+#endif
-       char *buf;
-       if (!username || !uid)
-@@ -427,7 +431,11 @@
-       int rc = -1;
-         struct group grp;
-       struct group *gr;
-+#ifdef _SC_GETGR_R_SIZE_MAX
-       size_t sz = sysconf(_SC_GETGR_R_SIZE_MAX);
-+#else
-     size_t sz = 0;
-+#endif
-       char *buf;
-       if (!groupname || !gid)
+#--- util-linux-2.19/libmount/src/utils.c~     2011-01-24 23:46:29.000000000 +0100
+#+++ util-linux-2.19/libmount/src/utils.c      2011-02-10 20:12:00.499611392 +0100
+#@@ -398,7 +398,11 @@
+#      int rc = -1;
+#         struct passwd pwd;
+#      struct passwd *pw;
+#+#ifdef _SC_GETPW_R_SIZE_MAX
+#      size_t sz = sysconf(_SC_GETPW_R_SIZE_MAX);
+#+#else
+#+     size_t sz = 0;
+#+#endif
+#      char *buf;
+# 
+#      if (!username || !uid)
+#@@ -427,7 +431,11 @@
+#      int rc = -1;
+#         struct group grp;
+#      struct group *gr;
+#+#ifdef _SC_GETGR_R_SIZE_MAX
+#      size_t sz = sysconf(_SC_GETGR_R_SIZE_MAX);
+#+#else
+#+     size_t sz = 0;
+#+#endif
+#      char *buf;
+# 
+#      if (!groupname || !gid)
 --- util-linux-2.19/lib/at.c~  2011-01-31 16:43:47.000000000 +0100
 +++ util-linux-2.19/lib/at.c   2011-02-10 20:30:37.336797058 +0100
 @@ -7,6 +7,7 @@
        if (inst->lock >= 0) {
                int rc = -1;
  
---- util-linux-2.19/configure.ac~      2011-02-10 21:28:23.395401725 +0100
-+++ util-linux-2.19/configure.ac       2011-02-10 22:12:29.997898392 +0100
-@@ -188,6 +188,8 @@
+--- util-linux-2.21/configure.ac~      2012-02-24 12:53:35.000000000 +0200
++++ util-linux-2.21/configure.ac       2012-03-05 21:03:25.833675080 +0200
+@@ -263,6 +263,8 @@
        lchown \
        llseek \
        lseek64 \
 +      mkostemp \
 +      versionsort \
+       scandirat \
        strtoull \
        sysconf \
-       getdtablesize \
 --- util-linux-2.19/misc-utils/findfs.c~       2011-01-31 16:43:47.000000000 +0100
 +++ util-linux-2.19/misc-utils/findfs.c        2011-02-10 22:24:39.615735924 +0100
 @@ -12,6 +12,7 @@
  #include "nls.h"
  
  #define SCRIPT_MIN_DELAY 0.0001               /* from original sripreplay.pl */
---- util-linux-2.19/libmount/src/tab_parse.c~  2011-02-10 23:28:02.091461025 +0100
-+++ util-linux-2.19/libmount/src/tab_parse.c   2011-02-10 23:29:04.934794359 +0100
-@@ -422,7 +422,13 @@
-       /* TODO: it would be nice to have a scandir() implementaion that
-        *       is able to use already opened directory */
--      n = scandir(dirname, &namelist, NULL, versionsort);
-+      n = scandir(dirname, &namelist, NULL,
+--- util-linux-2.21/libmount/src/tab_parse.c~  2012-03-05 21:00:14.000000000 +0200
++++ util-linux-2.21/libmount/src/tab_parse.c   2012-03-05 21:05:27.562569076 +0200
+@@ -524,7 +524,13 @@
+       DIR *dir = NULL;
+       struct dirent **namelist = NULL;
+-      n = scandir(dirname, &namelist, mnt_table_parse_dir_filter, versionsort);
++      n = scandir(dirname, &namelist, mnt_table_parse_dir_filter,
 +#ifdef HAVE_VERSIONSORT
-+                      versionsort
++              versionsort
 +#else
-+                      alphasort
++              alphasort
 +#endif
-+                      );
++      );
        if (n <= 0)
                return 0;
  
index 7435782345e38ba528cd8330ee4f48389a3d2688..7bbb01f7c934646a1951e3f4a23d177dcc61c677 100644 (file)
@@ -1,6 +1,6 @@
---- util-linux-ng-2.17.2/include/pathnames.h.orig      2010-03-22 09:05:42.000000000 +0100
-+++ util-linux-ng-2.17.2/include/pathnames.h   2010-05-09 10:46:42.934937584 +0200
-@@ -20,12 +20,12 @@
+--- util-linux-2.21/include/pathnames.h~       2011-12-18 22:28:28.000000000 +0200
++++ util-linux-2.21/include/pathnames.h        2012-03-05 17:32:49.986673893 +0200
+@@ -26,13 +26,13 @@
  #define       _PATH_DEFPATH_ROOT      "/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin"
  
  #define _PATH_SECURETTY               "/etc/securetty"
@@ -8,6 +8,7 @@
 +#define _PATH_WTMPLOCK                "/var/lock/wtmplock"
  
  #define       _PATH_HUSHLOGIN         ".hushlogin"
+ #define       _PATH_HUSHLOGINS        "/etc/hushlogins"
  
  #ifndef _PATH_MAILDIR
 -#define       _PATH_MAILDIR           "/var/spool/mail"
  #endif
  #define       _PATH_MOTDFILE          "/etc/motd"
  #define       _PATH_NOLOGIN           "/etc/nologin"
+--- util-linux-2.21/login-utils/login.1~       2012-02-10 15:45:52.000000000 +0200
++++ util-linux-2.21/login-utils/login.1        2012-03-05 18:07:04.386917212 +0200
+@@ -223,7 +223,7 @@
+ .I /var/run/utmp
+ .I /var/log/wtmp
+ .I /var/log/lastlog
+-.I /var/spool/mail/*
++.I /var/mail/*
+ .I /etc/motd
+ .I /etc/passwd
+ .I /etc/nologin
index 733326c5957690ef29035cb1e70f767bfb8c1e32..f0cb1e035f1c76874e24a31a4777ed7fd0d24070 100644 (file)
@@ -1,11 +1,11 @@
---- util-linux-ng-2.17.2/login-utils/login.c.orig      2010-03-18 23:11:23.000000000 +0100
-+++ util-linux-ng-2.17.2/login-utils/login.c   2010-05-09 11:42:42.890935908 +0200
-@@ -1431,7 +1431,7 @@
-     struct lastlog ll;
-     int fd;
+--- util-linux-2.21/login-utils/login.c~       2012-02-10 16:16:07.000000000 +0200
++++ util-linux-2.21/login-utils/login.c        2012-03-05 17:33:34.932052369 +0200
+@@ -503,7 +503,7 @@
+       if (!cxt->pwd)
+               return;
+-      fd = open(_PATH_LASTLOG, O_RDWR, 0);
++      fd = open(_PATH_LASTLOG, O_RDWR|O_CREAT, 0);
+       if (fd < 0)
+               return;
  
--    if ((fd = open(_PATH_LASTLOG, O_RDWR, 0)) >= 0) {
-+    if ((fd = open(_PATH_LASTLOG, O_RDWR|O_CREAT, 0)) >= 0) {
-       lseek(fd, (off_t)pwd->pw_uid * sizeof(ll), SEEK_SET);
-       if (!quiet) {
-           if (read(fd, (char *)&ll, sizeof(ll)) == sizeof(ll) &&
index 7b5d75d29f2c0eca8abc0c8e1d6563a0db5a7e8e..9c5b157dc14467fc522108af59b117c7e96527e2 100644 (file)
@@ -1,54 +1,11 @@
---- util-linux-2.20.1/po/pl.po.orig    2011-10-20 10:13:15.000000000 +0200
-+++ util-linux-2.20.1/po/pl.po 2011-12-03 08:40:19.058372761 +0100
-@@ -6,10 +6,10 @@
- #
- msgid ""
+--- util-linux-2.21/po/pl.po~  2012-02-24 12:35:23.000000000 +0200
++++ util-linux-2.21/po/pl.po   2012-03-05 21:36:38.404584366 +0200
+@@ -13376,7 +13376,7 @@
+ " -3, --3gb                limits the used address space to a maximum of 3 "
+ "GB\n"
+ "     --4gb                ignored (for backward compatibility only)\n"
+-"     --uname-2.6          turns on UNAME26\n"
++"     --uname-2.6          w³±czenie UNAME26\n"
  msgstr ""
--"Project-Id-Version: util-linux 2.20-rc2\n"
-+"Project-Id-Version: util-linux 2.20.1\n"
- "Report-Msgid-Bugs-To: util-linux@vger.kernel.org\n"
- "POT-Creation-Date: 2011-10-20 10:13+0200\n"
--"PO-Revision-Date: 2011-08-20 21:22+0200\n"
-+"PO-Revision-Date: 2011-12-03 08:35+0100\n"
- "Last-Translator: Jakub Bogusz <qboosh@pld-linux.org>\n"
- "Language-Team: Polish <translation-team-pl@lists.sourceforge.net>\n"
- "Language: pl\n"
-@@ -5499,12 +5499,12 @@
- msgstr "Uwaga: partycje %s i %s zachodz± na siebie\n"
- #: fdisk/sfdisk.c:1260
--#, fuzzy, c-format
-+#, c-format
- msgid ""
- "Warning: partition %s contains part of the partition table (sector %llu),\n"
- "and will destroy it when filled\n"
- msgstr ""
--"Uwaga: partycja %s zawiera czê¶æ tablicy partycji (sektor %lu)\n"
-+"Uwaga: partycja %s zawiera czê¶æ tablicy partycji (sektor %llu)\n"
- "i zostanie zniszczona po jej wype³nieniu\n"
- #: fdisk/sfdisk.c:1273
-@@ -11524,13 +11524,12 @@
- " -v, --verbose       wypisanie liczby usuniêtych bajtów\n"
- #: sys-utils/fstrim.c:66
--#, fuzzy
- msgid ""
- "\n"
- "For more information see fstrim(8).\n"
- msgstr ""
- "\n"
--"Wiêcej informacji w fstrim(1).\n"
-+"Wiêcej informacji w fstrim(8).\n"
- #: sys-utils/fstrim.c:102
- #, c-format
-@@ -12899,7 +12898,7 @@
- #: sys-utils/setarch.c:137
- #, c-format
- msgid "     --uname-2.6          turns on UNAME26\n"
--msgstr ""
-+msgstr "     --uname-2.6          w³±czenie UNAME26\n"
- #: sys-utils/setarch.c:139
- #, c-format
+ " -v, --verbose            szczegó³owa informacja o w³±czanych opcjach\n"
+ " -R, --addr-no-randomize  wy³±czenie losowo¶ci wirtualnej przestrzeni "
index a6d0a6a735b904f1bd4758c6bb3b634750cb6319..a5200c6526f0b84bd77e1c570774844410b2feff 100644 (file)
@@ -2,8 +2,8 @@ When swap is a symlink, the swap entry in
 /etc/fstab may not match /proc/swaps. That
 means strcmp shouldn't be used for swapon.
 
---- util-linux-2.12p/mount/swapon.c.sopwith    Wed Dec 22 04:50:19 2004
-+++ util-linux-2.12p/mount/swapon.c    Thu Dec 23 14:44:49 2004
+--- util-linux-2.12p/sys-utils/swapon.c.sopwith        Wed Dec 22 04:50:19 2004
++++ util-linux-2.12p/sys-utils/swapon.c        Thu Dec 23 14:44:49 2004
 @@ -138,9 +138,19 @@
  is_in_proc_swaps(const char *fname) {
        int i;
index 1da435dad1d0ff1412c765b6ab39993ab7342d64..950f531a7fd30d7126913b9e8a37bf487bd8b5f9 100644 (file)
@@ -1,3 +1,13 @@
+# TODO
+# - follow readprofile.1 -> redprofile.8 change in translated manuals as well
+#   /sbin/chcpu
+#   /sbin/raw
+#   /usr/bin/prlimit
+#   /usr/share/getopt/getopt-parse.bash
+#   /usr/share/getopt/getopt-parse.tcsh
+#   /usr/share/man/man1/prlimit.1.gz
+#   /usr/share/man/man8/chcpu.8.gz
+#   /usr/share/man/man8/raw.8.gz
 #
 # Conditional build:
 %bcond_with    uClibc          # link initrd version with static glibc instead of uClibc
@@ -29,13 +39,12 @@ Summary(ru.UTF-8):  Набор базовых системных утилит д
 Summary(tr.UTF-8):     Temel sistem araçları
 Summary(uk.UTF-8):     Набір базових системних утиліт для Linux
 Name:          util-linux
-Version:       2.20.1
-Release:       4
+Version:       2.21
+Release:       0.3
 License:       GPL
 Group:         Applications/System
-#Source0:      http://ftp.kernel.org/pub/linux/utils/util-linux/v2.20/%{name}-%{version}.tar.bz2
-Source0:       ftp://ftp.infradead.org/pub/util-linux/v2.20/%{name}-%{version}.tar.bz2
-# Source0-md5: 079b37517fd4e002a2e6e992e8b4e361
+Source0:       https://www.kernel.org/pub/linux/utils/util-linux/v2.21/%{name}-%{version}.tar.xz
+# Source0-md5: 208aa058f4117759d2939d1be7d662fc
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 3c940c7e7fe699eaa2ddb1bffb3de2fe
 Source2:       login.pamd
@@ -44,7 +53,6 @@ Source4:      %{name}-blockdev.sysconfig
 Source5:       blockdev.upstart
 Patch0:                %{name}-pl.po-update.patch
 Patch1:                %{name}-ng-union-mount.patch
-Patch2:                %{name}-ctrlaltdel-man.patch
 Patch3:                %{name}-fdformat-ide.patch
 Patch4:                %{name}-fhs.patch
 Patch5:                %{name}-hotkeys.patch
@@ -53,7 +61,8 @@ Patch8:               %{name}-procpartitions.patch
 Patch9:                %{name}-swaponsymlink.patch
 Patch10:       %{name}-diet.patch
 Patch11:       no-openat.patch
-Patch12:       %{name}-build.patch
+Patch12:       https://github.com/karelzak/util-linux/commit/2f595c001b4528b3b9a4aea04d72b6918c434efb.patch
+# Patch12-md5: 6671ea54ea50f49ef56e05a7b3c8bd37
 URL:           http://userweb.kernel.org/~kzak/util-linux/
 BuildRequires: audit-libs-devel >= 1.0.6
 BuildRequires: autoconf >= 2.60
@@ -71,6 +80,8 @@ BuildRequires:        pkgconfig
 BuildRequires: rpm >= 4.4.9-56
 BuildRequires: rpmbuild(macros) >= 1.470
 BuildRequires: sed >= 4.0
+BuildRequires: tar >= 1:1.22
+BuildRequires: xz
 BuildRequires: zlib-devel
 %if %{with initrd}
        %if %{with uClibc}
@@ -625,7 +636,6 @@ etykietę lub UUID - statycznie skonsolidowane na potrzeby initrd.
 %setup -q -a1
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
@@ -689,7 +699,7 @@ for dir in libblkid libuuid disk-utils misc-utils fsck fdisk schedutils hwclock;
                LDFLAGS="-lcompat"
        %endif
        # empty line required because there is a backslash up there
-       %{__make} -C $dir install DESTDIR=`pwd`/initrd
+       %{__make} -C $dir install DESTDIR=$(pwd)/initrd
 done
 
 %{__make} clean
@@ -724,8 +734,6 @@ install -d $RPM_BUILD_ROOT/etc/{pam.d,rc.d/init.d,sysconfig,init,security} \
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%{__sed} -i -e 's,/usr/spool/mail,/var/mail,g' $RPM_BUILD_ROOT%{_mandir}/man1/login.1
-
 %if %{with partx}
 mv $RPM_BUILD_ROOT%{_sbindir}/{addpart,delpart,partx} $RPM_BUILD_ROOT/sbin
 %endif
@@ -826,7 +834,7 @@ fi
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc */README.* text-utils/LICENSE.pg NEWS
+%doc */README.* NEWS
 
 %attr(755,root,root) /sbin/clock
 %attr(755,root,root) /sbin/hwclock*
@@ -961,7 +969,6 @@ fi
 %{_mandir}/man1/more.1*
 %{_mandir}/man1/namei.1*
 %{_mandir}/man1/pg.1*
-%{_mandir}/man1/readprofile.1*
 %{_mandir}/man1/renice.1*
 %{_mandir}/man1/rev.1*
 %{_mandir}/man1/rename.1*
@@ -989,6 +996,7 @@ fi
 %{_mandir}/man8/isosize.8*
 %{_mandir}/man8/ldattach.8*
 %{_mandir}/man8/mkswap.8*
+%{_mandir}/man8/readprofile.8*
 %{_mandir}/man8/rtcwake.8*
 %{_mandir}/man8/swaplabel.8*
 %if "%{pld_release}" != "ac"
This page took 0.144363 seconds and 4 git commands to generate.