]> git.pld-linux.org Git - packages/urxvt.git/blob - urxvt.spec
- added gcc 4.4 patch
[packages/urxvt.git] / urxvt.spec
1 #
2 # Conditional build:
3 #
4 %bcond_with     256colors # unsupported 256 colors patch (see FAQ)
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Rxvt terminal with unicode support and some improvements
7 Summary(pl.UTF-8):      Terminal Rxvt z obsługą unicode i kilkoma usprawnieniami
8 Name:           urxvt
9 Version:        9.06
10 Release:        1
11 License:        GPL v2+
12 Group:          X11/Applications
13 Source0:        http://dist.schmorp.de/rxvt-unicode/rxvt-unicode-%{version}.tar.bz2
14 # Source0-md5:  4cb9330e99fc0b0b05cebf3581557dd8
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-gcc44.patch
17 URL:            http://software.schmorp.de/
18 BuildRequires:  autoconf >= 2.50
19 BuildRequires:  fontconfig-devel
20 BuildRequires:  libstdc++-devel
21 BuildRequires:  perl-devel
22 BuildRequires:  sed >= 4.0
23 BuildRequires:  xorg-lib-libXext-devel
24 BuildRequires:  xorg-lib-libXft-devel
25 BuildRequires:  xorg-lib-libXpm-devel
26 BuildRequires:  zlib-devel
27 Requires:       terminfo
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 URxvt is a Rxvt modification which includes:
32 - unicode support
33 - xft font support (antialiasing)
34 - background pixmaps
35 - background tinting
36 - real transparency
37
38 %description -l pl.UTF-8
39 URxvt jest modyfikacją Rxvt uwzględniającą:
40 - obsługę unicode
41 - obsługę czcionek xft (antialiasing)
42 - możliwość ustawienia grafiki jako tła
43 - cieniowanie tła
44 - prawdziwą przezroczystość
45
46 %prep
47 %setup -q -n rxvt-unicode-%{version}
48 %patch0 -p1
49 %if %{with 256colors}
50 patch -p1 < doc/urxvt-8.2-256color.patch
51 %endif
52
53 %build
54 %{__autoheader}
55 %{__autoconf}
56 %configure \
57 %if %{with 256colors}
58         --enable-xterm-colors=256 \
59 %endif
60         --enable-everything \
61         --enable-mousewheel \
62         --enable-next-scroll \
63         --with-term=rxvt \
64         --enable-smart-resize
65
66 %{__make} \
67         CXXFLAGS="%{rpmcxxflags}" \
68         CFLAGS="%{rpmcxxflags}"
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %{__make} install \
74         DESTDIR=$RPM_BUILD_ROOT
75
76 install -d $RPM_BUILD_ROOT%{_desktopdir}
77 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
78 echo '.so urxvtc.1' >$RPM_BUILD_ROOT%{_mandir}/man1/urxvtd.1
79
80 %clean
81 rm -rf $RPM_BUILD_ROOT
82
83 %files
84 %defattr(644,root,root,755)
85 %doc Changes doc/README.xvt
86 %attr(755,root,root) %{_bindir}/urxvt*
87 %{_libdir}/%{name}
88 %{_desktopdir}/urxvt.desktop
89 %{_mandir}/man1/urxvt*.1*
90 %{_mandir}/man3/urxvtperl.3*
91 %{_mandir}/man7/urxvt.7*
This page took 0.067809 seconds and 4 git commands to generate.