]> git.pld-linux.org Git - packages/uriparser.git/blob - uriparser.spec
af3277c9582eabe8c4252bb6212eae1acfccdd69
[packages/uriparser.git] / uriparser.spec
1 #
2 # Conditional build
3 %bcond_without  doc     # disable generated documentation
4 %bcond_without  tests   # disable 'make check'
5 #
6 Summary:        A strictly RFC 3986 compliant URI parsing library
7 Summary(pl.UTF-8):      Biblioteka analizująca URI ściśle zgodne z RFC 3986
8 Name:           uriparser
9 Version:        0.9.0
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/uriparser/uriparser/releases
14 Source0:        https://github.com/uriparser/uriparser/releases/download/%{name}-%{version}/%{name}-%{version}.tar.bz2
15 # Source0-md5:  16452063f65826f8d1b5fc3b13e71d3a
16 Patch0:         %{name}-doxygen.patch
17 URL:            https://uriparser.github.io/
18 BuildRequires:  autoconf >= 2.61
19 BuildRequires:  automake >= 1:1.10.1
20 %{?with_tests:BuildRequires:    gtest-devel >= 1.8.1-3}
21 %if %{with doc}
22 BuildRequires:  doxygen
23 BuildRequires:  graphviz
24 %endif
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:2
27 BuildRequires:  pkgconfig >= 1:0.9.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 uriparser is a strictly RFC 3986 compliant URI parsing library.
32 uriparser is cross-platform, fast, supports Unicode.
33
34 %description -l pl.UTF-8
35 uriparser to biblioteka analizująca URI ściśle zgodne z RFC 3986. Jest
36 wieloplatformowa, szybka i obsługuje Unicode.
37
38 %package devel
39 Summary:        Header files for uriparser
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki uriparser
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for uriparser.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki uriparser.
49
50 %package static
51 Summary:        Static uriparser library
52 Summary(pl.UTF-8):      Statyczna biblioteka uriparser
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static uriparser library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka uriparser.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__automake}
70 %{__autoheader}
71 %{__autoconf}
72 %configure \
73          %{!?with_doc:--disable-doc} \
74          %{!?with_tests:--disable-test}
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 %if %{with doc}
84 # packaged as %doc
85 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/uriparser
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %post   -p /sbin/ldconfig
92 %postun -p /sbin/ldconfig
93
94 %files
95 %defattr(644,root,root,755)
96 %doc AUTHORS COPYING ChangeLog THANKS
97 %attr(755,root,root) %{_bindir}/uriparse
98 %attr(755,root,root) %{_libdir}/liburiparser.so.*.*.*
99 %attr(755,root,root) %ghost %{_libdir}/liburiparser.so.1
100
101 %files devel
102 %defattr(644,root,root,755)
103 %if %{with doc}
104 %doc doc/html
105 %endif
106 %attr(755,root,root) %{_libdir}/liburiparser.so
107 %{_libdir}/liburiparser.la
108 %{_includedir}/uriparser
109 %{_pkgconfigdir}/liburiparser.pc
110
111 %files static
112 %defattr(644,root,root,755)
113 %{_libdir}/liburiparser.a
This page took 0.097552 seconds and 3 git commands to generate.