]> git.pld-linux.org Git - packages/uriparser.git/blob - uriparser.spec
12fa5ae8fda6ba5cf091845dd44f4252cde6f0bf
[packages/uriparser.git] / uriparser.spec
1 #
2 # Conditional build
3 %bcond_without  doc     # disable generated documentation
4 %bcond_without  tests   # disable 'make check'
5 #
6 Summary:        A strictly RFC 3986 compliant URI parsing library
7 Summary(pl.UTF-8):      Biblioteka analizująca URI ściśle zgodne z RFC 3986
8 Name:           uriparser
9 Version:        0.8.6
10 Release:        1
11 License:        BSD
12 Group:          Libraries
13 #Source0Download: https://github.com/uriparser/uriparser/releases
14 Source0:        https://github.com/uriparser/uriparser/releases/download/%{name}-%{version}/%{name}-%{version}.tar.bz2
15 # Source0-md5:  ce2507966df78e36ccf71782fc598a59
16 Patch0:         %{name}-doxygen.patch
17 URL:            https://uriparser.github.io/
18 BuildRequires:  autoconf >= 2.61
19 BuildRequires:  automake >= 1:1.10.1
20 %{?with_tests:BuildRequires:    cpptest-devel >= 1.1.0}
21 %if %{with doc}
22 BuildRequires:  doxygen
23 BuildRequires:  graphviz
24 %endif
25 BuildRequires:  libstdc++-devel
26 BuildRequires:  libtool >= 2:1.5
27 BuildRequires:  pkgconfig >= 1:0.9.0
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 uriparser is a strictly RFC 3986 compliant URI parsing library.
32 uriparser is cross-platform, fast, supports Unicode.
33
34 %description -l pl.UTF-8
35 uriparser to biblioteka analizująca URI ściśle zgodne z RFC 3986. Jest
36 wieloplatformowa, szybka i obsługuje Unicode.
37
38 %package devel
39 Summary:        Header files for uriparser
40 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki uriparser
41 Group:          Development/Libraries
42 Requires:       %{name} = %{version}-%{release}
43
44 %description devel
45 Header files for uriparser.
46
47 %description devel -l pl.UTF-8
48 Pliki nagłówkowe biblioteki uriparser.
49
50 %package static
51 Summary:        Static uriparser library
52 Summary(pl.UTF-8):      Statyczna biblioteka uriparser
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static uriparser library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka uriparser.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65
66 %build
67 %{__libtoolize}
68 %{__aclocal}
69 %{__automake}
70 %{__autoconf}
71 %configure \
72          %{!?with_doc:--disable-doc} \
73          %{!?with_tests:--disable-test}
74 %{__make}
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78
79 %{__make} install \
80         DESTDIR=$RPM_BUILD_ROOT
81
82 %if %{with doc}
83 # packaged as %doc
84 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/uriparser
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %post   -p /sbin/ldconfig
91 %postun -p /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc AUTHORS COPYING ChangeLog THANKS
96 %attr(755,root,root) %{_bindir}/uriparse
97 %attr(755,root,root) %{_libdir}/liburiparser.so.*.*.*
98 %attr(755,root,root) %ghost %{_libdir}/liburiparser.so.1
99
100 %files devel
101 %defattr(644,root,root,755)
102 %if %{with doc}
103 %doc doc/html
104 %endif
105 %attr(755,root,root) %{_libdir}/liburiparser.so
106 %{_libdir}/liburiparser.la
107 %{_includedir}/uriparser
108 %{_pkgconfigdir}/liburiparser.pc
109
110 %files static
111 %defattr(644,root,root,755)
112 %{_libdir}/liburiparser.a
This page took 0.095589 seconds and 3 git commands to generate.