]> git.pld-linux.org Git - packages/uhd.git/blobdiff - uhd.spec
new sonames
[packages/uhd.git] / uhd.spec
index c72f106159824d4c3b1be2905643638ff57cc842..3a154a7091d3646a2cabef4bfa536536841892aa 100644 (file)
--- a/uhd.spec
+++ b/uhd.spec
@@ -1,17 +1,18 @@
 #
 # Conditional build
 %bcond_without mpm     # Module Peripheral Manager (run on embedded devices)
+%bcond_with    tests   # build tests
 
 Summary:       Universal Hardware Driver for Ettus Research products
 Summary(pl.UTF-8):     Uniwersalny sterownik sprzętowy do produktów Ettus Research
 Name:          uhd
-Version:       3.15.0.0
+Version:       4.1.0.1
 Release:       1
 License:       GPL v3+
 Group:         Applications/System
 #Source0Download: https://github.com/EttusResearch/uhd/releases
 Source0:       https://github.com/EttusResearch/uhd/archive/v%{version}/%{name}-%{version}.tar.gz
-# Source0-md5: cf589d5130ebd8348e3dbf129a7c5c38
+# Source0-md5: a05185b631e7f0491d76d75a2568219e
 Patch0:                %{name}-boost.patch
 Patch1:                %{name}-libdir.patch
 Patch2:                %{name}-link.patch
@@ -31,6 +32,7 @@ BuildRequires:        python3-devel >= 1:3.5
 BuildRequires: python3-numpy >= 1.7
 BuildRequires: python3-requests >= 2.0
 BuildRequires: rpm-pythonprov
+BuildRequires: rpmbuild(macros) >= 1.742
 %if %{with mpm}
 BuildRequires: udev-devel
 %endif
@@ -160,21 +162,22 @@ Biblioteka USRP Module Peripheral Manager dla Pythona.
 
 %prep
 %setup -q
-%patch0 -p1
+#%patch0 -p1
 %patch1 -p1
-%patch2 -p1
+#%patch2 -p1
 %patch3 -p1
 
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' host/examples/python/*.py
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' host/utils/{converter_benchmark.py,usrp2_{card_burner,card_burner_gui,recovery}.py}
 %{__sed} -i -e '1s,/usr/bin/env python$,%{__python},' host/utils/latency/graph.py
-%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' mpm/python/{n3xx_bist,usrp_hwd.py,usrp_update_fs}
-%{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' mpm/tools/mpm_{debug,shell}.py
+grep -rl '/usr/bin/env python3' . | xargs %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},'
 
 %build
 install -d build-{host,mpm}
 cd build-host
 %cmake ../host \
+       -DUHD_VERSION="%{version}" \
+       %{cmake_on_off tests ENABLE_TESTS} \
        -DENABLE_USB=ON
 
 %{__make}
@@ -196,9 +199,11 @@ rm -rf $RPM_BUILD_ROOT
 
 # outdated (binaries removed)
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{octoclock_firmware_burner,usrp_n2xx_simple_net_burner,usrp_x3xx_fpga_burner}.1*
+%if %{with tests}
 # not packaging tests
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/tests \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/utils/latency/run_tests.py
+%endif
 # packaged as %doc
 %{__rm} $RPM_BUILD_ROOT%{_docdir}/uhd/{LICENSE,README.md}
 
@@ -262,7 +267,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libuhd.so.3.15.0
+%attr(755,root,root) %{_libdir}/libuhd.so.4.1.0
 %dir %{_libdir}/%{name}
 
 %files devel
@@ -311,7 +316,7 @@ rm -rf $RPM_BUILD_ROOT
 %files mpm-libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libusrp-periphs.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libusrp-periphs.so.3
+%attr(755,root,root) %ghost %{_libdir}/libusrp-periphs.so.4
 
 %files mpm-devel
 %defattr(644,root,root,755)
This page took 0.089086 seconds and 4 git commands to generate.