]> git.pld-linux.org Git - packages/ufraw.git/blob - ufraw.spec
- rebuild with exiv2 0.26
[packages/ufraw.git] / ufraw.spec
1 #
2 # Conditional build:
3 %bcond_without  gimp            # GIMP plugin
4 %bcond_without  openmp          # OpenMP support
5 #
6 Summary:        RAW photo loader
7 Summary(pl.UTF-8):      Narzędzie do wczytywania zdjęć w formacie RAW
8 Name:           ufraw
9 Version:        0.22
10 Release:        6
11 License:        GPL v2+
12 Group:          Applications/Graphics
13 Source0:        http://downloads.sourceforge.net/ufraw/%{name}-%{version}.tar.gz
14 # Source0-md5:  c30767cae2c44310f2a3d67d7a76f2c3
15 URL:            http://ufraw.sourceforge.net/
16 BuildRequires:  automake
17 BuildRequires:  bzip2-devel
18 BuildRequires:  cfitsio-devel
19 BuildRequires:  exiv2-devel >= 0.20
20 %{?with_openmp:BuildRequires:   gcc-c++ >= 6:4.2}
21 BuildRequires:  gettext-tools
22 %{?with_gimp:BuildRequires:     gimp-devel >= 2.6.0}
23 BuildRequires:  glib2-devel >= 1:2.12
24 BuildRequires:  gtk+2-devel >= 2:2.12
25 BuildRequires:  gtkimageview-devel >= 1.6
26 BuildRequires:  jasper-devel
27 BuildRequires:  lcms2-devel >= 2
28 BuildRequires:  lensfun-devel >= 0.2.5
29 %{?with_openmp:BuildRequires:   libgomp-devel}
30 BuildRequires:  libjpeg-devel
31 BuildRequires:  libpng-devel >= 1.2
32 BuildRequires:  libstdc++-devel
33 BuildRequires:  libtiff-devel >= 4
34 BuildRequires:  perl-tools-pod
35 BuildRequires:  pkgconfig >= 1:0.9.0
36 BuildRequires:  zlib-devel
37 Requires(post,postun):  desktop-file-utils
38 Requires(post,postun):  shared-mime-info >= 0.21
39 Requires(post,preun):   GConf2 >= 2.16.0
40 Requires:       exiv2-libs >= 0.20
41 Requires:       glib2 >= 1:2.12
42 Requires:       gtk+2 >= 1:2.12
43 Requires:       gtkimageview >= 1.6
44 Requires:       lcms2 >= 2
45 Requires:       lensfun >= 0.2.5
46 Obsoletes:      cinepaint-plugin-ufraw
47 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
48
49 %if %{with gimp}
50 %define         gimp_plugindir          %(gimptool --gimpplugindir)/plug-ins
51 %endif
52
53 %description
54 UFRaw is a utility to read and manipulate raw images from digital
55 cameras. It can be used by itself or as a GIMP plug-in. It reads raw
56 images using Dave Coffin's raw conversion utility DCRaw. And it
57 supports basic color management using Little CMS, allowing the user to
58 apply color profiles.
59
60 %description -l pl.UTF-8
61 UFRaw to narzędzie do czytania i przetwarzania zdjęć w formacie RAW
62 różnych aparatów cyfrowych. Może być używane samodzielnie lub jako
63 wtyczka programu GIMP. Zdjęcia w formacie RAW są wczytywane za pomocą
64 programu DCRaw Dave'a Coffina. Użytkownik ma możliwość stosowania
65 profili kolorów dzięki bibliotece Little CMS.
66
67 %package batch
68 Summary:        RAW photo loader batch software
69 Summary(pl.UTF-8):      Program do wsadowego przetwarzania zdjęć w formacie RAW
70 Group:          Applications/Graphics
71 Requires:       exiv2 >= 0.20
72 Requires:       glib2 >= 1:2.12
73 Requires:       lcms2 >= 2
74 Requires:       lensfun >= 0.2.5
75
76 %description batch
77 RAW photo loader batch software.
78
79 %description batch -l pl.UTF-8
80 Program do wsadowego przetwarzania zdjęć w formacie RAW.
81
82 %package -n gimp-plugin-ufraw
83 Summary:        RAW photo loader GIMP plugin
84 Summary(pl.UTF-8):      Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW
85 Group:          Applications/Graphics
86 Requires:       exiv2 >= 0.20
87 Requires:       gimp >= 2.6.0
88 Requires:       glib2 >= 1:2.12
89 Requires:       gtk+2 >= 1:2.12
90 Requires:       gtkimageview >= 1.6
91 Requires:       lcms2 >= 2
92 Requires:       lensfun >= 0.2.5
93
94 %description -n gimp-plugin-ufraw
95 RAW photo loader GIMP plugin.
96
97 %description -n gimp-plugin-ufraw -l pl.UTF-8
98 Wtyczka GIMP-a do wczytywania zdjęć w formacie RAW.
99
100 %prep
101 %setup -q
102
103 %build
104 cp -f /usr/share/automake/mkinstalldirs .
105 %configure \
106         --disable-silent-rules \
107         %{!?with_openmp:--disable-openmp} \
108         --enable-contrast \
109         --enable-dst-correction \
110         --enable-extras \
111         --enable-mime \
112         --with-gimp%{!?with_gimp:=no} \
113         --with-gtk
114
115 %{__make}
116
117 %install
118 rm -rf $RPM_BUILD_ROOT
119 install -d $RPM_BUILD_ROOT%{_desktopdir}
120
121 %{__make} install \
122         DESTDIR=$RPM_BUILD_ROOT \
123         schemasdir=%{_sysconfdir}/gconf/schemas
124
125 install ufraw.desktop $RPM_BUILD_ROOT%{_desktopdir}
126 %{__rm} $RPM_BUILD_ROOT%{_bindir}/dcraw
127
128 %find_lang %{name}
129
130 %clean
131 rm -rf $RPM_BUILD_ROOT
132
133 %post
134 %gconf_schema_install ufraw.schemas
135 %update_desktop_database_post
136
137 %preun
138 %gconf_schema_uninstall ufraw.schemas
139
140 %postun
141 %update_desktop_database_postun
142
143 %files -f %{name}.lang
144 %defattr(644,root,root,755)
145 %doc README TODO
146 %attr(755,root,root) %{_bindir}/nikon-curve
147 %attr(755,root,root) %{_bindir}/ufraw
148 %{_desktopdir}/ufraw.desktop
149 %{_pixmapsdir}/ufraw.png
150 %{_sysconfdir}/gconf/schemas/%{name}.schemas
151 %{_datadir}/appdata/ufraw.appdata.xml
152 %{_mandir}/man1/ufraw.1*
153
154 %files batch
155 %defattr(644,root,root,755)
156 %attr(755,root,root) %{_bindir}/ufraw-batch
157
158 %if %{with gimp}
159 %files -n gimp-plugin-ufraw
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{gimp_plugindir}/ufraw-gimp
162 %endif
This page took 0.089572 seconds and 3 git commands to generate.