]> git.pld-linux.org Git - packages/uboot.git/blob - uboot.spec
- release 2
[packages/uboot.git] / uboot.spec
1 Summary:        Das U-Boot -- the Universal Boot Loader
2 Name:           uboot
3 Version:        2009.01
4 Release:        2
5 License:        GPL
6 Group:          Applications/System
7 Source0:        ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
8 # Source0-md5:  cb11d3d74eee4d31124523d90d8c31fa
9 URL:            http://www.denx.de/wiki/U-Boot
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Das U-Boot (Universal Bootloader, German for "the submarine") is a
14 boot loader for a number of different computer architectures,
15 including PPC, ARM, AVR32, MIPS, x86, 68k, Nios, and MicroBlaze.
16
17 %package mkimage
18 Summary:        Generate kernel image for U-Boot
19 Group:          Applications/System
20
21 %description mkimage
22 This package contains the mkimage utility, which encapsulates a
23 compressed "uImage" Linux kerel image with header information, CRC32
24 checksum, etc, for use with the U-Boot bootloader.
25
26 mkimage can also be used to create ramdisk images for use with U-Boot,
27 either separated from the Linux kernel image, or combined into one
28 file. mkimage encapsulates the images with a 64 byte header containing
29 information about target architecture, operating system, image type,
30 compression method, entry points, time stamp, CRC32 checksums, etc.
31
32 %prep
33 %setup -q -n u-boot-%{version}
34
35 %build
36 touch include/config.mk include/config.h
37
38 %{__make} tools \
39         HOSTSTRIP=echo \
40         HOST_CFLAGS="%{rpmcflags}" \
41         HOST_LDFLAGS="%{rpmldflags}" \
42         BIN_FILES="bmp_logo gen_eth_addr img2srec mkimage"
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_bindir}
47
48 install tools/mkimage  $RPM_BUILD_ROOT%{_bindir}
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc CHANGELOG CHANGELOG-before-U-Boot-1.1.5 CREDITS MAINTAINERS README
56 # COPYING contains some extra note
57 %doc COPYING
58
59 %files mkimage
60 %defattr(644,root,root,755)
61 %attr(755,root,root) %{_bindir}/mkimage
This page took 0.13077 seconds and 3 git commands to generate.