]> git.pld-linux.org Git - packages/uboot.git/blob - uboot.spec
c085f8c945aab341c6a9ecafd489d551c2893e4f
[packages/uboot.git] / uboot.spec
1 Summary:        Das U-Boot -- the Universal Boot Loader
2 Name:           uboot
3 Version:        1.3.3
4 Release:        0.1
5 License:        GPL
6 Group:          Applications/System
7 Source0:        ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
8 # Source0-md5:  6ee26954bb548ad90392cd329ab5cc4c
9 URL:            http://www.denx.de/wiki/UBoot
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Das U-Boot (Universal Bootloader, German for "the submarine") is a
14 boot loader for a number of different computer architectures,
15 including PPC, ARM, AVR32, MIPS, x86, 68k, Nios, and MicroBlaze.
16
17 %package mkimage
18 Summary:        Generate kernel image for U-Boot
19 Group:          Applications/System
20
21 %description mkimage
22 This package contains the mkimage utility, which encapsulates a
23 compressed "uImage" Linux kerel image with header information, CRC32
24 checksum, etc, for use with the U-Boot bootloader.
25
26 mkimage can also be used to create ramdisk images for use with U-Boot,
27 either separated from the Linux kernel image, or combined into one
28 file. mkimage encapsulates the images with a 64 byte header containing
29 information about target architecture, operating system, image type,
30 compression method, entry points, time stamp, CRC32 checksums, etc.
31
32 %prep
33 %setup -q -n u-boot-%{version}
34
35 %build
36 touch include/config.mk include/config.h
37
38 %{__make} tools \
39         HOSTSTRIP=echo \
40         BIN_FILES="bmp_logo gen_eth_addr img2srec mkimage"
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_bindir}
45
46 install tools/mkimage  $RPM_BUILD_ROOT%{_bindir}
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc CHANGELOG CHANGELOG-before-U-Boot-1.1.5 CREDITS MAINTAINERS README
54 # COPYING contains some extra note
55 %doc COPYING
56
57 %files mkimage
58 %defattr(644,root,root,755)
59 %attr(755,root,root) %{_bindir}/mkimage
This page took 0.095876 seconds and 2 git commands to generate.