]> git.pld-linux.org Git - packages/uboot.git/blob - uboot.spec
b0649f35e9d5fba485ccc2ca5eab9ec401d38b06
[packages/uboot.git] / uboot.spec
1 Summary:        Das U-Boot -- the Universal Boot Loader
2 Name:           uboot
3 Version:        1.3.2
4 Release:        0.1
5 License:        GPL
6 Group:          Applications/System
7 Source0:        ftp://ftp.denx.de/pub/u-boot/u-boot-%{version}.tar.bz2
8 # Source0-md5:  78b1c2722d3907b5fae2cd219dbaf927
9 URL:            http://www.denx.de/wiki/UBoot
10 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
11
12 %description
13 Das U-Boot (Universal Bootloader, German for "the submarine") is a
14 boot loader for a number of different computer architectures,
15 including PPC, ARM, AVR32, MIPS, x86, 68k, Nios, and MicroBlaze.
16
17 %package mkimage
18 Summary:        Generate kernel image for U-Boot
19 Group:          Applications/System
20
21 %description mkimage
22 This package contains the mkimage utility, which encapsulates a
23 compressed "uImage" Linux kerel image with header information, CRC32
24 checksum, etc, for use with the U-Boot bootloader.
25
26 mkimage can also be used to create ramdisk images for use with U-Boot,
27 either separated from the Linux kernel image, or combined into one
28 file. mkimage encapsulates the images with a 64 byte header containing
29 information about target architecture, operating system, image type,
30 compression method, entry points, time stamp, CRC32 checksums, etc.
31
32 %prep
33 %setup -q -n u-boot-%{version}
34 ln -s ../lib_generic/crc32.c tools
35
36 %build
37 cd tools
38 %{__cc} %{rpmcflags} -DUSE_HOSTCC -c crc32.c -o crc32.o
39 %{__cc} %{rpmcflags} -I../include -c mkimage.c -o mkimage.o
40 %{__cc} %{rpmldflags} -o mkimage crc32.o mkimage.o
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT%{_bindir}
45 install tools/mkimage  $RPM_BUILD_ROOT%{_bindir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc CHANGELOG CHANGELOG-before-U-Boot-1.1.5 CREDITS MAINTAINERS README
53 # COPYING contains some extra note
54 %doc COPYING
55
56 %files mkimage
57 %defattr(644,root,root,755)
58 %attr(755,root,root) %{_bindir}/mkimage
This page took 0.066154 seconds and 2 git commands to generate.