]> git.pld-linux.org Git - packages/tzdata.git/blob - tzdata.spec
- updated to 2009t/2009u
[packages/tzdata.git] / tzdata.spec
1 #
2 # Conditional build
3 %bcond_without  tests                   # make check
4 #
5 %define         tzcode_ver      2009t
6 %define         tzdata_ver      2009u
7 Summary:        Timezone data
8 Summary(pl.UTF-8):      Dane o strefach czasowych
9 Name:           tzdata
10 Version:        %{tzdata_ver}
11 Release:        1
12 License:        Public Domain (database), BSD/LGPL v2.1+ (code/test suite)
13 Group:          Base
14 Source0:        %{name}-base-0.tar.bz2
15 # Source0-md5:  906a4c98cc5240f416524a256b039c42
16 Source1:        ftp://elsie.nci.nih.gov/pub/%{name}%{tzdata_ver}.tar.gz
17 # Source1-md5:  91355f66ab9bffe3d450357ff7a1189a
18 Source2:        ftp://elsie.nci.nih.gov/pub/tzcode%{tzcode_ver}.tar.gz
19 # Source2-md5:  17fe1e12237b11d490f62dcec4b4bc11
20 Source3:        timezone.init
21 Source4:        timezone.sysconfig
22 Patch0:         %{name}-test-update.patch
23 URL:            http://www.twinsun.com/tz/tz-link.htm
24 BuildRequires:  gawk
25 BuildRequires:  perl-base
26 BuildRequires:  rpmbuild(macros) >= 1.228
27 Requires(post,preun):   /sbin/chkconfig
28 Requires:       /sbin/chkconfig
29 Requires:       rc-scripts >= 0.4.1.4
30 BuildArch:      noarch
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 This package contains data files with rules for various timezones
35 around the world.
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera pliki z danymi na temat reguł stref czasowych na
39 całym świecie.
40
41 %package zoneinfo_right
42 Summary:        Non-POSIX (real) time zones
43 Summary(es.UTF-8):      Zonas de tiempo reales (no de POSIX)
44 Summary(pl.UTF-8):      Nie-POSIX-owe (prawdziwe) strefy czasowe
45 Group:          Libraries
46 Obsoletes:      glibc-zoneinfo_right
47
48 %description zoneinfo_right
49 You don't want this. Details at:
50 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
51
52 %description zoneinfo_right -l es.UTF-8
53 No lo necesita. Encontrará los detalles en:
54 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
55
56 %description zoneinfo_right -l pl.UTF-8
57 Nie potrzebujesz tego. Szczegóły pod:
58 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
59
60 %package devel
61 Summary:        tzfile header file
62 Summary(pl.UTF-8):      Plik nagłówkowy tzfile
63 Group:          Development/Libraries
64
65 %description devel
66 Header file for timezone database.
67
68 %description devel -l pl.UTF-8
69 Plik nagłówkowy bazy danych stref czasowych.
70
71 %prep
72 %setup -qc
73 mv tzdata/* .
74 %{__tar} xzf %{SOURCE1} -C tzdata
75 mkdir tzcode
76 %{__tar} xzf %{SOURCE2} -C tzcode
77 %patch0 -p1
78
79 sed -e "
80 s|@objpfx@|`pwd`/obj/|
81 s|@datadir@|%{_datadir}|
82 s|@install_root@|$RPM_BUILD_ROOT|
83 " Makeconfig.in > Makeconfig
84
85 grep -v tz-art.htm tzcode/tz-link.htm > tzcode/tz-link.html
86
87 %build
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
93 install -d $RPM_BUILD_ROOT%{_includedir}
94 install -d $RPM_BUILD_ROOT%{_mandir}/man5
95
96 %{__make} install
97
98 %if %{with tests}
99 : ====================TESTING=========================
100 %{__make} check \
101         CC="%{__cc}" \
102         CFLAGS="%{rpmcflags} %{rpmldflags}"
103 : ====================TESTING END=====================
104 %endif
105
106
107 # glibc.spec didn't keep it. so won't here either.
108 rm -rf $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posix
109 # behave more like glibc.spec
110 ln -sf %{_sysconfdir}/localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/localtime
111 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixtime
112 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixrules
113
114 > $RPM_BUILD_ROOT/etc/localtime
115
116 # header file
117 install tzcode/tzfile.h $RPM_BUILD_ROOT%{_includedir}/tzfile.h
118 install tzcode/tzfile.5 $RPM_BUILD_ROOT%{_mandir}/man5
119
120 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/timezone
121 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/timezone
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 /sbin/chkconfig --add timezone
128 %service timezone restart
129
130 %preun
131 if [ "$1" = "0" ]; then
132         /sbin/chkconfig --del timezone
133
134         # save for postun
135         cp -f /etc/localtime /etc/localtime.rpmsave
136 fi
137
138 %postun
139 if [ "$1" = "0" ]; then
140         if [ ! -f /etc/localtime -a -f /etc/localtime.rpmsave ]; then
141                 mv -f /etc/localtime{.rpmsave,}
142         fi
143 fi
144
145 %triggerpostun -- rc-scripts < 0.4.1.4
146 /sbin/chkconfig --add timezone
147
148 %triggerpostun -- tzdata < 2008b-4
149 if ! grep -q '^TIMEZONE=' /etc/sysconfig/timezone; then
150         . /etc/sysconfig/timezone
151
152         if [ -z $ZONE_INFO_AREA ]; then
153                 TIMEZONE=$TIME_ZONE
154         else
155                 TIMEZONE=$ZONE_INFO_AREA/$TIME_ZONE
156         fi
157
158         echo "TIMEZONE=\"$TIMEZONE\"" >> /etc/sysconfig/timezone
159
160         %service timezone restart
161 fi
162
163 %files
164 %defattr(644,root,root,755)
165 %doc tzcode/README tzcode/Theory tzcode/tz-link.html
166 %ghost /etc/localtime
167 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/timezone
168 %attr(754,root,root) /etc/rc.d/init.d/timezone
169
170 %{_datadir}/zoneinfo
171 %exclude %{_datadir}/zoneinfo/right
172
173 %files zoneinfo_right
174 %defattr(644,root,root,755)
175 %{_datadir}/zoneinfo/right
176
177 %files devel
178 %defattr(644,root,root,755)
179 %doc tzcode/tzfile.5.txt
180 %{_includedir}/tzfile.h
181 %{_mandir}/man5/tzfile.5*
This page took 0.052949 seconds and 3 git commands to generate.