]> git.pld-linux.org Git - packages/tzdata.git/blob - tzdata.spec
- R: chkconfig due rpm bugs
[packages/tzdata.git] / tzdata.spec
1 #
2 # Conditional build
3 %bcond_without  tests           # make check
4 %bcond_without  java            # build java subpackage
5
6 %if "%{pld_release}" == "ac"
7 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
8 %undefine       with_java
9 %endif
10 %endif
11
12 %define         tzcode_ver      2011i
13 %define         tzdata_ver      2011n
14 Summary:        Timezone data
15 Summary(pl.UTF-8):      Dane o strefach czasowych
16 Name:           tzdata
17 Version:        %{tzdata_ver}
18 Release:        1
19 License:        Public Domain (database), BSD/LGPL v2.1+ (code/test suite)
20 Group:          Base
21 # The tzdata-base-0.tar.bz2 is a simple building infrastructure and
22 # a test suite. It is occasionally updated from glibc sources, and as
23 # such is under LGPL v2+, but none of this ever gets to be part of
24 # final zoneinfo files.
25 Source0:        %{name}-base-0.tar.bz2
26 # Source0-md5:  e36d2f742c22f8c8dbf0686ac9769b55
27 # ftp://elsie.nci.nih.gov/pub/ has been shut down because of lawsuit
28 #Source1Download: http://www.iana.org/time-zones/
29 Source1:        http://www.iana.org/time-zones/repository/releases/%{name}%{tzdata_ver}.tar.gz
30 # Source1-md5:  20dbfb28efa008ddbf6dd34601ea40fa
31 #Source2Download: http://www.iana.org/time-zones/
32 Source2:        http://www.iana.org/time-zones/repository/releases/tzcode%{tzcode_ver}.tar.gz
33 # Source2-md5:  cf7f4335b7c8682899fa2814e711c1b2
34 Source3:        timezone.init
35 Source4:        timezone.sysconfig
36 Source5:        javazic.tar.gz
37 # Source5-md5:  6a3392cd5f1594d13c12c1a836ac8d91
38 Source6:        timezone.upstart
39 Patch1:         javazic-fixup.patch
40 Patch2:         install.patch
41 URL:            http://www.twinsun.com/tz/tz-link.htm
42 BuildRequires:  rpm >= 4.4.9-56
43 BuildRequires:  rpmbuild(macros) >= 1.300
44 %if %{with java}
45 BuildRequires:  jdk
46 BuildRequires:  jpackage-utils
47 BuildRequires:  rpm-javaprov
48 %endif
49 Requires:       /sbin/chkconfig
50 Requires:       rc-scripts >= 0.4.3.0
51 BuildArch:      noarch
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %description
55 This package contains data files with rules for various timezones
56 around the world.
57
58 %description -l pl.UTF-8
59 Ten pakiet zawiera pliki z danymi na temat reguł stref czasowych na
60 całym świecie.
61
62 %package -n java-tzdata
63 Summary:        Timezone data for Java
64 Summary(pl.UTF-8):      Dane stref czasowych dla Javy
65 Group:          Base
66
67 %description -n java-tzdata
68 This package contains timezone information for use by Java runtimes.
69
70 %description -n java-tzdata -l pl.UTF-8
71 Ten pakiet zawiera informacje o strefach czasowych przeznaczone dla
72 programów w Javie.
73
74 %package zoneinfo_right
75 Summary:        Non-POSIX (real) time zones
76 Summary(es.UTF-8):      Zonas de tiempo reales (no de POSIX)
77 Summary(pl.UTF-8):      Nie-POSIX-owe (prawdziwe) strefy czasowe
78 Group:          Libraries
79 Obsoletes:      glibc-zoneinfo_right
80
81 %description zoneinfo_right
82 You don't want this. Details at:
83 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
84
85 %description zoneinfo_right -l es.UTF-8
86 No lo necesita. Encontrará los detalles en:
87 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
88
89 %description zoneinfo_right -l pl.UTF-8
90 Nie potrzebujesz tego. Szczegóły pod:
91 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
92
93 %package devel
94 Summary:        tzfile header file
95 Summary(pl.UTF-8):      Plik nagłówkowy tzfile
96 Group:          Development/Libraries
97
98 %description devel
99 Header file for timezone database.
100
101 %description devel -l pl.UTF-8
102 Plik nagłówkowy bazy danych stref czasowych.
103
104 %prep
105 %setup -qc
106 mv tzdata/* .
107 %{__tar} xzf %{SOURCE1} -C tzdata
108 install -d tzcode
109 %{__tar} xzf %{SOURCE2} -C tzcode
110 %patch2 -p1
111
112 %{__sed} -e "
113 s|@objpfx@|`pwd`/obj/|
114 s|@datadir@|%{_datadir}|
115 s|@install_root@|$RPM_BUILD_ROOT|
116 " 'Makeconfig.in' > Makeconfig
117
118 grep -v tz-art.htm tzcode/tz-link.htm > tzcode/tz-link.html
119
120 %if %{with java}
121 install -d javazic
122 tar zxf %{SOURCE5} -C javazic
123 cd javazic
124 %patch1
125
126 # Hack alert! sun.tools may be defined and installed in the
127 # VM. In order to guarantee that we are using IcedTea/OpenJDK
128 # for creating the zoneinfo files, rebase all the packages
129 # from "sun." to "rht.". Unfortunately, gcj does not support
130 # any of the -Xclasspath options, so we must go this route
131 # to ensure the greatest compatibility.
132 # XXX: do we want 'pld' instead of 'rht'?
133 mv sun rht
134 find . -type f -name '*.java' -print0 \
135         | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
136                                                  -e 's:sun\.util\.:rht.util.:g'
137 cd -
138 %endif
139
140 %build
141 %{__make}
142
143 %if %{with java}
144 cd javazic
145 %javac -source 1.5 -target 1.5 -classpath . $(find -name '*.java')
146 cd ../tzdata
147 %java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
148         -d ../zoneinfo/java \
149         africa antarctica asia australasia europe northamerica pacificnew \
150         southamerica backward etcetera solar87 solar88 solar89 systemv \
151         ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
152 cd ..
153 %endif
154
155 %install
156 rm -rf $RPM_BUILD_ROOT
157 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_mandir}/man5,%{_includedir}}
158 %{__make} install
159
160 %if %{with tests}
161 # test needs to be ran after "make install", as it uses installed files
162 : ====================TESTING=========================
163 %{__make} check \
164         CC="%{__cc}" \
165         CFLAGS="%{rpmcflags} %{rpmldflags}"
166 : ====================TESTING END=====================
167 %endif
168
169 # glibc.spec didn't keep it. so won't here either.
170 rm -rf $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posix
171 # behave more like glibc.spec
172 ln -sf %{_sysconfdir}/localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/localtime
173 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixtime
174 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixrules
175
176 > $RPM_BUILD_ROOT/etc/localtime
177
178 # header file
179 cp -p tzcode/tzfile.h $RPM_BUILD_ROOT%{_includedir}/tzfile.h
180 cp -p tzcode/tzfile.5 $RPM_BUILD_ROOT%{_mandir}/man5
181
182 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/timezone
183 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/timezone
184
185 install -d $RPM_BUILD_ROOT/etc/init
186 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/init/timezone.conf
187
188 %if %{with java}
189 cp -a zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
190 %endif
191
192 %clean
193 rm -rf $RPM_BUILD_ROOT
194
195 %post
196 /sbin/chkconfig --add timezone
197 %service timezone restart
198
199 %preun
200 if [ "$1" = "0" ]; then
201         /sbin/chkconfig --del timezone
202
203         # save for postun
204         cp -f /etc/localtime /etc/localtime.rpmsave
205 fi
206
207 %postun
208 if [ "$1" = "0" ]; then
209         if [ ! -f /etc/localtime -a -f /etc/localtime.rpmsave ]; then
210                 mv -f /etc/localtime{.rpmsave,}
211         fi
212 fi
213
214 %triggerpostun -- rc-scripts < 0.4.1.4
215 /sbin/chkconfig --add timezone
216
217 %triggerpostun -- tzdata < 2008b-4
218 if ! grep -q '^TIMEZONE=' /etc/sysconfig/timezone; then
219         . /etc/sysconfig/timezone
220
221         if [ -z $ZONE_INFO_AREA ]; then
222                 TIMEZONE=$TIME_ZONE
223         else
224                 TIMEZONE=$ZONE_INFO_AREA/$TIME_ZONE
225         fi
226
227         echo "TIMEZONE=\"$TIMEZONE\"" >> /etc/sysconfig/timezone
228
229         %service timezone restart
230 fi
231
232 %files
233 %defattr(644,root,root,755)
234 %doc tzcode/README tzcode/Theory tzcode/tz-link.html
235 %ghost /etc/localtime
236 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/timezone
237 %attr(754,root,root) /etc/rc.d/init.d/timezone
238 %config(noreplace) %verify(not md5 mtime size) /etc/init/timezone.conf
239
240 %{_datadir}/zoneinfo
241 %exclude %{_datadir}/zoneinfo/right
242
243 %if %{with java}
244 %files -n java-tzdata
245 %defattr(644,root,root,755)
246 %{_datadir}/javazi
247 %endif
248
249 %files zoneinfo_right
250 %defattr(644,root,root,755)
251 %{_datadir}/zoneinfo/right
252
253 %files devel
254 %defattr(644,root,root,755)
255 %doc tzcode/tzfile.5.txt
256 %{_includedir}/tzfile.h
257 %{_mandir}/man5/tzfile.5*
This page took 0.878954 seconds and 3 git commands to generate.