]> git.pld-linux.org Git - packages/tzdata.git/blob - tzdata.spec
- update upstart deps
[packages/tzdata.git] / tzdata.spec
1 #
2 # Conditional build
3 %bcond_without  tests           # make check
4 %bcond_without  java            # build java subpackage
5
6 %if "%{pld_release}" == "ac"
7 %ifnarch i586 i686 pentium3 pentium4 athlon %{x8664}
8 %undefine       with_java
9 %endif
10 %endif
11
12 %define         tzcode_ver      2011i
13 %define         tzdata_ver      2011i
14 Summary:        Timezone data
15 Summary(pl.UTF-8):      Dane o strefach czasowych
16 Name:           tzdata
17 Version:        %{tzdata_ver}
18 Release:        1
19 License:        Public Domain (database), BSD/LGPL v2.1+ (code/test suite)
20 Group:          Base
21 # The tzdata-base-0.tar.bz2 is a simple building infrastructure and
22 # a test suite. It is occasionally updated from glibc sources, and as
23 # such is under LGPL v2+, but none of this ever gets to be part of
24 # final zoneinfo files.
25 Source0:        %{name}-base-0.tar.bz2
26 # Source0-md5:  e36d2f742c22f8c8dbf0686ac9769b55
27 Source1:        ftp://elsie.nci.nih.gov/pub/%{name}%{tzdata_ver}.tar.gz
28 # Source1-md5:  c7a86ec34f30f8d6aa77ef94902a3047
29 Source2:        ftp://elsie.nci.nih.gov/pub/tzcode%{tzcode_ver}.tar.gz
30 # Source2-md5:  cf7f4335b7c8682899fa2814e711c1b2
31 Source3:        timezone.init
32 Source4:        timezone.sysconfig
33 Source5:        javazic.tar.gz
34 # Source5-md5:  6a3392cd5f1594d13c12c1a836ac8d91
35 Source6:        timezone.upstart
36 Patch1:         javazic-fixup.patch
37 Patch2:         install.patch
38 URL:            http://www.twinsun.com/tz/tz-link.htm
39 BuildRequires:  rpm >= 4.4.9-56
40 BuildRequires:  rpmbuild(macros) >= 1.300
41 %if %{with java}
42 BuildRequires:  jdk
43 BuildRequires:  jpackage-utils
44 BuildRequires:  rpm-javaprov
45 %endif
46 Requires(post,preun):   /sbin/chkconfig
47 Requires:       rc-scripts >= 0.4.3.0
48 BuildArch:      noarch
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 This package contains data files with rules for various timezones
53 around the world.
54
55 %description -l pl.UTF-8
56 Ten pakiet zawiera pliki z danymi na temat reguł stref czasowych na
57 całym świecie.
58
59 %package -n java-tzdata
60 Summary:        Timezone data for Java
61 Summary(pl.UTF-8):      Dane stref czasowych dla Javy
62 Group:          Base
63
64 %description -n java-tzdata
65 This package contains timezone information for use by Java runtimes.
66
67 %description -n java-tzdata -l pl.UTF-8
68 Ten pakiet zawiera informacje o strefach czasowych przeznaczone dla
69 programów w Javie.
70
71 %package zoneinfo_right
72 Summary:        Non-POSIX (real) time zones
73 Summary(es.UTF-8):      Zonas de tiempo reales (no de POSIX)
74 Summary(pl.UTF-8):      Nie-POSIX-owe (prawdziwe) strefy czasowe
75 Group:          Libraries
76 Obsoletes:      glibc-zoneinfo_right
77
78 %description zoneinfo_right
79 You don't want this. Details at:
80 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
81
82 %description zoneinfo_right -l es.UTF-8
83 No lo necesita. Encontrará los detalles en:
84 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
85
86 %description zoneinfo_right -l pl.UTF-8
87 Nie potrzebujesz tego. Szczegóły pod:
88 <http://sources.redhat.com/ml/libc-alpha/2000-12/msg00068.html>.
89
90 %package devel
91 Summary:        tzfile header file
92 Summary(pl.UTF-8):      Plik nagłówkowy tzfile
93 Group:          Development/Libraries
94
95 %description devel
96 Header file for timezone database.
97
98 %description devel -l pl.UTF-8
99 Plik nagłówkowy bazy danych stref czasowych.
100
101 %prep
102 %setup -qc
103 mv tzdata/* .
104 %{__tar} xzf %{SOURCE1} -C tzdata
105 install -d tzcode
106 %{__tar} xzf %{SOURCE2} -C tzcode
107 %patch2 -p1
108
109 %{__sed} -e "
110 s|@objpfx@|`pwd`/obj/|
111 s|@datadir@|%{_datadir}|
112 s|@install_root@|$RPM_BUILD_ROOT|
113 " 'Makeconfig.in' > Makeconfig
114
115 grep -v tz-art.htm tzcode/tz-link.htm > tzcode/tz-link.html
116
117 %if %{with java}
118 install -d javazic
119 tar zxf %{SOURCE5} -C javazic
120 cd javazic
121 %patch1
122
123 # Hack alert! sun.tools may be defined and installed in the
124 # VM. In order to guarantee that we are using IcedTea/OpenJDK
125 # for creating the zoneinfo files, rebase all the packages
126 # from "sun." to "rht.". Unfortunately, gcj does not support
127 # any of the -Xclasspath options, so we must go this route
128 # to ensure the greatest compatibility.
129 # XXX: do we want 'pld' instead of 'rht'?
130 mv sun rht
131 find . -type f -name '*.java' -print0 \
132         | xargs -0 -- sed -i -e 's:sun\.tools\.:rht.tools.:g' \
133                                                  -e 's:sun\.util\.:rht.util.:g'
134 cd -
135 %endif
136
137 %build
138 %{__make}
139
140 %if %{with java}
141 cd javazic
142 %javac -source 1.5 -target 1.5 -classpath . $(find -name '*.java')
143 cd ../tzdata
144 %java -classpath ../javazic/ rht.tools.javazic.Main -V %{version} \
145         -d ../zoneinfo/java \
146         africa antarctica asia australasia europe northamerica pacificnew \
147         southamerica backward etcetera solar87 solar88 solar89 systemv \
148         ../javazic/tzdata_jdk/gmt ../javazic/tzdata_jdk/jdk11_backward
149 cd ..
150 %endif
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT{/etc/{sysconfig,rc.d/init.d},%{_mandir}/man5,%{_includedir}}
155 %{__make} install
156
157 %if %{with tests}
158 # test needs to be ran after "make install", as it uses installed files
159 : ====================TESTING=========================
160 %{__make} check \
161         CC="%{__cc}" \
162         CFLAGS="%{rpmcflags} %{rpmldflags}"
163 : ====================TESTING END=====================
164 %endif
165
166 # glibc.spec didn't keep it. so won't here either.
167 rm -rf $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posix
168 # behave more like glibc.spec
169 ln -sf %{_sysconfdir}/localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/localtime
170 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixtime
171 ln -sf localtime $RPM_BUILD_ROOT%{_datadir}/zoneinfo/posixrules
172
173 > $RPM_BUILD_ROOT/etc/localtime
174
175 # header file
176 cp -p tzcode/tzfile.h $RPM_BUILD_ROOT%{_includedir}/tzfile.h
177 cp -p tzcode/tzfile.5 $RPM_BUILD_ROOT%{_mandir}/man5
178
179 install -p %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/timezone
180 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/timezone
181
182 install -d $RPM_BUILD_ROOT/etc/init
183 cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/init/timezone.conf
184
185 %if %{with java}
186 cp -a zoneinfo/java $RPM_BUILD_ROOT%{_datadir}/javazi
187 %endif
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post
193 /sbin/chkconfig --add timezone
194 %service timezone restart
195
196 %preun
197 if [ "$1" = "0" ]; then
198         /sbin/chkconfig --del timezone
199
200         # save for postun
201         cp -f /etc/localtime /etc/localtime.rpmsave
202 fi
203
204 %postun
205 if [ "$1" = "0" ]; then
206         if [ ! -f /etc/localtime -a -f /etc/localtime.rpmsave ]; then
207                 mv -f /etc/localtime{.rpmsave,}
208         fi
209 fi
210
211 %triggerpostun -- rc-scripts < 0.4.1.4
212 /sbin/chkconfig --add timezone
213
214 %triggerpostun -- tzdata < 2008b-4
215 if ! grep -q '^TIMEZONE=' /etc/sysconfig/timezone; then
216         . /etc/sysconfig/timezone
217
218         if [ -z $ZONE_INFO_AREA ]; then
219                 TIMEZONE=$TIME_ZONE
220         else
221                 TIMEZONE=$ZONE_INFO_AREA/$TIME_ZONE
222         fi
223
224         echo "TIMEZONE=\"$TIMEZONE\"" >> /etc/sysconfig/timezone
225
226         %service timezone restart
227 fi
228
229 %files
230 %defattr(644,root,root,755)
231 %doc tzcode/README tzcode/Theory tzcode/tz-link.html
232 %ghost /etc/localtime
233 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/timezone
234 %attr(754,root,root) /etc/rc.d/init.d/timezone
235 %config(noreplace) %verify(not md5 mtime size) /etc/init/timezone.conf
236
237 %{_datadir}/zoneinfo
238 %exclude %{_datadir}/zoneinfo/right
239
240 %if %{with java}
241 %files -n java-tzdata
242 %defattr(644,root,root,755)
243 %{_datadir}/javazi
244 %endif
245
246 %files zoneinfo_right
247 %defattr(644,root,root,755)
248 %{_datadir}/zoneinfo/right
249
250 %files devel
251 %defattr(644,root,root,755)
252 %doc tzcode/tzfile.5.txt
253 %{_includedir}/tzfile.h
254 %{_mandir}/man5/tzfile.5*
This page took 0.791229 seconds and 3 git commands to generate.