]> git.pld-linux.org Git - packages/tvheadend.git/commitdiff
- rel 1 auto/th/tvheadend-3.4.27-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 11 Jan 2014 23:17:29 +0000 (00:17 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 11 Jan 2014 23:17:29 +0000 (00:17 +0100)
tvheadend.init
tvheadend.spec

index 68b924d95104002a6e9697301dd1158930cdeed7..69425887dd8e05116ece0806e29787ccb605c2bf 100755 (executable)
@@ -56,18 +56,6 @@ stop() {
        rm -f /var/lock/subsys/tvheadend
 }
 
-reload() {
-       if [ ! -f /var/lock/subsys/tvheadend ]; then
-               msg_not_running "tvheadend"
-               RETVAL=7
-               return
-       fi
-
-       msg_reloading "tvheadend"
-       killproc tvheadend -HUP
-       RETVAL=$?
-}
-
 condrestart() {
        if [ ! -f /var/lock/subsys/tvheadend ]; then
                msg_not_running "tvheadend"
@@ -95,12 +83,6 @@ case "$1" in
   try-restart)
        condrestart 0
        ;;
-# include force-reload here if program allows reloading without restart
-# otherwise remove reload action and support force-reload as restart if running
-  reload|force-reload)
-       reload
-       ;;
-# use this one if program doesn't support reloading without restart
   force-reload)
        condrestart 7
        ;;
@@ -109,7 +91,7 @@ case "$1" in
        RETVAL=$?
        ;;
   *)
-       msg_usage "$0 {start|stop|restart|try-restart|reload|force-reload|status}"
+       msg_usage "$0 {start|stop|restart|try-restart|force-reload|status}"
        exit 3
 esac
 
index a913bae913f9a692ae0c7589d6c6342641907d3b..50be75821422c4c0e7b5a20f399e86ed6f4f0630 100644 (file)
@@ -1,12 +1,11 @@
 # TODO
 # - register uid
-# - initscript: two 'force-reload' (either it has reload or not, cleanup!)
 Summary:       TV streaming server
 Name:          tvheadend
 # keep stable version announced on web page
 %define vername 3.4patch1
 Version:       3.4.27
-Release:       0.1
+Release:       1
 License:       GPL v3
 Group:         Applications/Multimedia
 Source0:       https://github.com/tvheadend/tvheadend/archive/%{vername}.tar.gz
This page took 0.188113 seconds and 4 git commands to generate.