]> git.pld-linux.org Git - packages/trousers.git/blob - trousers.spec
fa6557f747a2efc8ff34f5332fee8a1266c2b6f9
[packages/trousers.git] / trousers.spec
1 # TODO: tcsd init script (see dist/fedora/fedora.initrd.tcsd)
2 #
3 # Conditional build:
4 %bcond_with     gtk     # use GTK+ popups instead of openssl
5 #
6 Summary:        TrouSerS - The open-source TCG Software Stack
7 Summary(pl.UTF-8):      TrouSerS - programowy stos TCG o otwartych źródłach
8 Name:           trousers
9 Version:        0.3.13
10 Release:        2
11 License:        BSD
12 Group:          Applications/System
13 Source0:        http://downloads.sourceforge.net/trousers/%{name}-%{version}.tar.gz
14 # Source0-md5:  ad508f97b406f6e48cd90e85d78e7ca8
15 Patch0:         no_inline.patch
16 URL:            http://trousers.sourceforge.net/
17 BuildRequires:  autoconf
18 BuildRequires:  automake >= 1.6
19 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.0.0}
20 BuildRequires:  libtool
21 BuildRequires:  openssl-devel
22 BuildRequires:  pkgconfig
23 BuildRequires:  sed >= 4.0
24 Requires(pre):  /bin/id
25 Requires(pre):  /usr/bin/getgid
26 Requires(pre):  /usr/sbin/groupadd
27 Requires(pre):  /usr/sbin/useradd
28 Requires(postun):       /usr/sbin/groupdel
29 Requires(postun):       /usr/sbin/userdel
30 Requires:       %{name}-libs = %{version}-%{release}
31 Provides:       group(tss)
32 Provides:       user(tss)
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 TrouSerS is an open-source TCG Software Stack (TSS), released under
37 the Common Public License. TrouSerS aims to be compliant with the 1.1b
38 and 1.2 TSS specifications available from the Trusted Computing Group
39 website: <http://www.trustedcomputinggroup.org/>.
40
41 %description -l pl.UTF-8
42 TrouSerS to programowy stos TCG (TSS, czyli TCG Software Stack) o
43 otwartych źródłach wydany na licencji Common Public License. Celem
44 projektu jest zgodność ze specyfikacjami TSS 1.1b i 1.2 dostępnymi na
45 stronie Trusted Computing Group:
46 <http://www.trustedcomputinggroup.org/>.
47
48 %package libs
49 Summary:        TrouSerS shared library
50 Summary(pl.UTF-8):      Biblioteka współdzielona TrouSerS
51 Group:          Libraries
52
53 %description libs
54 TrouSerS shared library.
55
56 %description libs -l pl.UTF-8
57 Biblioteka współdzielona TrouSerS.
58
59 %package devel
60 Summary:        Header files for TrouSerS library
61 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TrouSerS
62 Group:          Development/Libraries
63 Requires:       %{name}-libs = %{version}-%{release}
64 %{?with_gtk:Requires:   gtk+2-devel >= 1:2.0.0}
65 Requires:       openssl-devel
66
67 %description devel
68 Header files for TrouSerS library.
69
70 %description devel -l pl.UTF-8
71 Pliki nagłówkowe biblioteki TrouSerS.
72
73 %package static
74 Summary:        Static TrouSerS library
75 Summary(pl.UTF-8):      Statyczna biblioteka TrouSerS
76 Group:          Development/Libraries
77 Requires:       %{name}-devel = %{version}-%{release}
78
79 %description static
80 Static TrouSerS library.
81
82 %description static -l pl.UTF-8
83 Statyczna biblioteka TrouSerS.
84
85 %prep
86 %setup -q
87
88 %patch0 -p1
89
90 # there is some unused variable causing warning
91 sed -i -e 's/-Werror //' configure.in
92
93 %build
94 %{__libtoolize}
95 %{__aclocal}
96 %{__autoconf}
97 %{__automake}
98 %configure \
99         --enable-static \
100         %{?with_gtk:--with-gui=gtk} \
101         --disable-usercheck
102 %{__make}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %pre
114 %groupadd -g 139 tss
115 %useradd -u 139 -d %{_localstatedir}/lib/tpm -s /bin/false -c "TrouSerS user" -g tss tss
116
117 %postun
118 if [ "$1" = "0" ]; then
119         %userremove tss
120         %groupremove tss
121 fi
122
123 %post   libs -p /sbin/ldconfig
124 %postun libs -p /sbin/ldconfig
125
126 %files
127 %defattr(644,root,root,755)
128 %doc AUTHORS ChangeLog LICENSE NICETOHAVES README README.selinux TODO
129 %attr(755,root,root) %{_sbindir}/tcsd
130 %attr(640,root,tss) %{_sysconfdir}/tcsd.conf
131 %attr(700,tss,tss) %{_localstatedir}/lib/tpm
132 %{_mandir}/man5/tcsd.conf.5*
133 %{_mandir}/man8/tcsd.8*
134
135 %files libs
136 %defattr(644,root,root,755)
137 %attr(755,root,root) %{_libdir}/libtspi.so.*.*.*
138 %attr(755,root,root) %ghost %{_libdir}/libtspi.so.1
139
140 %files devel
141 %defattr(644,root,root,755)
142 %doc doc/{LTC-TSS_LLD_08_r2.pdf,TSS_programming_SNAFUs.txt}
143 %attr(755,root,root) %{_libdir}/libtspi.so
144 %{_libdir}/libtspi.la
145 %{_libdir}/libtddl.a
146 %{_includedir}/trousers
147 %{_includedir}/tss
148 %{_mandir}/man3/Tspi_*.3*
149
150 %files static
151 %defattr(644,root,root,755)
152 %{_libdir}/libtspi.a
This page took 0.038365 seconds and 2 git commands to generate.