]> git.pld-linux.org Git - packages/trousers.git/blob - trousers.spec
- x32 rebuild
[packages/trousers.git] / trousers.spec
1 # TODO: tcsd init script (see dist/fedora/fedora.initrd.tcsd)
2 #
3 # Conditional build:
4 %bcond_with     gtk     # use GTK+ popups instead of openssl
5 #
6 Summary:        TrouSerS - The open-source TCG Software Stack
7 Summary(pl.UTF-8):      TrouSerS - programowy stos TCG o otwartych źródłach
8 Name:           trousers
9 Version:        0.3.13
10 Release:        2
11 License:        BSD
12 Group:          Applications/System
13 Source0:        http://downloads.sourceforge.net/trousers/%{name}-%{version}.tar.gz
14 # Source0-md5:  ad508f97b406f6e48cd90e85d78e7ca8
15 URL:            http://trousers.sourceforge.net/
16 BuildRequires:  autoconf
17 BuildRequires:  automake >= 1.6
18 %{?with_gtk:BuildRequires:      gtk+2-devel >= 1:2.0.0}
19 BuildRequires:  libtool
20 BuildRequires:  openssl-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  sed >= 4.0
23 Requires(pre):  /bin/id
24 Requires(pre):  /usr/bin/getgid
25 Requires(pre):  /usr/sbin/groupadd
26 Requires(pre):  /usr/sbin/useradd
27 Requires(postun):       /usr/sbin/groupdel
28 Requires(postun):       /usr/sbin/userdel
29 Requires:       %{name}-libs = %{version}-%{release}
30 Provides:       group(tss)
31 Provides:       user(tss)
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 TrouSerS is an open-source TCG Software Stack (TSS), released under
36 the Common Public License. TrouSerS aims to be compliant with the 1.1b
37 and 1.2 TSS specifications available from the Trusted Computing Group
38 website: <http://www.trustedcomputinggroup.org/>.
39
40 %description -l pl.UTF-8
41 TrouSerS to programowy stos TCG (TSS, czyli TCG Software Stack) o
42 otwartych źródłach wydany na licencji Common Public License. Celem
43 projektu jest zgodność ze specyfikacjami TSS 1.1b i 1.2 dostępnymi na
44 stronie Trusted Computing Group:
45 <http://www.trustedcomputinggroup.org/>.
46
47 %package libs
48 Summary:        TrouSerS shared library
49 Summary(pl.UTF-8):      Biblioteka współdzielona TrouSerS
50 Group:          Libraries
51
52 %description libs
53 TrouSerS shared library.
54
55 %description libs -l pl.UTF-8
56 Biblioteka współdzielona TrouSerS.
57
58 %package devel
59 Summary:        Header files for TrouSerS library
60 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TrouSerS
61 Group:          Development/Libraries
62 Requires:       %{name}-libs = %{version}-%{release}
63 %{?with_gtk:Requires:   gtk+2-devel >= 1:2.0.0}
64 Requires:       openssl-devel
65
66 %description devel
67 Header files for TrouSerS library.
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki TrouSerS.
71
72 %package static
73 Summary:        Static TrouSerS library
74 Summary(pl.UTF-8):      Statyczna biblioteka TrouSerS
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static TrouSerS library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka TrouSerS.
83
84 %prep
85 %setup -q
86
87 # there is some unused variable causing warning
88 sed -i -e 's/-Werror //' configure.in
89
90 %build
91 %{__libtoolize}
92 %{__aclocal}
93 %{__autoconf}
94 %{__automake}
95 %configure \
96         --enable-static \
97         %{?with_gtk:--with-gui=gtk} \
98         --disable-usercheck
99 %{__make}
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103
104 %{__make} install \
105         DESTDIR=$RPM_BUILD_ROOT
106
107 %clean
108 rm -rf $RPM_BUILD_ROOT
109
110 %pre
111 %groupadd -g 139 tss
112 %useradd -u 139 -d %{_localstatedir}/lib/tpm -s /bin/false -c "TrouSerS user" -g tss tss
113
114 %postun
115 if [ "$1" = "0" ]; then
116         %userremove tss
117         %groupremove tss
118 fi
119
120 %post   libs -p /sbin/ldconfig
121 %postun libs -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc AUTHORS ChangeLog LICENSE NICETOHAVES README README.selinux TODO
126 %attr(755,root,root) %{_sbindir}/tcsd
127 %attr(640,root,tss) %{_sysconfdir}/tcsd.conf
128 %attr(700,tss,tss) %{_localstatedir}/lib/tpm
129 %{_mandir}/man5/tcsd.conf.5*
130 %{_mandir}/man8/tcsd.8*
131
132 %files libs
133 %defattr(644,root,root,755)
134 %attr(755,root,root) %{_libdir}/libtspi.so.*.*.*
135 %attr(755,root,root) %ghost %{_libdir}/libtspi.so.1
136
137 %files devel
138 %defattr(644,root,root,755)
139 %doc doc/{LTC-TSS_LLD_08_r2.pdf,TSS_programming_SNAFUs.txt}
140 %attr(755,root,root) %{_libdir}/libtspi.so
141 %{_libdir}/libtspi.la
142 %{_libdir}/libtddl.a
143 %{_includedir}/trousers
144 %{_includedir}/tss
145 %{_mandir}/man3/Tspi_*.3*
146
147 %files static
148 %defattr(644,root,root,755)
149 %{_libdir}/libtspi.a
This page took 0.135988 seconds and 3 git commands to generate.