]> git.pld-linux.org Git - packages/totem.git/commitdiff
Update to 3.26.0 auto/th/totem-3.26.0-1
authorMarcin Banasiak <marcin.banasiak@gmail.com>
Sat, 17 Mar 2018 22:15:41 +0000 (23:15 +0100)
committerMarcin Banasiak <marcin.banasiak@gmail.com>
Sat, 17 Mar 2018 22:15:41 +0000 (23:15 +0100)
- removed obsolete -python3 patch
- added -gtk-doc patch to fix build with recent gtk-doc
- -static subpackage is gone

totem-configure.patch
totem-gtk-doc.patch [new file with mode: 0644]
totem-python3.patch [deleted file]
totem.spec

index b899cdaecf80cdd05d1f140f9a9342ab736b83fa..5ee774444f06cca0e30e28056f19dbc7e36cb27b 100644 (file)
@@ -1,62 +1,35 @@
---- totem-3.14.1/configure.ac.fix      2014-11-20 17:18:40.000000000 +0100
-+++ totem-3.14.1/configure.ac  2015-01-26 21:27:57.453277498 +0100
-@@ -135,59 +135,6 @@ BACKEND_MODULES="gstreamer-1.0 >= $GST_R
- PKG_CHECK_MODULES(BACKEND, $BACKEND_MODULES)
PKG_CHECK_MODULES(BACKEND_TEST, $BACKEND_MODULES gtk+-3.0 >= $GTK_REQS)
+--- totem-3.26.0/src/backend/meson.build.configfix     2018-03-17 22:39:59.380045123 +0100
++++ totem-3.26.0/src/backend/meson.build       2018-03-17 22:40:14.210790112 +0100
+@@ -6,32 +6,17 @@ gst_inspect = find_program(
+   required: false
+ )
  
--dnl Check for required plugins
--gst10_toolsdir=`$PKG_CONFIG --variable=toolsdir gstreamer-1.0`
--gst10_inspect="$gst10_toolsdir/gst-inspect-1.0"
+-assert(gst_inspect.found(),
+-       'Cannot find required GStreamer-1.0 tool "gst-inspect-1.0". It should be part of gstreamer-1_0-utils. Please install it.')
 -
--dnl Give error and exit if we don't have the gst_inspect tool
--AC_MSG_CHECKING([GStreamer 1.0 inspection tool])
--if test -r "$gst10_inspect"; then
--      AC_MSG_RESULT([yes])
--else
--      AC_MSG_RESULT([no])
--      AC_MSG_ERROR([
--              Cannot find required GStreamer-1.0 tool 'gst-inspect-1.0'.
--              It should be part of gstreamer-1_0-utils. Please install it.
--      ])
--fi
--
--dnl Check for elements from gst-plugins-base
--dnl Set plugins which contain below elements
--set -- playback videoscale
--for base_element in playbin videoscale
--do
--      AC_MSG_CHECKING([GStreamer 1.0 $base_element element])
--      if $gst10_inspect $base_element >/dev/null 2>/dev/null; then
--              AC_MSG_RESULT([yes])
--      else
--              AC_MSG_RESULT([no])
--              AC_MSG_ERROR([
--                      Cannot find required GStreamer-1.0 plugin '$1'.
--                      It should be part of gst-plugins-base. Please install it.
--              ])
--
--      fi
--      shift;
--done
+ gst_base_plugins = [
+   'playbin',
+   'videoscale'
+ ]
+-foreach plugin: gst_base_plugins
+-  r = run_command(gst_inspect, plugin)
+-  assert(r.returncode() == 0,
+-         'Cannot find required GStreamer-1.0 plugin "' + plugin + '". It should be part of gst-plugins-base. Please install it.')
+-endforeach
 -
--dnl Check for elements from gst-plugins-good
--dnl Set plugins which contain below elements
--set -- autodetect goom scaletempo
--for good_element in autoaudiosink goom scaletempo
--do
--      AC_MSG_CHECKING([GStreamer 1.0 $good_element element])
--      if $gst10_inspect $good_element >/dev/null 2>/dev/null; then
--              AC_MSG_RESULT([yes])
--      else
--              AC_MSG_RESULT([no])
--              AC_MSG_ERROR([
--                      Cannot find required GStreamer-1.0 plugin '$1'.
--                      It should be part of gst-plugins-good. Please install it.
--              ])
--      fi
--      shift;
--done
+ gst_good_plugins = [
+   'autoaudiosink',
+   'goom',
+   'scaletempo'
+ ]
+-foreach plugin: gst_good_plugins
+-  r = run_command(gst_inspect, plugin)
+-  assert(r.returncode() == 0,
+-         'Cannot find required GStreamer-1.0 plugin "' + plugin + '". It should be part of gst-plugins-good. Please install it.')
+-endforeach
 -
- # ================================================================
- # Python plugins
- # ================================================================
+ sources = files(
+   'bacon-time-label.c',
+   'bacon-video-controls-actor.c',
diff --git a/totem-gtk-doc.patch b/totem-gtk-doc.patch
new file mode 100644 (file)
index 0000000..871b4cf
--- /dev/null
@@ -0,0 +1,37 @@
+From 6bf1e1d06d1a93b727f2fa7a4ba5c6dae2977199 Mon Sep 17 00:00:00 2001
+From: Jeremy Bicha <jbicha@ubuntu.com>
+Date: Thu, 19 Oct 2017 10:41:55 -0400
+Subject: [PATCH] build: Fix build with gtk-doc 1.26
+
+https://bugzilla.gnome.org/show_bug.cgi?id=789202
+---
+ docs/reference/meson.build | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/docs/reference/meson.build b/docs/reference/meson.build
+index 16f64bb8..ff61274f 100644
+--- a/docs/reference/meson.build
++++ b/docs/reference/meson.build
+@@ -89,7 +89,7 @@ gnome.gtkdoc(
+     '--ignore-headers=' + ' '.join(private_headers),
+   ],
+   mkdb_args: [
+-    '--sgml-mode',
++    '--xml-mode',
+     '--output-format=xml',
+     '--name-space=' + meson.project_name()
+   ],
+-- 
+2.14.3
+
+--- totem-3.26.0/docs/reference/meson.build.gtkdoc     2018-03-17 22:59:32.785973378 +0100
++++ totem-3.26.0/docs/reference/meson.build    2018-03-17 22:59:40.769963377 +0100
+@@ -72,7 +72,7 @@ configure_file(
+   configuration: version_conf
+ )
+-doc_path = join_paths(totem_datadir, 'gtk-doc', 'html', meson.project_name())
++doc_path = join_paths(totem_datadir, 'doc', 'gtk-doc', 'html', meson.project_name())
+ gnome.gtkdoc(
+   meson.project_name(),
diff --git a/totem-python3.patch b/totem-python3.patch
deleted file mode 100644 (file)
index 0a7fd9e..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- totem-3.14.1/configure.ac.py3      2015-01-26 22:35:24.687778621 +0100
-+++ totem-3.14.1/configure.ac  2015-01-26 22:35:38.501037126 +0100
-@@ -57,7 +57,7 @@ GTK_REQS=3.11.5
- TOTEM_PLPARSER_REQS=3.10.1
- VALA_REQS=0.14.1
- PEAS_REQS=1.1.0
--PYTHON_REQS=2.3
-+PYTHON_REQS=3.0
- PYGOBJECT_REQS=2.90.3
- GRILO_REQS=0.2.10
- GRILO_PLS_REQS=0.2.1
index 6cb1ab2a6c2b4d183b0c796e96096665c126ef44..5425310bdd6fa1a03e1e73104cdded608893a90f 100644 (file)
@@ -5,26 +5,24 @@
 Summary:       Movie player for GNOME based on the gstreamer engine
 Summary(pl.UTF-8):     Odtwarzacz filmów dla GNOME oparty na silniku gstreamer
 Name:          totem
-Version:       3.20.1
+Version:       3.26.0
 Release:       1
 License:       GPL v2
 Group:         X11/Applications/Multimedia
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/totem/3.20/%{name}-%{version}.tar.xz
-# Source0-md5: 765a0a1d2d2a8fc8d9c44dbaa92d5d7c
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/totem/3.26/%{name}-%{version}.tar.xz
+# Source0-md5: 70fac11be0ef7da7d6d3ae1abaded8a6
+Patch0:                %{name}-gtk-doc.patch
 # PLD-specific patches
-Patch0:                %{name}-configure.patch
-Patch1:                %{name}-python3.patch
+Patch10:       %{name}-configure.patch
 URL:           https://wiki.gnome.org/Apps/Videos
-BuildRequires: autoconf >= 2.64
-BuildRequires: automake >= 1:1.11
 BuildRequires: cairo-devel >= 1.14.0
 BuildRequires: clutter-devel >= 1.18.0
 BuildRequires: clutter-gst-devel >= 3.0.0
-BuildRequires: clutter-gtk-devel >= 1.8.0
+BuildRequires: clutter-gtk-devel >= 1.8.1
 BuildRequires: docbook-dtd45-xml
 BuildRequires: gdk-pixbuf2-devel >= 2.24.0
 BuildRequires: gettext-tools
-BuildRequires: glib2-devel >= 1:2.36.0
+BuildRequires: glib2-devel >= 1:2.44.0
 BuildRequires: gnome-common >= 2.24.0
 BuildRequires: gnome-desktop-devel
 BuildRequires: gnome-doc-utils >= 0.20.3
@@ -35,12 +33,11 @@ BuildRequires:      gstreamer-devel >= 1.6.0
 BuildRequires: gstreamer-plugins-base-devel >= 1.6.0
 BuildRequires: gtk+3-devel >= 3.20.0
 BuildRequires: gtk-doc >= 1.14
-BuildRequires: intltool >= 0.50.1
 BuildRequires: libpeas-devel >= 1.1.0
 BuildRequires: libpeas-gtk-devel >= 1.1.0
-BuildRequires: libtool
 BuildRequires: libxml2-devel >= 1:2.6.31
 %{?with_lirc:BuildRequires:    lirc-devel}
+BuildRequires: meson >= 0.41.0
 BuildRequires: nautilus-devel >= 3.0.0
 BuildRequires: pkgconfig
 BuildRequires: pylint
@@ -67,7 +64,7 @@ Requires(post,postun):        glib2 >= 1:2.28.0
 Requires(post,postun): scrollkeeper
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      clutter-gst >= 3.0.0
-Requires:      glib2 >= 1:2.36.0
+Requires:      glib2 >= 1:2.44.0
 Requires:      gnome-icon-theme >= 3.0.0
 Requires:      gstreamer-audiosink >= 1.6.0
 Requires:      gstreamer-plugins-bad >= 1.6.0
@@ -128,9 +125,10 @@ Summary:   Header files for totem
 Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja
 Group:         X11/Development/Libraries
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      glib2-devel >= 1:2.36.0
+Requires:      glib2-devel >= 1:2.44.0
 Requires:      gtk+3-devel >= 3.20.0
 Requires:      totem-pl-parser-devel >= 3.10.1
+Obsoletes:     totem-static < 3.26.0
 
 %description devel
 This package contains the files necessary to develop applications
@@ -144,18 +142,6 @@ bibliotek programu Totem.
 Este pacote contém os arquivos necessários para desenvolvimento de
 aplicações utilizando as bibliotecas do Totem.
 
-%package static
-Summary:       Static libraries for totem
-Summary(pl.UTF-8):     Biblioteki statyczne dla totem
-Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
-
-%description static
-This package contains static libraries for Totem.
-
-%description static -l pl.UTF-8
-Pakiet zawiera statyczne biblioteki Totem.
-
 %package im-status
 Summary:       Instant Messenger status plugin for Totem
 Group:         Applications/Multimedia
@@ -236,34 +222,19 @@ of audio and video files in the properties dialog.
 %prep
 %setup -q
 %patch0 -p1
-%patch1 -p1
+%patch10 -p1
 
 %build
-%{__gtkdocize}
-%{__intltoolize}
-%{__libtoolize}
-%{__aclocal} -I m4 -I libgd
-%{__autoconf}
-%{__autoheader}
-%{__automake}
-%configure \
-       --disable-silent-rules \
-       --enable-nautilus \
-       --enable-python \
-       --enable-gtk-doc \
-       --with-html-dir=%{_gtkdocdir}
-
-%{__make}
+%meson build \
+       -Denable-nautilus=yes \
+       -Denable-python=yes \
+       -Denable-gtk-doc=true
+%meson_build -C build -j1
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       INSTALL="install -p"
 
-%{__rm}        $RPM_BUILD_ROOT%{_libdir}/nautilus/extensions-3.0/*.{la,a} \
-       $RPM_BUILD_ROOT%{_libdir}/totem/plugins/*/*.{la,a} \
-       $RPM_BUILD_ROOT%{_libdir}/*.la
+%meson_install -C build
 
 %find_lang %{name} --with-gnome --with-omf --all-name
 
@@ -295,16 +266,15 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README TODO
+%doc AUTHORS ChangeLog.pre-gitlog NEWS README TODO
 %attr(755,root,root) %{_bindir}/totem
-%attr(755,root,root) %{_bindir}/totem-audio-preview
 %attr(755,root,root) %{_bindir}/totem-video-thumbnailer
-%{_datadir}/appdata/org.gnome.Totem.appdata.xml
+%attr(755,root,root) %{_libexecdir}/totem-gallery-thumbnailer
+%{_datadir}/metainfo/org.gnome.Totem.appdata.xml
 %{_datadir}/dbus-1/services/org.gnome.Totem.service
 %{_datadir}/%{name}
 %{_desktopdir}/org.gnome.Totem.desktop
 %{_mandir}/man1/totem.1*
-%{_mandir}/man1/totem-audio-preview.1*
 %{_mandir}/man1/totem-video-thumbnailer.1*
 %{_iconsdir}/hicolor/*/*/*.png
 %{_iconsdir}/hicolor/*/*/*.svg
@@ -327,7 +297,6 @@ rm -rf $RPM_BUILD_ROOT
 %{pluginsdir}/brasero-disc-recorder/brasero-disc-recorder.plugin
 
 %dir %{pluginsdir}/dbus
-%{pluginsdir}/dbus/__pycache__
 %{pluginsdir}/dbus/*.py
 %{pluginsdir}/dbus/dbusservice.plugin
 
@@ -344,7 +313,6 @@ rm -rf $RPM_BUILD_ROOT
 %{pluginsdir}/properties/movie-properties.plugin
 
 %dir %{pluginsdir}/pythonconsole
-%{pluginsdir}/pythonconsole/__pycache__
 %{pluginsdir}/pythonconsole/console.py
 %{pluginsdir}/pythonconsole/pythonconsole.py
 %{pluginsdir}/pythonconsole/pythonconsole.plugin
@@ -379,6 +347,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %{_datadir}/thumbnailers/totem.thumbnailer
 
+%dir %{pluginsdir}/variable-rate
+%attr(755,root,root) %{pluginsdir}/variable-rate/libvariable-rate.so
+%{pluginsdir}/variable-rate/variable-rate.plugin
+
 %dir %{pluginsdir}/vimeo
 %attr(755,root,root) %{pluginsdir}/vimeo/libvimeo.so
 %{pluginsdir}/vimeo/vimeo.plugin
@@ -400,10 +372,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/totem.pc
 %{_datadir}/gir-1.0/Totem-1.0.gir
 
-%files static
-%defattr(644,root,root,755)
-%{_libdir}/libtotem.a
-
 %files im-status
 %defattr(644,root,root,755)
 %dir %{pluginsdir}/im-status
@@ -426,7 +394,6 @@ rm -rf $RPM_BUILD_ROOT
 %files opensubtitles
 %defattr(644,root,root,755)
 %dir %{pluginsdir}/opensubtitles
-%{pluginsdir}/opensubtitles/__pycache__
 %{pluginsdir}/opensubtitles/*.py
 %{pluginsdir}/opensubtitles/opensubtitles.plugin
 %{pluginsdir}/opensubtitles/opensubtitles.ui
This page took 0.120228 seconds and 4 git commands to generate.