]> git.pld-linux.org Git - packages/tora.git/blob - tora.spec
a922d5ca706bc83b735677a5170dd573fb90101c
[packages/tora.git] / tora.spec
1 #
2 # Conditional build:
3 %bcond_with     oracle          # build with oracle support
4 %bcond_with     instantclient   # build oracle support with oracle-instantclient
5
6 Summary:        A graphical toolkit for database developers and administrators
7 Summary(pl.UTF-8):      Zestaw graficznych narzędzi dla programistów i administratorów baz danych
8 Name:           tora
9 Version:        2.1.3
10 Release:        8
11 License:        GPL v2
12 Group:          Applications/Databases/Interfaces
13 Source0:        http://downloads.sourceforge.net/tora/%{name}-%{version}.tar.gz
14 # Source0-md5:  ea4a75a9daeaf58492413e3f7fe40293
15 Source1:        %{name}.desktop
16 Patch0:         %{name}-postgresql.patch
17 Patch1:         %{name}-gcc.patch
18 Patch2:         %{name}-build.patch
19 Patch3:         gethostname.patch
20 URL:            http://tora.sourceforge.net/
21 BuildRequires:  QtCore-devel
22 BuildRequires:  QtGui-devel
23 BuildRequires:  QtNetwork-devel
24 BuildRequires:  QtSql-devel
25 BuildRequires:  QtXml-devel
26 BuildRequires:  cppunit-devel
27 %{?with_instantclient:BuildRequires:    oracle-instantclient-devel}
28 BuildRequires:  pcre-devel
29 BuildRequires:  postgresql-devel
30 BuildRequires:  qscintilla2-qt4-devel
31 BuildRequires:  qt4-build
32 BuildRequires:  qt4-linguist
33 BuildRequires:  xorg-lib-libICE-devel
34 Suggests:       QtSql-pgsql
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %if %{with oracle}
38 # ORACLE_HOME is required for oracle
39 %define _preserve_env %_preserve_env_base ORACLE_HOME
40 %endif
41
42 %description
43 TOra features a schema browser, SQL worksheet, PL/SQL editor and
44 debugger, storage manager, rollback segment monitor, instance manager,
45 and SQL output viewer. Via qt3 it can access PostgreSQL and MySQL
46 directly. Any other database systems can be accessed via ODBC.
47
48 %description -l pl.UTF-8
49 TOra zawiera przeglądarkę schematów, arkusz roboczy SQL, edytor i
50 debugger PL/SQL, zarządcę danych, monitor segmentów wycofań, zarządcę
51 instancji i przeglądarkę wyjścia SQL. Poprzez qt3 może współpracować
52 bezpośrednio z bazami PostgreSQL i MySQL. Inne systemy baz danych mogą
53 być obsługiwane poprzez ODBC.
54
55 %prep
56 %setup -q
57 %patch0 -p1
58 %patch1 -p1
59 %patch2 -p1
60 %patch3 -p1
61
62 rm -f src/moc_*
63
64 %build
65 %{__libtoolize}
66 %{__aclocal} -I config/m4
67 %{__autoconf}
68 %{__automake}
69 %configure \
70         --libdir=%{_datadir}/%{name} \
71         --with-qt-libraries=%{_libdir} \
72 %if %{with oracle}
73         %if %{with instantclient}
74         --with-instant-client \
75         --with-oracle-includes=%{_includedir}/oracle/client \
76         --with-oracle-libraries=%{_libdir} \
77         %endif
78         --with-oracle
79 %else
80         --without-oracle
81 %endif
82
83 %{__make}
84
85 %install
86 rm -rf $RPM_BUILD_ROOT
87 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
88 %{__make} install \
89         DESTDIR=$RPM_BUILD_ROOT
90
91 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
92 cp -p src/icons/tora.xpm $RPM_BUILD_ROOT%{_pixmapsdir}
93 cp -a src/templates $RPM_BUILD_ROOT%{_datadir}/%{name}
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post   -p /sbin/postshell
99 -/usr/sbin/fix-info-dir -c %{_infodir}
100
101 %postun -p /sbin/postshell
102 -/usr/sbin/fix-info-dir -c %{_infodir}
103
104 %files
105 %defattr(644,root,root,755)
106 %doc BUGS NEWS README TODO
107 %attr(755,root,root) %{_bindir}/*
108 %dir %{_datadir}/%{name}
109 %{_datadir}/%{name}/help
110 %{_datadir}/%{name}/templates
111 %{_datadir}/%{name}/*.qm
112 %{_desktopdir}/*.desktop
113 %{_pixmapsdir}/*.xpm
114 %{_infodir}/tora*
This page took 0.074733 seconds and 2 git commands to generate.