]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
- up to 0.3.4.8
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl.UTF-8):      Sieć nakładkowa dla TCP zapewniająca anonimowość (router cebulowy)
3 Name:           tor
4 Version:        0.3.4.8
5 Release:        1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://www.torproject.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  84497a248f49ed42c344612501bae934
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 Source4:        %{name}.tmpfiles
14 URL:            http://www.torproject.org/
15 # http://archives.seul.org/or/announce/Feb-2009/msg00000.html
16 BuildRequires:  libevent-devel >= 1.1
17 BuildRequires:  openssl-devel >= 0.9.6
18 BuildRequires:  rpm-build >= 4.0
19 BuildRequires:  rpmbuild(macros) >= 1.268
20 BuildRequires:  zlib-devel
21 Requires(post,preun):   /sbin/chkconfig
22 Requires(pre):  /bin/id
23 Requires(pre):  /usr/bin/getgid
24 Requires(pre):  /usr/sbin/groupadd
25 Requires(pre):  /usr/sbin/useradd
26 Requires:       rc-scripts
27 Provides:       group(tor)
28 Provides:       user(tor)
29 Conflicts:      logrotate < 3.7-4
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Tor is a connection-based low-latency anonymous communication system.
34
35 This package provides the "tor" program, which serves as both a client
36 and a relay node. Scripts will automatically create a "tor" user and
37 group, and set tor up to run as a daemon when the system is rebooted.
38
39 Applications connect to the local Tor proxy using the SOCKS protocol.
40 The local proxy chooses a path through a set of relays, in which each
41 relay knows its predecessor and successor, but no others. Traffic
42 flowing down the circuit is unwrapped by a symmetric key at each
43 relay, which reveals the downstream relay.
44
45 Warnings: Tor does no protocol cleaning. That means there is a danger
46 that application protocols and associated programs can be induced to
47 reveal information about the initiator. Tor depends on Privoxy and
48 similar protocol cleaners to solve this problem. This is alpha code,
49 and is even more likely than released code to have anonymity-spoiling
50 bugs. The present network is very small -- this further reduces the
51 strength of the anonymity provided. Tor is not presently suitable for
52 high-stakes anonymity.
53
54 %description -l pl.UTF-8
55 Tor to oparty na połączeniach system anonimowej komunikacji o małych
56 opóźnieniach.
57
58 Ten pakiet dostarcza program "tor", służący zarówno jako klient, jak i
59 węzeł przekaźnikowy. Skrypty automatycznie tworzą użytkownika i grupę
60 "tor" i konfigurują tora do działania jako demon po uruchomieniu
61 systemu.
62
63 Aplikacje łączą się z lokalnym proxy Tor przy użyciu protokołu SOCKS.
64 Lokalne proxy wybiera ścieżkę poprzez zbiór przekaźników, z których
65 każdy zna swojego poprzednika i następnika, ale żadnego więcej. Ruch
66 przychodzący jest rozpakowywany przy użyciu klucza symetrycznego na
67 każdym przekaźniku, który odsłania kolejny przekaźnik.
68
69 Uwaga: Tor nie oczyszcza protokołów. Oznacza to, że istnieje
70 niebezpieczeństwo, że protokoły aplikacji i powiązane programy mogą
71 odkryć informacje o pochodzeniu. Tor polega na Privoxy i podobnych
72 oczyszczaczach protokołów w celu rozwiązania tego problemu. To jest
73 kod alpha, więc może mieć więcej błędów psujących anonimowość niż kod
74 wydany. Obecna sieć jest bardzo mała - co w dalszym stopniu ogranicza
75 zapewnianą anonimowość. Tor aktualnie nie nadaje się do zadań
76 wymagających anonimowości na wysoką stawkę.
77
78 %prep
79 %setup -q
80
81 %build
82 %configure \
83         --disable-silent-rules
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT/var/{{lib,run}/%{name},log/{,archive/}%{name}} \
89         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
90
91 %{__make} install \
92         DESTDIR=$RPM_BUILD_ROOT
93
94 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
95 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
96 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
97 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
98 install %{SOURCE4} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
99
100 %clean
101 rm -rf $RPM_BUILD_ROOT
102
103 %pre
104 %groupadd -g 156 tor
105 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
106
107 %post
108 /sbin/chkconfig --add %{name}
109 %service %{name} restart
110
111 %preun
112 if [ "$1" = "0" ]; then
113         %service -q %{name} stop
114         /sbin/chkconfig --del %{name}
115 fi
116
117 %postun
118 if [ "$1" = "0" ]; then
119         %userremove  tor
120         %groupremove tor
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc LICENSE README ChangeLog doc/HACKING
126 %attr(755,root,root) %{_bindir}/*
127 %{_mandir}/man1/*.1*
128 %attr(754,root,root) /etc/rc.d/init.d/%{name}
129 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
130 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
131 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
132 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
133 /usr/lib/tmpfiles.d/%{name}.conf
134 %dir %attr(750,root,tor) /var/lib/%{name}
135 %dir %attr(750,root,tor) /var/run/%{name}
136 %dir %attr(750,root,tor) /var/log/%{name}
137 %dir %attr(750,root,tor) /var/log/archive
138 %dir %attr(750,root,tor) /var/log/archive/%{name}
139 %{_datadir}/tor
This page took 0.10808 seconds and 3 git commands to generate.