]> git.pld-linux.org Git - packages/tor.git/blob - tor.spec
2e91e27c56ab2ec124e19f7c3800665135c2ee4d
[packages/tor.git] / tor.spec
1 Summary:        Anonymizing overlay network for TCP (The onion router)
2 Summary(pl.UTF-8):      Sieć nakładkowa dla TCP zapewniająca anonimowość (router cebulowy)
3 Name:           tor
4 Version:        0.1.2.16
5 Release:        1
6 License:        BSD-like
7 Group:          Networking/Daemons
8 Source0:        http://tor.eff.org/dist/%{name}-%{version}.tar.gz
9 # Source0-md5:  f340777b3f6c3175de976856d2d2e4be
10 Source1:        %{name}.logrotate
11 Source2:        %{name}.init
12 Source3:        %{name}.sysconfig
13 URL:            http://tor.eff.org/
14 BuildRequires:  libevent-devel >= 1.1
15 BuildRequires:  openssl-devel >= 0.9.6
16 BuildRequires:  rpm-build >= 4.0
17 BuildRequires:  rpmbuild(macros) >= 1.268
18 Requires(post,preun):   /sbin/chkconfig
19 Requires(pre):  /bin/id
20 Requires(pre):  /usr/bin/getgid
21 Requires(pre):  /usr/sbin/groupadd
22 Requires(pre):  /usr/sbin/useradd
23 Requires:       rc-scripts
24 Provides:       group(tor)
25 Provides:       user(tor)
26 Conflicts:      logrotate < 3.7.4
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 Tor is a connection-based low-latency anonymous communication system.
31
32 This package provides the "tor" program, which serves as both a client
33 and a relay node. Scripts will automatically create a "tor" user and
34 group, and set tor up to run as a daemon when the system is rebooted.
35
36 Applications connect to the local Tor proxy using the SOCKS protocol.
37 The local proxy chooses a path through a set of relays, in which each
38 relay knows its predecessor and successor, but no others. Traffic
39 flowing down the circuit is unwrapped by a symmetric key at each
40 relay, which reveals the downstream relay.
41
42 Warnings: Tor does no protocol cleaning. That means there is a danger
43 that application protocols and associated programs can be induced to
44 reveal information about the initiator. Tor depends on Privoxy and
45 similar protocol cleaners to solve this problem. This is alpha code,
46 and is even more likely than released code to have anonymity-spoiling
47 bugs. The present network is very small -- this further reduces the
48 strength of the anonymity provided. Tor is not presently suitable for
49 high-stakes anonymity.
50
51 %description -l pl.UTF-8
52 Tor to oparty na połączeniach system anonimowej komunikacji o małych
53 opóźnieniach.
54
55 Ten pakiet dostarcza program "tor", służący zarówno jako klient, jak i
56 węzeł przekaźnikowy. Skrypty automatycznie tworzą użytkownika i grupę
57 "tor" i konfigurują tora do działania jako demon po uruchomieniu
58 systemu.
59
60 Aplikacje łączą się z lokalnym proxy Tor przy użyciu protokołu SOCKS.
61 Lokalne proxy wybiera ścieżkę poprzez zbiór przekaźników, z których
62 każdy zna swojego poprzednika i następnika, ale żadnego więcej. Ruch
63 przychodzący jest rozpakowywany przy użyciu klucza symetrycznego na
64 każdym przekaźniku, który odsłania kolejny przekaźnik.
65
66 Uwaga: Tor nie oczyszcza protokołów. Oznacza to, że istnieje
67 niebezpieczeństwo, że protokoły aplikacji i powiązane programy mogą
68 odkryć informacje o pochodzeniu. Tor polega na Privoxy i podobnych
69 oczyszczaczach protokołów w celu rozwiązania tego problemu. To jest
70 kod alpha, więc może mieć więcej błędów psujących anonimowość niż kod
71 wydany. Obecna sieć jest bardzo mała - co w dalszym stopniu ogranicza
72 zapewnianą anonimowość. Tor aktualnie nie nadaje się do zadań
73 wymagających anonimowości na wysoką stawkę.
74
75 %prep
76 %setup -q
77
78 %build
79 %configure
80 %{__make}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 mv $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/torrc{.sample,}
89 install -D %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
90 install -D %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
91 install -D %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
92
93 install -d $RPM_BUILD_ROOT/var/lib/%{name}
94 install -d $RPM_BUILD_ROOT/var/run/%{name}
95 install -d $RPM_BUILD_ROOT/var/log/{,archive/}%{name}
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %pre
101 %groupadd -g 156 tor
102 %useradd  -u 156 -r -d /var/lib/tor -s /bin/false -c "Tor" -g tor tor
103
104 %post
105 /sbin/chkconfig --add %{name}
106 %service %{name} restart
107
108 %preun
109 if [ "$1" = "0" ]; then
110         %service -q %{name} stop
111         /sbin/chkconfig --del %{name}
112 fi
113
114 %postun
115 if [ "$1" = "0" ]; then
116         %userremove  tor
117         %groupremove tor
118 fi
119
120 %files
121 %defattr(644,root,root,755)
122 %doc AUTHORS INSTALL LICENSE README ChangeLog doc/HACKING doc/TODO
123 %attr(755,root,root) %{_bindir}/*
124 %{_mandir}/man?/*
125 %attr(754,root,root) /etc/rc.d/init.d/%{name}
126 %dir %attr(750,root,tor) %{_sysconfdir}/%{name}
127 %attr(640,root,tor)  %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/*
128 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/*
129 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
130 %dir %attr(750,root,tor) /var/lib/%{name}
131 %dir %attr(750,root,tor) /var/run/%{name}
132 %dir %attr(750,root,tor) /var/log/%{name}
133 %dir %attr(750,root,tor) /var/log/archive/%{name}
This page took 0.026433 seconds and 2 git commands to generate.