]> git.pld-linux.org Git - packages/tomcat.git/commitdiff
- use tomcat uid/gid instead of http
authorpawelz <pawelz@pld-linux.org>
Mon, 26 Jan 2009 10:43:46 +0000 (10:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    tomcat.spec -> 1.74

tomcat.spec

index 13f20532849b6f79e949f455af26fb3b66434447..167bd75536a8e763262d6031879e384f70e5e452 100644 (file)
@@ -97,8 +97,8 @@ Requires:     jsse >= 1.0.2
 Requires:      jta >= 1.0.1
 Requires:      rc-scripts
 Requires:      xml-commons
-Provides:      group(http)
-Provides:      user(http)
+Provides:      group(tomcat)
+Provides:      user(tomcat)
 Obsoletes:     jakarta-tomcat
 BuildArch:     noarch
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -320,8 +320,8 @@ ln -sf $(find-jar struts-core) $TOMCATDIR/server/webapps/admin/WEB-INF/lib/strut
 rm -rf $RPM_BUILD_ROOT
 
 %pre
-%groupadd -g 51 -r -f http
-%useradd -u 51 -r -d /home/services/httpd -s /bin/false -c "HTTP User" -g http http
+%groupadd -g 51 -r -f tomcat
+%useradd -u 51 -r -d /var/lib/tomcat -s /bin/false -c "Tomcat User" -g tomcat tomcat
 
 %post
 /sbin/chkconfig --add tomcat
@@ -335,8 +335,8 @@ fi
 
 %postun
 if [ "$1" = "0" ]; then
-       %userremove http
-       %groupremove http
+       %userremove tomcat
+       %groupremove tomcat
 fi
 
 %files
@@ -373,11 +373,11 @@ fi
 %dir %{_vardir}
 # tomcat config has to be writeable because of tomacta-users.xml file and
 # Catalina dir
-%config(noreplace) %attr(775,root,http) %verify(not md5 mtime size) %{_vardir}/conf
-%dir %attr(1730,root,http) %{_vardir}/work
-%dir %attr(775,root,http) %{_vardir}/webapps
-%dir %attr(775,root,http) %{_vardir}/temp
-%dir %attr(775,root,http) %{_logdir}/tomcat
+%config(noreplace) %attr(775,root,tomcat) %verify(not md5 mtime size) %{_vardir}/conf
+%dir %attr(1730,root,tomcat) %{_vardir}/work
+%dir %attr(775,root,tomcat) %{_vardir}/webapps
+%dir %attr(775,root,tomcat) %{_vardir}/temp
+%dir %attr(775,root,tomcat) %{_logdir}/tomcat
 %{_vardir}/logs
 
 %if 0
This page took 0.101072 seconds and 4 git commands to generate.