]> git.pld-linux.org Git - packages/tomcat-native.git/blob - tomcat-native.spec
e29a7464ff8dac6f3b337ce8f48cf02468e657eb
[packages/tomcat-native.git] / tomcat-native.spec
1
2 %include        /usr/lib/rpm/macros.java
3
4 Summary:        Native Tomcat Connector based on APR
5 Summary(pl.UTF-8):      Natywny Connector Tomcata oparty o APR
6 Name:           tomcat-native
7 Version:        1.1.16
8 Release:        0.1
9 License:        Apache v2
10 Group:          Libraries
11 Source0:        http://www.apache.org/dist/tomcat/tomcat-connectors/native/%{version}/source/%{name}-%{version}-src.tar.gz
12 # Source0-md5:  2d27f8cf0d87b92b57b2758dad48ff2d
13 URL:            http://tomcat.apache.org/native-doc
14 BuildRequires:  ant
15 BuildRequires:  apr-devel
16 BuildRequires:  autoconf
17 BuildRequires:  automake
18 BuildRequires:  java-sun
19 BuildRequires:  jpackage-utils
20 BuildRequires:  libtool
21 BuildRequires:  openssl-devel
22 BuildRequires:  rpm >= 4.4.9-56
23 BuildRequires:  rpm-javaprov
24 BuildRequires:  rpmbuild(macros) >= 1.300
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Tomcat can use the Apache Portable Runtime to provide superior
29 scalability, performance, and better integration with native server
30 technologies. The Apache Portable Runtime is a highly portable library
31 that is at the heart of Apache HTTP Server 2.x. APR has many uses,
32 including access to advanced IO functionality (such as sendfile, epoll
33 and OpenSSL), OS level functionality (random number generation, system
34 status, etc), and native process handling (shared memory, NT pipes and
35 Unix sockets).
36
37 These features allows making Tomcat a general purpose webserver, will
38 enable much better integration with other native web technologies, and
39 overall make Java much more viable as a full fledged webserver
40 platform rather than simply a backend focused technology.
41
42 %description -l pl.UTF-8
43 Tomcat może wykorzytać Apache Portable Runtime aby zapewnić
44 najwyższą, saklowalność, wydajność i lepszą integrację z
45 natywnymi technologiami serwerowymi.
46
47 Apache portable Runtime jest wysoce przenośną biblioteką, która
48 jest sercem serwera Apache HTTPD 2.x. APR ma wiele zestosowań, m. in.
49 dostępd do zaawansowanych funkcjonalnośći IO (takich jak sendfile,
50 epoll i OpenSSL), funkcjonalności posiomu systemu operacyjnego
51 (generacja liczb losowych, stan systemu, itp.) i natywną obsługę
52 procesów (współdzielona pamięć, potoki NT i gniazda uniksowe).
53
54 Te cechy pozwalają na wykorzystanie Tomcata jako sewera www do
55 zastosowań ogólnych, pozwalają na o wiele lepszą integrację z
56 innymi natywnymi technologiami www i w ogólności pozwalają na
57 traktowanie Javy jako zaawansowanej i kompletnej platformy www s nie
58 tylko technologii backendowej.
59
60 %package devel
61 Summary:        Header files for tcnative library
62 Summary(pl.UTF-8):      Pliki nagłówwkowe biblioteki tcnative
63 Group:          Development/Libraries
64 Requires:       %{name} = %{version}-%{release}
65
66 %description devel
67 Header files for tcnative library
68
69 %description devel -l pl.UTF-8
70 Pliki nagłówkowe biblioteki tcnative
71
72 %package static
73 Summary:        Static tcnative library
74 Summary(pl.UTF-8):      Statyczna biblioteka tcnative
75 Group:          Development/Libraries
76 Requires:       %{name}-devel = %{version}-%{release}
77
78 %description static
79 Static tcnative library.
80
81 %description static -l pl.UTF-8
82 Statyczna biblioteka tcnative.
83
84 %prep
85 %setup -q -n %{name}-%{version}-src
86
87 %build
88 # build java part
89 cd jni
90 %ant clean jar
91
92 # build native part
93 cd native
94 ./buildconf --with-apr=%{_datadir}/apr
95 %configure \
96         --with-java-home=%{java_home} \
97         --with-apr=/usr
98 %{__make}
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102
103 cd jni
104 install -d $RPM_BUILD_ROOT/%{_javadir}
105 install dist/tomcat-native-1.0.0.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native-1.0.0.jar
106 ln -s tomcat-native-1.0.0.jar $RPM_BUILD_ROOT/%{_javadir}/tomcat-native.jar
107
108 cd native
109 %{__make} install \
110         prefix=%{_prefix} \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 # Why Makefile doesn't do that?
114 install -d $RPM_BUILD_ROOT/%{_includedir}
115 install include/*.h $RPM_BUILD_ROOT/%{_includedir}
116
117 %clean
118 rm -rf $RPM_BUILD_ROOT
119
120 %post   -p /sbin/ldconfig
121 %postun -p /sbin/ldconfig
122
123 %files
124 %defattr(644,root,root,755)
125 %doc CHANGELOG.txt KEYS
126 %{_javadir}/%{name}-1.0.0.jar
127 %{_javadir}/%{name}.jar
128 %attr(755,root,root) %{_libdir}/libtcnative-1.so.0.1.16
129 %attr(755,root,root) %ghost %{_libdir}/libtcnative-1.so.0
130
131 %files devel
132 %defattr(644,root,root,755)
133 %{_libdir}/libtcnative-1.la
134 %{_libdir}/libtcnative-1.so
135 %{_pkgconfigdir}/tcnative-1.pc
136 %{_includedir}/*.h
137
138 %files static
139 %defattr(644,root,root,755)
140 %{_libdir}/libtcnative-1.a
This page took 0.058561 seconds and 2 git commands to generate.