]> git.pld-linux.org Git - packages/tla.git/blob - tla.spec
f899698407da60d0393c8fb2e19bf19ea5d33d2e
[packages/tla.git] / tla.spec
1 Name:           tla
2 Summary:        tla arch - revision control system
3 Summary(pl):    tla arch - systeme kontroli wersji
4 Version:        1.1pre7
5 Release:        1
6 License:        GPL v2
7 Group:          Development/Version Control
8 URL:            http://regexps.srparish.net/www/
9 Source0:        http://ftp.gnu.org/gnu/gnu-arch/%{name}-%{version}.tar.gz
10 # Source0-md5:  98542bdbcaf2e6146f41ba90a7643fc0
11 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
12
13 %description
14 tla arch is a revision control system: a program that lets
15 programmers archive a history of changes made to the software they
16 maintain and that, more importantly, helps programmers to coordinate,
17 synchronize, and combine multiple lines of development for a single
18 project.
19
20 arch version tla is a C version of the reference arch concepts.
21
22 %prep
23 %setup -q
24
25 ## using: rpmbuild -ba --target=i686-redhat-linux tls-1.0.6.spec
26
27 %build
28 cd %{_builddir}/%{name}-%{version}/src
29 mkdir =build
30 cd =build
31 ## imitate what an rpm macro would export
32 export CFLAGS="${RPM_OPT_FLAGS}" CXXFLAGS="${RPM_OPT_FLAGS}" FFLAGS="${RPM_OPT_FLAGS}";
33 ../configure --prefix=%{_prefix} --destdir=%{buildroot}
34 %{__make}
35 # ok, I tested already
36 %{__make} test
37
38
39 %install
40 rm -rf $RPM_BUILD_ROOT
41 rm -rf %{buildroot}
42 cd %{_builddir}/%{name}-%{version}/src/=build
43 %{__make} install
44 ## move some docs to a place the rpm doc macro likes
45 cd %{_builddir}/%{name}-%{version}
46 cp src/tla/=THANKS =THANKS
47 cp --recursive src/docs-tla/html html
48 cp --recursive src/docs-tla/ps ps
49 cp --recursive src/docs-tla/texi texi
50
51 # CLEANUP UNKNOWN USAGE DIRS
52 rm -rf %{buildroot}%{_libdir}
53 rm -rf %{buildroot}%{_prefix}/src
54
55
56 %clean
57 rm -rf %{buildroot}
58
59 %files
60 %defattr(644,root,root,755)
61 %doc COPYING =INSTALL =RELEASE-ID html ps texi
62 %attr(755,root,root) %{_bindir}
63 #{_includedir}
64 #{_libdir}
65 #{_libexecdir}
This page took 0.080227 seconds and 2 git commands to generate.