]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
- rel 11
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         snap            r4159
5 %define         xversion        1.9.3
6
7 Summary:        A TigerVNC remote display system
8 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
9 Name:           tigervnc
10 Version:        1.0.90
11 Release:        11
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 #Source0:       http://dl.sourceforge.net/tigervnc/%{name}-%{version}.tar.gz
15 Source0:        %{name}-%{version}-%{snap}.tar.bz2
16 # Source0-md5:  bd83717c960fb9e585387948b5cb41e2
17 Source1:        %{name}.desktop
18 Patch0:         tigervnc-cookie.patch
19 Patch1:         tigervnc-ldnow.patch
20 Patch2:         tigervnc-rh102434.patch
21 Patch3:         tigervnc-rh611677.patch
22 Patch4:         tigervnc-rh633931.patch
23 Patch5:         tigervnc-viewer-reparent.patch
24 Patch6:         tigervnc-as-needed.patch
25 Patch7:         tigervnc-options-dialog.patch
26 URL:            http://www.tigervnc.com/
27 BuildRequires:  ImageMagick
28 BuildRequires:  ImageMagick-coder-png
29 BuildRequires:  ImageMagick-coder-svg
30 BuildRequires:  cpp
31 BuildRequires:  gnutls-devel
32 BuildRequires:  libjpeg-devel
33 BuildRequires:  zlib-devel
34 BuildRequires:  xorg-xserver-server-source >= %{xversion}
35 # xserver BRs, should match xorg-xserver-server.spec
36 BuildRequires:  Mesa-libGL-devel >= 7.8.1
37 # for glx headers
38 BuildRequires:  OpenGL-GLX-devel
39 BuildRequires:  autoconf >= 2.57
40 BuildRequires:  automake
41 BuildRequires:  libdrm-devel >= 2.4.5
42 BuildRequires:  libtool
43 BuildRequires:  ncurses-devel
44 BuildRequires:  pam-devel
45 BuildRequires:  perl-base
46 BuildRequires:  pixman-devel >= 0.16.0
47 BuildRequires:  pkgconfig >= 1:0.19
48 BuildRequires:  xorg-app-mkfontscale
49 BuildRequires:  xorg-font-font-util >= 1.1
50 BuildRequires:  xorg-lib-libX11-devel
51 BuildRequires:  xorg-lib-libXau-devel
52 BuildRequires:  xorg-lib-libXaw-devel
53 BuildRequires:  xorg-lib-libXdamage-devel
54 BuildRequires:  xorg-lib-libXdmcp-devel
55 BuildRequires:  xorg-lib-libXext-devel  >= 1.0.99.4
56 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
57 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
58 BuildRequires:  xorg-lib-libXmu-devel
59 BuildRequires:  xorg-lib-libXpm-devel
60 BuildRequires:  xorg-lib-libXrender-devel
61 BuildRequires:  xorg-lib-libXres-devel
62 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
63 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
64 BuildRequires:  xorg-lib-libXv-devel
65 BuildRequires:  xorg-lib-libXxf86dga-devel
66 BuildRequires:  xorg-lib-libXxf86misc-devel
67 BuildRequires:  xorg-lib-libXxf86vm-devel
68 BuildRequires:  xorg-lib-libfontenc-devel
69 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
70 BuildRequires:  xorg-lib-libxkbfile-devel
71 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
72 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
73 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
74 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
75 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
76 BuildRequires:  xorg-proto-fontcacheproto-devel
77 BuildRequires:  xorg-proto-fontsproto-devel
78 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
79 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
80 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
81 BuildRequires:  xorg-proto-printproto-devel
82 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
83 BuildRequires:  xorg-proto-recordproto-devel
84 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
85 BuildRequires:  xorg-proto-resourceproto-devel
86 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
87 BuildRequires:  xorg-proto-videoproto-devel
88 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
89 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
90 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
91 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
92 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
93 BuildRequires:  xorg-proto-xf86miscproto-devel
94 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
95 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
96 BuildRequires:  xorg-util-util-macros >= 1.10
97 Provides:       vnc-client
98 Conflicts:      vnc
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source 2> /dev/null)
102
103 %description
104 TigerVNC is a suite of VNC servers and clients that have a focus on
105 performance and remote display functionality. Originally this software
106 was based on the (never released) VNC 4 branch of TightVNC.
107
108 %description -l pl.UTF-8
109 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
110 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
111 oprogramowanie oparte było na (nigdy nie wydanej)
112 gałęzi VNC 4 TightVNC.
113
114 %package server
115 Summary:        VNC X server - TigerVNC version
116 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
117 Group:          X11/Applications/Networking
118 Requires:       xorg-app-rgb
119 # for vncpasswd tool
120 Requires:       %{name}-utils = %{version}-%{release}
121 # for mcookie
122 Requires:       util-linux
123 Obsoletes:      vnc-server
124
125 %description server
126 This package contains VNC X server in TigerVNC version.
127
128 %description server -l pl.UTF-8
129 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
130
131 %package utils
132 Summary:        Additional utilities for TigerVNC
133 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
134 Group:          X11/Applications/Networking
135 Obsoletes:      vnc-utils
136
137 %description utils
138 This package contains additional TigerVNC utilities: vncconfig and
139 vncpasswd. vncconfig is used to configure and control a running
140 instance of Xvnc, or any other X server with the VNC extension.
141 vncpasswd generates password file (both on server and viewer side).
142
143 %description utils -l pl.UTF-8
144 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
145 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
146 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
147 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
148 stronie serwera, jak i przeglądarki).
149
150 %package -n xorg-xserver-libvnc
151 Summary:        TigerVNC module for X.org server
152 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
153 Group:          X11/Servers
154 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
155 Provides:       xorg-xserver-module(vnc)
156
157 %description -n xorg-xserver-libvnc
158 This package contains libvnc.so module for X.org server,
159 allowing others to access the desktop on your machine.
160
161 %description -n xorg-xserver-libvnc -l pl.UTF-8
162 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
163 pozwalający na zdalny dostęp do pulpitu.
164
165 %prep
166 %setup -q -n %{name}
167 %patch0 -p1
168 %patch1 -p1
169 %patch2 -p1
170 %patch3 -p1
171 %patch4 -p1
172 %patch5 -p1
173 %patch6 -p1
174 %patch7 -p1
175
176 %{__sed} -i -e 's|^po/Makefile.in||' configure.ac
177
178 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
179 cd unix/xserver
180 patch -p1 <../xserver19.patch
181
182 %build
183 %{__gettextize}
184 %{__libtoolize}
185 %{__aclocal}
186 %{__autoconf}
187 %{__autoheader}
188 %{__automake}
189
190 %{configure} \
191         --with-system-jpeg
192
193 %{__make}
194
195 cd unix/xserver
196 %{__automake}
197 %{__autoconf}
198 %configure \
199         --with-os-name="PLD/Linux" \
200         --with-os-vendor="PLD/Team" \
201         --disable-config-dbus \
202         --disable-config-hal \
203         --disable-config-udev \
204         --disable-builddocs \
205         --without-xmlto \
206         --without-fop \
207         --without-doxygen \
208         --disable-devel-docs \
209         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
210         --disable-xorg \
211         --disable-xnest \
212         --disable-xvfb \
213         --disable-dmx \
214         --disable-xwin \
215         --disable-xephyr \
216         --disable-kdrive \
217         --disable-xfbdev \
218         --disable-dri2 \
219         --with-pic \
220         --disable-static \
221         --disable-xinerama \
222         --disable-composite \
223         --enable-glx \
224         --enable-glx-tls \
225         --enable-aiglx \
226         --enable-dga \
227         --enable-glx-tls \
228         --enable-install-libxf86config \
229         --enable-record \
230         --disable-xsdl \
231         --disable-xfake \
232         --enable-secure-rpc \
233         --with-dri-driver-path=%{_libdir}/xorg/modules/dri \
234         --with-xkb-output=/var/lib/xkb
235
236 %{__make}
237 cd -
238
239 cd media
240 %{__make}
241
242 %install
243 rm -rf $RPM_BUILD_ROOT
244 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
245         $RPM_BUILD_ROOT%{_desktopdir}
246
247 %{__make} install \
248         DESTDIR=$RPM_BUILD_ROOT
249
250 cd unix/xserver/hw/vnc
251 %{__make} install \
252         DESTDIR=$RPM_BUILD_ROOT
253 cd -
254
255 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
256
257 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
258 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
259 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
260 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
261 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
262 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
263
264 %find_lang %{name}
265
266 %clean
267 rm -rf $RPM_BUILD_ROOT
268
269 %post
270 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
271 [ ! -x /usr/bin/gtk-update-icon-cache ] || %update_icon_cache hicolor
272
273 %postun
274 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
275 [ ! -x /usr/bin/gtk-update-icon-cache ] || %update_icon_cache hicolor
276
277 %files -f %{name}.lang
278 %defattr(644,root,root,755)
279 %doc doc/*
280 %attr(755,root,root) %{_bindir}/vncviewer
281 %{_mandir}/man1/vncviewer.1*
282 %{_desktopdir}/tigervnc.desktop
283 %{_iconsdir}/hicolor/*/apps/tigervnc.*
284
285 %files server
286 %defattr(644,root,root,755)
287 %attr(755,root,root) %{_bindir}/Xvnc
288 %attr(755,root,root) %{_bindir}/vncserver
289 %attr(755,root,root) %{_bindir}/x0vncserver
290 %{_mandir}/man1/Xvnc.1*
291 %{_mandir}/man1/vncserver.1*
292 %{_mandir}/man1/x0vncserver.1*
293
294 %files utils
295 %defattr(644,root,root,755)
296 %attr(755,root,root) %{_bindir}/vncconfig
297 %attr(755,root,root) %{_bindir}/vncpasswd
298 %{_mandir}/man1/vncconfig.1*
299 %{_mandir}/man1/vncpasswd.1*
300
301 %files -n xorg-xserver-libvnc
302 %defattr(644,root,root,755)
303 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.185713 seconds and 4 git commands to generate.