]> git.pld-linux.org Git - packages/tigervnc.git/blob - tigervnc.spec
e8b06424c998dd1da643dc528ff42a8fd1b818b5
[packages/tigervnc.git] / tigervnc.spec
1 # TODO:
2 # - tigervnc.init
3
4 %define         snap            r4237
5 %define         xversion        1.10.0
6
7 Summary:        A TigerVNC remote display system
8 Summary(pl.UTF-8):      System zdalnego dostępu TigerVNC
9 Name:           tigervnc
10 Version:        1.1.0
11 Release:        3
12 License:        GPL v2
13 Group:          X11/Applications/Networking
14 Source0:        http://dl.sourceforge.net/tigervnc/1.1.0/%{name}-%{version}.tar.gz
15 # Source0-md5:  1a5598b4a2ac530fb51411438959e11e
16 Source1:        %{name}.desktop
17 Patch0:         %{name}-cookie.patch
18 Patch1:         %{name}-ldnow.patch
19 Patch2:         %{name}-rh102434.patch
20 Patch3:         %{name}-viewer-reparent.patch
21 Patch4:         %{name}-as-needed.patch
22 URL:            http://www.tigervnc.com/
23 BuildRequires:  ImageMagick
24 BuildRequires:  ImageMagick-coder-png
25 BuildRequires:  ImageMagick-coder-svg
26 BuildRequires:  Mesa-libGL-devel >= 7.8.1
27 BuildRequires:  cpp
28 BuildRequires:  gnutls-devel
29 BuildRequires:  libjpeg-turbo-devel
30 BuildRequires:  xorg-xserver-server-source >= %{xversion}
31 BuildRequires:  zlib-devel
32 # xserver BRs, should match xorg-xserver-server.spec
33 # for glx headers
34 BuildRequires:  OpenGL-GLX-devel
35 BuildRequires:  autoconf >= 2.57
36 BuildRequires:  automake
37 BuildRequires:  libdrm-devel >= 2.4.5
38 BuildRequires:  libtool
39 BuildRequires:  nasm
40 BuildRequires:  ncurses-devel
41 BuildRequires:  pam-devel
42 BuildRequires:  perl-base
43 BuildRequires:  pixman-devel >= 0.16.0
44 BuildRequires:  pkgconfig >= 1:0.19
45 BuildRequires:  xorg-app-mkfontscale
46 BuildRequires:  xorg-font-font-util >= 1.1
47 BuildRequires:  xorg-lib-libX11-devel
48 BuildRequires:  xorg-lib-libXau-devel
49 BuildRequires:  xorg-lib-libXaw-devel
50 BuildRequires:  xorg-lib-libXdamage-devel
51 BuildRequires:  xorg-lib-libXdmcp-devel
52 BuildRequires:  xorg-lib-libXext-devel >= 1.0.99.4
53 BuildRequires:  xorg-lib-libXfont-devel >= 1.4.2
54 BuildRequires:  xorg-lib-libXi-devel >= 1.2.99.1
55 BuildRequires:  xorg-lib-libXmu-devel
56 BuildRequires:  xorg-lib-libXpm-devel
57 BuildRequires:  xorg-lib-libXrender-devel
58 BuildRequires:  xorg-lib-libXres-devel
59 BuildRequires:  xorg-lib-libXt-devel >= 1.0.0
60 BuildRequires:  xorg-lib-libXtst-devel >= 1.0.99.2
61 BuildRequires:  xorg-lib-libXv-devel
62 BuildRequires:  xorg-lib-libXxf86dga-devel
63 BuildRequires:  xorg-lib-libXxf86misc-devel
64 BuildRequires:  xorg-lib-libXxf86vm-devel
65 BuildRequires:  xorg-lib-libfontenc-devel
66 BuildRequires:  xorg-lib-libpciaccess-devel >= 0.8.0
67 BuildRequires:  xorg-lib-libxkbfile-devel
68 BuildRequires:  xorg-lib-libxkbui-devel >= 1.0.2
69 BuildRequires:  xorg-lib-xtrans-devel >= 1.2.2
70 BuildRequires:  xorg-proto-bigreqsproto-devel >= 1.1.0
71 BuildRequires:  xorg-proto-damageproto-devel >= 1.1
72 BuildRequires:  xorg-proto-fixesproto-devel >= 4.1
73 BuildRequires:  xorg-proto-fontcacheproto-devel
74 BuildRequires:  xorg-proto-fontsproto-devel
75 BuildRequires:  xorg-proto-glproto-devel >= 1.4.10
76 BuildRequires:  xorg-proto-inputproto-devel >= 1.9.99.902
77 BuildRequires:  xorg-proto-kbproto-devel >= 1.0.3
78 BuildRequires:  xorg-proto-printproto-devel
79 BuildRequires:  xorg-proto-randrproto-devel >= 1.2.99.3
80 BuildRequires:  xorg-proto-recordproto-devel
81 BuildRequires:  xorg-proto-renderproto-devel >= 0.11
82 BuildRequires:  xorg-proto-resourceproto-devel
83 BuildRequires:  xorg-proto-scrnsaverproto-devel >= 1.1.0
84 BuildRequires:  xorg-proto-videoproto-devel
85 BuildRequires:  xorg-proto-xcmiscproto-devel >= 1.2.0
86 BuildRequires:  xorg-proto-xextproto-devel >= 1:7.0.99.3
87 BuildRequires:  xorg-proto-xf86bigfontproto-devel >= 1.2.0
88 BuildRequires:  xorg-proto-xf86dgaproto-devel >= 2.0.99.1
89 BuildRequires:  xorg-proto-xf86driproto-devel >= 2.1.0
90 BuildRequires:  xorg-proto-xf86miscproto-devel
91 BuildRequires:  xorg-proto-xf86vidmodeproto-devel >= 2.2.99.1
92 BuildRequires:  xorg-proto-xproto-devel >= 7.0.17
93 BuildRequires:  xorg-util-util-macros >= 1.10
94 Requires(post,postun):  gtk-update-icon-cache
95 Requires(post,postun):  hicolor-icon-theme
96 Requires:       libjpeg-turbo
97 Provides:       vnc-client
98 Conflicts:      vnc
99 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
100
101 %define         _xserverver     %(LC_ALL=C rpm -q --qf '%{V}' xorg-xserver-server-source 2> /dev/null)
102
103 %description
104 TigerVNC is a suite of VNC servers and clients that have a focus on
105 performance and remote display functionality. Originally this software
106 was based on the (never released) VNC 4 branch of TightVNC.
107
108 %description -l pl.UTF-8
109 TigerVNC to zestaw serwerów i klientów VNC, które koncentrują się
110 na wydajności i funkcjonalności zdalnego wyświetlania. Pierwotnie
111 oprogramowanie oparte było na (nigdy nie wydanej)
112 gałęzi VNC 4 TightVNC.
113
114 %package server
115 Summary:        VNC X server - TigerVNC version
116 Summary(pl.UTF-8):      X serwer VNC - wersja TigerVNC
117 Group:          X11/Applications/Networking
118 Requires:       xorg-app-rgb
119 # for vncpasswd tool
120 Requires:       %{name}-utils = %{version}-%{release}
121 # for mcookie
122 Requires:       util-linux
123 Requires:       libjpeg-turbo
124 Obsoletes:      vnc-server
125
126 %description server
127 This package contains VNC X server in TigerVNC version.
128
129 %description server -l pl.UTF-8
130 Ten pakiet zawiera X serwer VNC w wersji TigerVNC.
131
132 %package utils
133 Summary:        Additional utilities for TigerVNC
134 Summary(pl.UTF-8):      Dodatkowe narzędzia do TigerVNC
135 Group:          X11/Applications/Networking
136 Obsoletes:      vnc-utils
137
138 %description utils
139 This package contains additional TigerVNC utilities: vncconfig and
140 vncpasswd. vncconfig is used to configure and control a running
141 instance of Xvnc, or any other X server with the VNC extension.
142 vncpasswd generates password file (both on server and viewer side).
143
144 %description utils -l pl.UTF-8
145 Ten pakiet zawiera dodatkowe narzędzia do tightvnc: vncconfig i
146 vncpasswd. vncconfig służy do konfigurowania i kontroli działającej
147 instancji Xvnc lub innego serwera X z rozszerzeniem VNC.
148 vncpasswd służy to tworzenia pliku z hasłem (zarówno po
149 stronie serwera, jak i przeglądarki).
150
151 %package -n xorg-xserver-libvnc
152 Summary:        TigerVNC module for X.org server
153 Summary(pl.UTF-8):      Moduł TigerVNC dla servera X.org
154 Group:          X11/Servers
155 %requires_eq_to xorg-xserver-server xorg-xserver-server-source
156 Provides:       xorg-xserver-module(vnc)
157
158 %description -n xorg-xserver-libvnc
159 This package contains libvnc.so module for X.org server,
160 allowing others to access the desktop on your machine.
161
162 %description -n xorg-xserver-libvnc -l pl.UTF-8
163 Ten pakiet zawiera moduł libvnc.so dla serwera X.org,
164 pozwalający na zdalny dostęp do pulpitu.
165
166 %prep
167 %setup -q
168 %patch0 -p1
169 %patch1 -p1
170 %patch2 -p1
171 %patch3 -p1
172 %patch4 -p1
173
174 cp -a %{_usrsrc}/xorg-xserver-server-%{_xserverver}/* unix/xserver
175 cd unix/xserver
176 patch -p1 <../xserver110.patch
177 cd -
178
179 %build
180 %{__gettextize}
181 %{__libtoolize}
182 %{__aclocal}
183 %{__autoconf}
184 %{__autoheader}
185 %{__automake}
186
187 %{configure} \
188         --with-system-jpeg
189
190 %{__make}
191
192 cd unix/xserver
193 %{__automake}
194 %{__autoconf}
195 %configure \
196         --with-os-name="PLD/Linux" \
197         --with-os-vendor="PLD/Team" \
198         --disable-config-dbus \
199         --disable-config-hal \
200         --disable-config-udev \
201         --without-xmlto \
202         --without-fop \
203         --without-doxygen \
204         --disable-devel-docs \
205         --with-default-font-path="%{_fontsdir}/misc,%{_fontsdir}/TTF,%{_fontsdir}/OTF,%{_fontsdir}/Type1,%{_fontsdir}/100dpi,%{_fontsdir}/75dpi" \
206         --disable-xorg \
207         --disable-xnest \
208         --disable-xvfb \
209         --disable-dmx \
210         --disable-xwin \
211         --disable-xephyr \
212         --disable-kdrive \
213         --disable-xfbdev \
214         --disable-dri2 \
215         --with-pic \
216         --disable-static \
217         --disable-xinerama \
218         --disable-composite \
219         --enable-glx \
220         --enable-glx-tls \
221         --enable-aiglx \
222         --enable-dga \
223         --enable-glx-tls \
224         --enable-install-libxf86config \
225         --enable-record \
226         --disable-xfake \
227         --enable-secure-rpc \
228         --with-xkb-output=/var/lib/xkb
229
230 %{__make}
231 cd -
232
233 cd media
234 %{__make}
235
236 %install
237 rm -rf $RPM_BUILD_ROOT
238 install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/{16x16,22x22,24x24,32x32,48x48,scalable}/apps \
239         $RPM_BUILD_ROOT%{_desktopdir}
240
241 %{__make} install \
242         DESTDIR=$RPM_BUILD_ROOT
243
244 cd unix/xserver/hw/vnc
245 %{__make} install \
246         DESTDIR=$RPM_BUILD_ROOT
247 cd -
248
249 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
250
251 install media/icons/tigervnc_16.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/16x16/apps/tigervnc.png
252 install media/icons/tigervnc_22.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/22x22/apps/tigervnc.png
253 install media/icons/tigervnc_24.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/24x24/apps/tigervnc.png
254 install media/icons/tigervnc_32.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/32x32/apps/tigervnc.png
255 install media/icons/tigervnc_48.png $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/tigervnc.png
256 install media/icons/tigervnc.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/tigervnc.svg
257
258 %find_lang %{name}
259
260 %clean
261 rm -rf $RPM_BUILD_ROOT
262
263 %post
264 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_post
265 %update_icon_cache hicolor
266
267 %postun
268 [ ! -x /usr/bin/update-desktop-database ] || %update_desktop_database_postun
269 %update_icon_cache hicolor
270
271 %files -f %{name}.lang
272 %defattr(644,root,root,755)
273 %doc doc/*
274 %attr(755,root,root) %{_bindir}/vncviewer
275 %{_mandir}/man1/vncviewer.1*
276 %{_desktopdir}/tigervnc.desktop
277 %{_iconsdir}/hicolor/*/apps/tigervnc.*
278
279 %files server
280 %defattr(644,root,root,755)
281 %attr(755,root,root) %{_bindir}/Xvnc
282 %attr(755,root,root) %{_bindir}/vncserver
283 %attr(755,root,root) %{_bindir}/x0vncserver
284 %{_mandir}/man1/Xvnc.1*
285 %{_mandir}/man1/vncserver.1*
286 %{_mandir}/man1/x0vncserver.1*
287
288 %files utils
289 %defattr(644,root,root,755)
290 %attr(755,root,root) %{_bindir}/vncconfig
291 %attr(755,root,root) %{_bindir}/vncpasswd
292 %{_mandir}/man1/vncconfig.1*
293 %{_mandir}/man1/vncpasswd.1*
294
295 %files -n xorg-xserver-libvnc
296 %defattr(644,root,root,755)
297 %attr(755,root,root) %{_libdir}/xorg/modules/extensions/libvnc.so
This page took 0.035802 seconds and 2 git commands to generate.