]> git.pld-linux.org Git - packages/thunderbird.git/commitdiff
- skip subshell in shell wrapper in normal mode
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 9 Sep 2010 12:34:34 +0000 (12:34 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- require sqlite with SQLITE_SECURE_DELETE enabled

Changed files:
    icedove.spec -> 1.102
    no-subshell.patch -> 1.1

icedove.spec
no-subshell.patch [new file with mode: 0644]

index f119ab50f5df6f0d5d6b189a6b4039465b20088a..caea23bc5cae8101989e13371d31b8921341b2a6 100644 (file)
@@ -57,6 +57,7 @@ Patch8:               %{name}-makefile.patch
 Patch9:                %{name}-libpng.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
+Patch12:       no-subshell.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 %{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
 BuildRequires: alsa-lib-devel
@@ -80,7 +81,7 @@ BuildRequires:        nss-devel >= 1:3.12.0
 BuildRequires: pango-devel >= 1:1.1.0
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.6.22
+BuildRequires: sqlite3-devel >= 3.7.2-2
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
@@ -186,6 +187,7 @@ cd mozilla
 %patch9 -p0
 %patch10 -p2
 %patch11 -p2
+%patch12 -p1
 
 %build
 cd mozilla
diff --git a/no-subshell.patch b/no-subshell.patch
new file mode 100644 (file)
index 0000000..e292fcc
--- /dev/null
@@ -0,0 +1,27 @@
+--- iceweasel-3.0.10/mozilla/build/unix/run-mozilla.sh~        2007-09-04 20:09:31.000000000 +0300
++++ iceweasel-3.0.10/mozilla/build/unix/run-mozilla.sh 2009-05-05 19:20:55.718561642 +0300
+@@ -438,7 +438,8 @@
+ then
+       moz_debug_program ${1+"$@"}
+ else
+-      moz_run_program ${1+"$@"}
++      exec "$MOZ_PROGRAM" ${1+"$@"}
++      # NORETURN
+ fi
+ exit $exitcode
+--- iceweasel-3.0.10/mozilla/build/unix/mozilla.in~    2007-10-05 10:29:26.000000000 +0300
++++ iceweasel-3.0.10/mozilla/build/unix/mozilla.in     2009-05-05 19:26:08.278322082 +0300
+@@ -135,8 +135,11 @@
+ if [ $debugging = 1 ]
+ then
+   echo $dist_bin/run-mozilla.sh $script_args $dist_bin/$MOZILLA_BIN "$@"
++  "$dist_bin/run-mozilla.sh" $script_args "$dist_bin/$MOZILLA_BIN" "$@"
++else
++  exec "$dist_bin/run-mozilla.sh" $script_args "$dist_bin/$MOZILLA_BIN" "$@"
++  # NORETURN
+ fi
+-"$dist_bin/run-mozilla.sh" $script_args "$dist_bin/$MOZILLA_BIN" "$@"
+ exitcode=$?
+ exit $exitcode
This page took 0.590456 seconds and 4 git commands to generate.