]> git.pld-linux.org Git - packages/thunderbird.git/commitdiff
Updated to 15.0 and engmail to 1.4.4
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 29 Aug 2012 12:32:59 +0000 (14:32 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 29 Aug 2012 12:32:59 +0000 (14:32 +0200)
Build with (PLD compliant) system virtualenv

crashreporter.patch
icedove-branding.patch
icedove-install.patch
icedove-makefile.patch
icedove.spec
system-cairo.patch
system-virtualenv.patch [new file with mode: 0644]

index dfe3a174ec346d2f3c61e12033fb26dcc42557db..df44594ad297cac5ee7e9222b40ed381ac606f67 100644 (file)
@@ -8,14 +8,3 @@
  
  #include <algorithm>
  #include <cassert>
---- icedove-3.1.2/mozilla/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in~ 2010-08-17 18:24:25.755776132 +0300
-+++ icedove-3.1.2/mozilla/mozilla/toolkit/crashreporter/google-breakpad/src/tools/linux/dump_syms/Makefile.in  2010-08-17 19:16:17.356296784 +0300
-@@ -62,8 +62,4 @@
- CPP_PROG_LINK = 1
- FORCE_USE_PIC = 1
--#XXX: bug 554854 causes us to be unable to run binaries on the build slaves
--# due to them having an older libstdc++
--HOST_LDFLAGS += -static
--
- include $(topsrcdir)/config/rules.mk
index a1c69c49e7abdd96b40a2d2ea3d60553fc9e0f55..012d834307ca379d7105afba2b55a868ef1c1392 100644 (file)
                  label="&featureConfiguratorCmd.label;"
 --- mozilla/mail/confvars.sh~  2011-08-12 15:52:05.000000000 +0200
 +++ mozilla/mail/confvars.sh   2011-09-17 15:34:33.613167078 +0200
-@@ -36,7 +36,7 @@
- #
- # ***** END LICENSE BLOCK *****
+@@ -36,8 +36,8 @@
+ # License, v. 2.0. If a copy of the MPL was not distributed with this
+ # file, You can obtain one at http://mozilla.org/MPL/2.0/.
  
+-MOZ_APP_BASENAME=Thunderbird
 -MOZ_APP_NAME=thunderbird
++MOZ_APP_BASENAME=Icedove
 +MOZ_APP_NAME=icedove
  MOZ_UPDATER=1
  MOZ_THUNDERBIRD=1
index a3ad9e2eba85b22e7675ed774f03f151d2744c0b..a45e2936915d9f959b763b5fc7dc1761a9768c68 100644 (file)
@@ -1,31 +1,34 @@
 --- mozilla/mozilla/toolkit/mozapps/installer/packager.mk.orig 2012-03-13 03:43:47.000000000 +0100
 +++ mozilla/mozilla/toolkit/mozapps/installer/packager.mk      2012-03-24 21:50:54.171788606 +0100
-@@ -708,35 +708,35 @@
+@@ -708,37 +708,37 @@
  endif
  
  stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_REMOVALS_GEN) elfhack
--      @rm -rf $(DIST)/$(MOZ_PKG_DIR) $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
-+      @rm -rf $(DESTDIR)/$(MOZ_PKG_DIR) $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
+-      @rm -rf $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
++      @rm -rf $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
+ ifndef MOZ_FAST_PACKAGE
+-      @rm -rf $(DIST)/$(MOZ_PKG_DIR)
++      @rm -rf $(DESTDIR)/$(MOZ_PKG_DIR)
+ endif
  # NOTE: this must be a tar now that dist links into the tree so that we
  # do not strip the binaries actually in the tree.
        @echo "Creating package directory..."
--      @mkdir $(DIST)/$(MOZ_PKG_DIR)
-+      @mkdir $(DESTDIR)/$(MOZ_PKG_DIR)
+-      if ! test -d $(DIST)/$(MOZ_PKG_DIR) ; then \
+-              mkdir $(DIST)/$(MOZ_PKG_DIR); \
++      if ! test -d $(DESTDIR)/$(MOZ_PKG_DIR) ; then \
++              mkdir $(DESTDIR)/$(MOZ_PKG_DIR); \
+       fi
  ifndef UNIVERSAL_BINARY
  # If UNIVERSAL_BINARY, the package will be made from an already-prepared
  # STAGEPATH
  ifdef MOZ_PKG_MANIFEST
+ ifndef MOZ_FAST_PACKAGE
        $(RM) -rf $(DIST)/xpt $(DIST)/manifests
+ endif
        $(call PACKAGER_COPY, "$(call core_abspath,$(DIST))",\
 -        "$(call core_abspath,$(DIST)/$(MOZ_PKG_DIR))", \
 +        "$(call core_abspath,$(DESTDIR)/$(MOZ_PKG_DIR))", \
          "$(MOZ_PKG_MANIFEST)", "$(PKGCP_OS)", 1, 0, 1)
- ifeq (DMG, $(MOZ_PKG_FORMAT))
- ifeq (dmg, $(filter dmg, $(MOZ_INTERNAL_SIGNING_FORMAT)))
--      @cd $(DIST)/$(_APPNAME)/Contents && ln -sf _CodeSignature/CodeResources CodeResources
-+      @cd $(DESTDIR)/$(_APPNAME)/Contents && ln -sf _CodeSignature/CodeResources CodeResources
- endif
- endif
 -      $(PERL) $(MOZILLA_DIR)/toolkit/mozapps/installer/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
 +      $(PERL) $(MOZILLA_DIR)/toolkit/mozapps/installer/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
        $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
@@ -43,7 +46,7 @@
 -      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
 +      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
  else # !MOZ_PKG_MANIFEST
- ifeq ($(MOZ_PKG_FORMAT),DMG)
+ ifeq ($(MOZ_WIDGET_TOOLKIT),cocoa)
  ifndef STAGE_SDK
 @@ -741,10 +741,10 @@
        @$(NSINSTALL) -D $(DIST)/xpt
index ef2f8496bef3a8c37717fb7f6d45cf90f69ef80d..19143c44953f43333ddd9ebdecded0dc9f69b604 100644 (file)
@@ -1,18 +1,11 @@
 --- icedove-6.0/mozilla/Makefile.in~   2011-08-12 16:52:03.000000000 +0300
 +++ icedove-6.0/mozilla/Makefile.in    2011-08-26 13:00:59.373870016 +0300
-@@ -58,8 +58,6 @@
+@@ -26,21 +26,7 @@
  
  include $(topsrcdir)/config/config.mk
  
 -default alldep all:: $(topsrcdir)/configure config.status
 -
- ifndef INCLUDED_BRIDGE_MK
- include $(topsrcdir)/bridge/bridge.mk
- endif
-@@ -67,19 +65,7 @@
- # workaround Bug 599809 by making these makefiles be generated here
- SUBMAKEFILES += $(addsuffix /Makefile, $(APP_LIBXUL_DIRS) $(APP_LIBXUL_STATICDIRS))
 -$(topsrcdir)/configure: $(topsrcdir)/configure.in
 -      @echo "STOP!  configure.in has changed, and your configure is out of date."
 -      @echo "Please rerun autoconf and configure."
index 365b99cb4a8d57ca0f1e5ac999942663d3d3d24f..b7e49c35bb39e0a789a72bf5856503e729644ced 100644 (file)
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.4.3
+%define                enigmail_ver    1.4.4
 %define                nspr_ver        4.9
 %define                nss_ver         3.13.3
 
-%define                xulrunner_ver   2:13.0
+%define                xulrunner_ver   2:15.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       14.0
+Version:       15.0
 Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 64dcfaa0aa47aa5fd8588090503fac9d
+# Source0-md5: e41f88ca2fd0c9bc608aa2c145b3bc2c
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 4a253db11436a32ef81d5917c4ee6e25
+# Source1-md5: 1bc36b5077f6b01b6acf0f75565dddc8
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -59,6 +59,8 @@ Patch9:               system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
+# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
+Patch13:       system-virtualenv.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -201,6 +203,7 @@ cd mozilla
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
+%patch13 -p1
 
 %build
 cd mozilla
index 9ae0888005edb047de5f9f4166545599ed8fa811..d3958220f1295df279a2d71fcddc17ede1739685 100644 (file)
@@ -25,21 +25,16 @@ diff -r baec1efc87a4 gfx/thebes/gfxPlatform.cpp
  {
    void *userData = aSurface->GetData(&kSourceSurface);
  
-@@ -524,24 +522,18 @@ gfxPlatform::GetSourceSurfaceForSurface(
-         NS_RUNTIMEABORT("Invalid surface format!");
-     }
+@@ -524,14 +522,8 @@ gfxPlatform::GetSourceSurfaceForSurface(
  
-     srcBuffer = aTarget->CreateSourceSurfaceFromData(imgSurface->Data(),
-                                                      IntSize(imgSurface->GetSize().width, imgSurface->GetSize().height),
-                                                      imgSurface->Stride(),
-                                                      format);
+     }
  
 -    cairo_surface_t *nullSurf =
 -      cairo_null_surface_create(CAIRO_CONTENT_COLOR_ALPHA);
 -    cairo_surface_set_user_data(nullSurf,
--                              &kSourceSurface,
--                              imgSurface,
--                              NULL);
+-                                &kSourceSurface,
+-                                imgSurface,
+-                                NULL);
 -    cairo_surface_attach_snapshot(imgSurface->CairoSurface(), nullSurf, SourceSnapshotDetached);
 -    cairo_surface_destroy(nullSurf);
 +    cairo_surface_set_mime_data(imgSurface->CairoSurface(), "mozilla/magic",
@@ -47,8 +42,3 @@ diff -r baec1efc87a4 gfx/thebes/gfxPlatform.cpp
    }
  
    srcBuffer->AddRef();
-   aSurface->SetData(&kSourceSurface, srcBuffer, SourceBufferDestroy);
-   return srcBuffer;
- }
diff --git a/system-virtualenv.patch b/system-virtualenv.patch
new file mode 100644 (file)
index 0000000..bc76d83
--- /dev/null
@@ -0,0 +1,24 @@
+Restore --system-site-packages when system virtualenv gets 1.7 upgrade
+
+--- xulrunner-15.0/mozilla/configure.in~       2012-08-29 11:06:34.517985819 +0200
++++ xulrunner-15.0/mozilla/configure.in        2012-08-29 11:23:47.234616054 +0200
+@@ -9069,7 +9069,7 @@
+ AC_MSG_RESULT([Creating Python virtualenv])
+ rm -rf _virtualenv
+ mkdir -p _virtualenv
+-MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= $PYTHON $_topsrcdir/other-licenses/virtualenv/virtualenv.py --system-site-packages ./_virtualenv
++MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= /usr/bin/virtualenv ./_virtualenv
+ case "$host_os" in
+ mingw*)
+     PYTHON=`pwd`/_virtualenv/Scripts/python.exe
+--- xulrunner-15.0/mozilla/configure~  2012-08-29 11:25:28.121279162 +0200
++++ xulrunner-15.0/mozilla/configure   2012-08-29 11:27:27.981274936 +0200
+@@ -25468,7 +25468,7 @@
+ echo "$ac_t""Creating Python virtualenv" 1>&6
+ rm -rf _virtualenv
+ mkdir -p _virtualenv
+-MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= $PYTHON $_topsrcdir/other-licenses/virtualenv/virtualenv.py --system-site-packages ./_virtualenv
++MACOSX_DEPLOYMENT_TARGET= PYTHONDONTWRITEBYTECODE= /usr/bin/virtualenv ./_virtualenv
+ case "$host_os" in
+ mingw*)
+     PYTHON=`pwd`/_virtualenv/Scripts/python.exe
This page took 0.839202 seconds and 4 git commands to generate.