]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - icedove.spec
- updated to 17.0, enigmail 1.4.6
[packages/thunderbird.git] / icedove.spec
index 3a105f429642a3faa8ec66ade98371b3491a7def..ef016babd51b11e3bd3b01eb7abe430cff710e2a 100644 (file)
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.4
+%define                enigmail_ver    1.4.6
 %define                nspr_ver        4.9
 %define                nss_ver         3.13.3
 
-# convert thunderbird release number to platform version: 12.0.x -> 12.0.x
-%define                xulrunner_main  12.0
-%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#11.0})
+%define                xulrunner_ver   2:15.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       12.0
-Release:       1
+Version:       17.0
+Release:       0.1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 7b30b72472a65bce74ba0ae60e4d4e6c
+# Source0-md5: f3690660044337273efb52f79cb15b0e
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 5cf3d9720ed1cda1b22eabe5457772c2
+# Source1-md5: 3d42cff27e0f8da24bdabf8363d8261f
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -57,11 +55,12 @@ Patch5:             %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-# this is only workaround, check if it is fixed with newer firefox
-Patch9:                bug-722975-workaround.patch
+Patch9:                system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
+# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
+Patch13:       system-virtualenv.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -97,7 +96,7 @@ BuildRequires:        xorg-lib-libXt-devel
 BuildRequires: yasm
 BuildRequires: zip
 %if %{with xulrunner}
-BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
+BuildRequires: xulrunner-devel >= %{xulrunner_ver}
 %else
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
@@ -110,16 +109,19 @@ Requires(post):   mktemp >= 1.5-18
 %endif
 Obsoletes:     mozilla-thunderbird
 Obsoletes:     mozilla-thunderbird-dictionary-en-US
+Conflicts:     icedove-lang-resources < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
 # iceweasel/icedove/iceape provide their own versions
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
-# we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libmozjs.so libxpcom.so libxul.so
+%if %{without xulrunner}
+# we don't want these to satisfy packages depending on xulrunner
+%define                _noautoprov             libmozalloc.so libxpcom.so libxul.so
 # and as we don't provide them, don't require either
-%define                _noautoreq              libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq              libmozalloc.so libxpcom.so libxul.so
+%endif
 
 %define                topdir          %{_builddir}/%{name}-%{version}
 %define                objdir          %{topdir}/obj-%{_target_cpu}
@@ -197,12 +199,11 @@ cd mozilla
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
-cd mozilla
 %patch9 -p1
-cd -
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
+%patch13 -p1
 
 %build
 cd mozilla
@@ -334,6 +335,11 @@ cd mailnews/extensions/enigmail
        STRIP="/bin/true" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
+
+%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
+       STRIP="/bin/true" \
+       CC="%{__cc}" \
+       CXX="%{__cxx}"
 %endif
 
 %install
@@ -393,6 +399,10 @@ ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
 %endif
 
+%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
+        -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
+       %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
+
 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
@@ -418,15 +428,16 @@ chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
 
 %if %{with enigmail}
 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
-install -d $ext_dir/{chrome,components,defaults/preferences}
+install -d $ext_dir/{chrome,components,defaults/preferences,modules}
 cd mozilla/dist/bin
-#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
-#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
+cp -rfLp chrome/enigmail.jar $ext_dir/chrome
 cp -rfLp components/enig* $ext_dir/components
 cp -rfLp components/libenigmime.so $ext_dir/components
 cp -rfLp components/libipc.so $ext_dir/components
 cp -rfLp components/ipc.xpt $ext_dir/components
 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
+cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,pipeTransport,subprocess}.jsm $ext_dir/modules
+cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
 cd -
 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
@@ -512,6 +523,16 @@ exit 0
 %{_datadir}/%{name}/extensions
 %{_datadir}/%{name}/isp
 %{_datadir}/%{name}/modules
+%if %{with enigmail}
+%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
+%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
+%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
+%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
+%exclude %{_datadir}/%{name}/modules/pipeTransport.jsm
+%exclude %{_datadir}/%{name}/modules/subprocess.jsm
+%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
+%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
+%endif
 %{_datadir}/%{name}/searchplugins
 %if %{without xulrunner}
 %{_datadir}/%{name}/res
@@ -562,4 +583,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
+%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
+%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
+%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
 %endif
This page took 0.365643 seconds and 4 git commands to generate.