]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - icedove.spec
- up to 17.0.7
[packages/thunderbird.git] / icedove.spec
index c7081743dafc10e076e5ada19ee9345ee6f64c0b..d72391577a90abd1a65af481dc367950369ba6f3 100644 (file)
@@ -1,33 +1,29 @@
 # TODO:
 # - separate spec for enigmail
-# - fix icedove (building) and installing nss/nspr libs!
 # - build with system mozldap
-# - about dialog broken:
-#XML Parsing Error: undefined entity
-#Location: chrome://messenger/content/aboutDialog.xul
-#Line Number 27, Column 37:        <description id="copyright">&logoTrademark;</description>
-#------------------------------------^
 #
 # Conditional builds
 %bcond_without enigmail        # don't build enigmail - GPG/PGP support
 %bcond_without gnomeui         # disable gnomeui support
-%bcond_without gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
-%bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
+%bcond_without gnome           # alias for gnomeui
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
-%bcond_without  lightning      # disable sunbird calendar
-%bcond_with            xulrunner       # build with xulrunner
+%bcond_without lightning       # disable Sunbird/Lightning calendar
+%bcond_with    xulrunner       # system xulrunner
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 
 %if %{without gnome}
 %undefine      with_gnomeui
-%undefine      with_gnomevfs
 %endif
 
-%if %{?_enable_debug_packages} != 1
+%if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver            1.1.2
+%define                enigmail_ver    1.5.1
+%define                nspr_ver        4.9.3
+%define                nss_ver         3.14.1
+
+%define                xulrunner_ver   2:17.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       3.1.2
-Release:       0.10
+Version:       17.0.7
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
-Group:         X11/Applications/Networking
+Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 48e80576a7af70e64d30a5162364525a
+# Source0-md5: 31f07c3911d1d6772831195af64db963
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
+# Source1-md5: 3e71f84ed2c11471282412ebe4f5eb2d
 Source2:       %{name}-branding.tar.bz2
-# Source2-md5: 85fdf877e2f1bc41329d8086ef5cf0f1
+# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
 Patch1:                %{name}-enigmail-shared.patch
-Patch2:                %{name}-gcc.patch
 Patch3:                %{name}-fonts.patch
 Patch4:                %{name}-install.patch
 Patch5:                %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-Patch9:                %{name}-libpng.patch
+Patch9:                system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
+Patch12:       no-subshell.patch
+# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
+Patch13:       system-virtualenv.patch
+Patch14:       gyp-slashism.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
-%{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
+BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: automake
 BuildRequires: bzip2-devel
+BuildRequires: cairo-devel >= 1.10
+BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: freetype-devel >= 1:2.1.8
-%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
-BuildRequires: gtk+2-devel >= 1:2.0.0
+BuildRequires: glib2-devel >= 2.0
+BuildRequires: gtk+2-devel >= 2:2.10.0
 BuildRequires: hunspell-devel
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnomevfs:BuildRequires:        libgnome-devel >= 2.0}
+%{?with_gnomeui:BuildRequires: libgnome-devel >= 2.0}
 %{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
 %{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
 BuildRequires: libiw-devel
+# requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
+BuildRequires: libjpeg-turbo-devel
 BuildRequires: libnotify-devel >= 0.4
-BuildRequires: libpng-devel >= 1.2.0
+BuildRequires: libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
-BuildRequires: nspr-devel >= 1:4.8
-BuildRequires: nss-devel >= 1:3.12.0
-BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: nspr-devel >= 1:%{nspr_ver}
+BuildRequires: nss-devel >= 1:%{nss_ver}
+BuildRequires: pango-devel >= 1:1.14.0
+BuildRequires: perl-base >= 1:5.6
 BuildRequires: pkgconfig
+BuildRequires: python >= 1:2.5
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.6.22
+BuildRequires: sqlite3-devel >= 3.7.4
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXt-devel
+BuildRequires: yasm
 BuildRequires: zip
 %if %{with xulrunner}
+BuildRequires: xulrunner-devel >= %{xulrunner_ver}
+BuildRequires: xulrunner-devel < 2:18
 %else
 Requires:      myspell-common
-Requires:      nspr >= 1:4.6.1
-Requires:      nss >= 1:3.11.3
+Requires:      nspr >= 1:%{nspr_ver}
+Requires:      nss >= 1:%{nss_ver}
 Requires:      sqlite3 >= %{sqlite_build_version}
 %endif
+Requires(post):        mktemp >= 1.5-18
+%if %{with xulrunner}
+%requires_eq_to        xulrunner xulrunner-devel
+%endif
+Requires:      libjpeg-turbo
 Obsoletes:     mozilla-thunderbird
 Obsoletes:     mozilla-thunderbird-dictionary-en-US
+Conflicts:     icedove-lang-resources < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
 # iceweasel/icedove/iceape provide their own versions
-%define                _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
-# we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
+%if %{without xulrunner}
+# we don't want these to satisfy packages depending on xulrunner
+%define                _noautoprov             libmozalloc.so libxpcom.so libxul.so
 # and as we don't provide them, don't require either
-%define                _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq              libmozalloc.so libxpcom.so libxul.so
+%endif
 
 %define                topdir          %{_builddir}/%{name}-%{version}
 %define                objdir          %{topdir}/obj-%{_target_cpu}
 
 %description
-Icedove is an open-source,fast and portable email client.
+Icedove is an open-source, fast and portable email client.
 
 %description -l pl.UTF-8
-Icedove jest open sourcowym, szybkim i przenośnym klientem poczty.
+Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
+poczty.
 
 %package addon-lightning
 Summary:       An integrated calendar for Icedove
@@ -174,32 +190,30 @@ Główne możliwości:
 
 %prep
 %setup -qc
-mv -f comm-1.9.2 mozilla
+mv comm-esr17 mozilla
 %setup -q -T -D -a2
 cd mozilla
-%{?with_enigmail:tar xvfz %{SOURCE1} -C mailnews/extensions}
+%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
 /bin/sh %{SOURCE3}
 %patch0 -p1
 %{?with_enigmail:%patch1 -p1}
-%patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p0
-%patch9 -p0
+%patch8 -p2
+%patch9 -p1
 %patch10 -p2
 %patch11 -p2
+%patch12 -p1
+%patch13 -p1
+%patch14 -p1
 
 %build
 cd mozilla
 cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
-cp -f %{_datadir}/automake/config.* directory/c-sdk/config/autoconf
-
-install -d libxul-sdk
-ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
+cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
 
 cat << EOF > .mozconfig
 mk_add_options MOZ_OBJDIR=%{objdir}
@@ -244,16 +258,13 @@ ac_add_options --enable-tests
 %else
 ac_add_options --disable-tests
 %endif
+ac_add_options --enable-gio
 %if %{with gnomeui}
 ac_add_options --enable-gnomeui
 %else
 ac_add_options --disable-gnomeui
 %endif
-%if %{with gnomevfs}
-ac_add_options --enable-gnomevfs
-%else
 ac_add_options --disable-gnomevfs
-%endif
 %if %{with ldap}
 ac_add_options --enable-ldap
 ac_add_options --with-system-ldap
@@ -273,7 +284,6 @@ ac_add_options --enable-calendar
 ac_add_options --disable-calendar
 %endif
 ac_add_options --disable-installer
-ac_add_options --disable-jsd
 ac_add_options --disable-updater
 ac_add_options --disable-xprint
 ac_add_options --disable-permissions
@@ -295,10 +305,9 @@ ac_add_options --enable-xinerama
 ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-branding=icedove/branding
 %if %{with xulrunner}
-ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk
-ac_add_options --enable-shared
-%else
-ac_add_options --enable-static
+ac_add_options --enable-shared-js
+ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
+ac_add_options --with-system-libxul
 %endif
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
@@ -315,6 +324,7 @@ EOF
 %{__make} -j1 -f client.mk build \
        STRIP="/bin/true" \
        MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
+       XLIBS="-lX11 -lXt" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
@@ -330,6 +340,11 @@ cd mailnews/extensions/enigmail
        STRIP="/bin/true" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
+
+%{__make} -C %{objdir}/mailnews/extensions/enigmail xpi \
+       STRIP="/bin/true" \
+       CC="%{__cc}" \
+       CXX="%{__cxx}"
 %endif
 
 %install
@@ -339,10 +354,15 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_
 cd %{objdir}
 %{__make} -C mail/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
-       MOZ_PKG_APPDIR=%{_libdir}/%{name} \
+       MOZ_PKG_DIR=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
 
-# Enable crash reporter for Firefox application
+%if %{with xulrunner}
+# needed to find mozilla runtime
+ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
+%endif
+# Enable crash reporter for Thunderbird application
 %if %{with crashreporter}
 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
 
@@ -359,59 +379,82 @@ cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
 # move arch independant ones to datadir
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs $RPM_BUILD_ROOT%{_datadir}/%{name}/greprefs
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
-ln -s ../../share/%{name}/greprefs $RPM_BUILD_ROOT%{_libdir}/%{name}/greprefs
 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
+ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
+%if %{without xulrunner}
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
 ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
+%endif
+
+# dir for arch independant extensions besides arch dependant extensions
+# see mozilla/xpcom/build/nsXULAppAPI.h
+# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
+install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
 
-rm -rf $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+%if %{without xulrunner}
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
+ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
+%endif
+
+%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
+        -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
+       %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
 
 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
 
-cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
-cp -a %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
+cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
 
-# files created by regxpcom -register
+# files created by regxpcom -register in post
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
+cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
+#!/bin/sh
+umask 022
+# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
+# dangerous if you run this with sudo with keep_env += HOME
+# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
+t=$(mktemp -d)
+%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
+TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
+rm -rf $t
+EOF
+chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
 
 %if %{with enigmail}
 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
-install -d $ext_dir/{chrome,components,defaults/preferences}
+install -d $ext_dir/{chrome,components,defaults/preferences,modules}
 cd mozilla/dist/bin
 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
-cp -rfLp chrome/enigmime.jar $ext_dir/chrome
 cp -rfLp components/enig* $ext_dir/components
 cp -rfLp components/libenigmime.so $ext_dir/components
-cp -rfLp components/libipc.so $ext_dir/components
-cp -rfLp components/ipc.xpt $ext_dir/components
 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
+cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
+cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
 cd -
-cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
-cp -a %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
+cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
+cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
 %endif
 
-# remove unecessary stuff
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
-rm $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
-
-# never package these
+# never package these. always remove
 # nss
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
 # nspr
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
 # mozldap
-rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
+# testpilot quiz
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -420,7 +463,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
        mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
 fi
-for d in chrome defaults greprefs icons isp modules res; do
+for d in chrome defaults icons isp modules res searchplugins; do
        if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
                install -d %{_datadir}/%{name}
                mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
@@ -428,6 +471,9 @@ for d in chrome defaults greprefs icons isp modules res; do
 done
 exit 0
 
+%post
+%{_libdir}/%{name}/register || :
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/icedove
@@ -435,38 +481,65 @@ exit 0
 %attr(755,root,root) %{_bindir}/thunderbird
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/application.ini
-%{_libdir}/%{name}/platform.ini
+%{_libdir}/%{name}/blocklist.xml
+%{_libdir}/%{name}/chrome.manifest
 %dir %{_libdir}/%{name}/components
-%attr(755,root,root) %{_libdir}/%{name}/components/*.so
 %{_libdir}/%{name}/components/*.js
 %{_libdir}/%{name}/components/*.xpt
-%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
-%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
-%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
+%{_libdir}/%{name}/components/components.manifest
+%{_libdir}/%{name}/components/interfaces.manifest
 %attr(755,root,root) %{_libdir}/%{name}/*.sh
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
-%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/icedove
+%attr(755,root,root) %{_libdir}/%{name}/register
+%if %{without xulrunner}
+%{_libdir}/%{name}/dependentlibs.list
+%{_libdir}/%{name}/platform.ini
+%{_libdir}/%{name}/greprefs.js
+%attr(755,root,root) %{_libdir}/%{name}/components/*.so
+%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
+%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
+%attr(755,root,root) %{_libdir}/%{name}/libxul.so
+%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
+%attr(755,root,root) %{_libdir}/%{name}/plugin-container
+%endif
 
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
-%{_libdir}/%{name}/dictionaries
-%{_libdir}/%{name}/greprefs
 %{_libdir}/%{name}/isp
 %{_libdir}/%{name}/modules
+%{_libdir}/%{name}/searchplugins
+%if %{with xulrunner}
+%{_libdir}/%{name}/xulrunner
+%else
+%{_libdir}/%{name}/dictionaries
+%{_libdir}/%{name}/hyphenation
 %{_libdir}/%{name}/res
+%endif
 
-%{_pixmapsdir}/*.png
-%{_desktopdir}/*.desktop
+%{_pixmapsdir}/icedove.png
+%{_desktopdir}/icedove.desktop
 
 %dir %{_datadir}/%{name}
 %{_datadir}/%{name}/chrome
 %{_datadir}/%{name}/defaults
-%{_datadir}/%{name}/greprefs
+%{_datadir}/%{name}/extensions
 %{_datadir}/%{name}/isp
 %{_datadir}/%{name}/modules
+%if %{with enigmail}
+%exclude %{_datadir}/%{name}/modules/commonFuncs.jsm
+%exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
+%exclude %{_datadir}/%{name}/modules/keyManagement.jsm
+%exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
+%exclude %{_datadir}/%{name}/modules/subprocess.jsm
+%exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
+%exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
+%endif
+%{_datadir}/%{name}/searchplugins
+%if %{without xulrunner}
 %{_datadir}/%{name}/res
+%endif
 
 %if %{with crashreporter}
 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
@@ -485,18 +558,19 @@ exit 0
 %files addon-lightning
 %defattr(644,root,root,755)
 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
 %dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
 %attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
-%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
+%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
-
 %{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
 %endif
 
@@ -512,4 +586,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
 %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
+%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules
+%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.jsm
+%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/modules/*.js
 %endif
This page took 0.094776 seconds and 4 git commands to generate.