]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - icedove.spec
- fix applying bump-nss-req patch
[packages/thunderbird.git] / icedove.spec
index abbeed4824ef8728016cf5dcefaf54200c725053..d01a9963f298f2afb12402ee95a6a816dc1379f5 100644 (file)
@@ -1,36 +1,21 @@
 # TODO:
-# - separate spec for enigmail
 # - build with system mozldap
-# - replace gnome-vfs2 with gio
-# - files:
-#   /usr/lib/icedove/hyphenation/hyph_en_US.dic
 #
 # Conditional builds
-%bcond_without enigmail        # don't build enigmail - GPG/PGP support
-%bcond_without gnomeui         # disable gnomeui support
-%bcond_without gnomevfs        # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
-%bcond_without gnome           # disable all GNOME components (gnome+gnomeui+gnomevfs)
+%bcond_with    gtk3            # GTK+ 3.x instead of 2.x
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
 %bcond_without lightning       # disable Sunbird/Lightning calendar
-%bcond_without xulrunner       # build with xulrunner
+%bcond_with    xulrunner       # system xulrunner
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 
-%if %{without gnome}
-%undefine      with_gnomeui
-%undefine      with_gnomevfs
-%endif
-
 %if 0%{?_enable_debug_packages} != 1
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.3.2
-%define                nspr_ver        4.8.8
-%define                nss_ver         3.12.10
+%define                nspr_ver        4.10.2
+%define                nss_ver         3.16.2.3
 
-# convert firefox release number to platform version: 7.0.x -> 7.0.x
-%define                xulrunner_main  8.0
-%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#8.0})
+%define                xulrunner_ver   2:24.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       8.0
+Version:       31.3.0
 Release:       0.1
-License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
-Group:         X11/Applications/Networking
+License:       MPL v2.0
+Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 332f60036aebdce7dec6ee2b1af4941d
-Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 2318d60320dc6c3db3c34d968bb7d533
+# Source0-md5: 3781dfb541412c7f6b530a654b834ce5
 Source2:       %{name}-branding.tar.bz2
-# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
+# Source2-md5: d8e6897870bf288fdf264c0e9ef85f7d
 Source3:       %{name}-rm_nonfree.sh
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
-Patch1:                %{name}-enigmail-shared.patch
-Patch2:                %{name}-gcc.patch
 Patch3:                %{name}-fonts.patch
-Patch4:                %{name}-install.patch
-Patch5:                %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
 Patch10:       %{name}-extensiondir.patch
-Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
+# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
+Patch13:       system-virtualenv.patch
+Patch15:       enable-addons.patch
+Patch16:       bump-nss-req.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
-%{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
+BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
 BuildRequires: automake
 BuildRequires: bzip2-devel
 BuildRequires: cairo-devel >= 1.10
 BuildRequires: dbus-glib-devel >= 0.60
 BuildRequires: freetype-devel >= 1:2.1.8
-%{?with_gnomevfs:BuildRequires:        gnome-vfs2-devel >= 2.0}
-BuildRequires: gtk+2-devel >= 2:2.10.0
+BuildRequires: glib2-devel >= 1:2.20
+BuildRequires: gstreamer0.10-devel
+BuildRequires: gstreamer0.10-plugins-base-devel
+%{!?with_gtk3:BuildRequires:   gtk+2-devel >= 2:2.14}
+%{?with_gtk3:BuildRequires:    gtk+3-devel >= 3.0.0}
 BuildRequires: hunspell-devel
 BuildRequires: libIDL-devel >= 0.8.0
-%{?with_gnomevfs:BuildRequires:        libgnome-devel >= 2.0}
-%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
-%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
+BuildRequires: libevent-devel
 BuildRequires: libiw-devel
+# requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
-BuildRequires: libnotify-devel >= 0.4
+BuildRequires: libjpeg-turbo-devel
 BuildRequires: libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
+BuildRequires: mozldap-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
-BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: pango-devel >= 1:1.14.0
 BuildRequires: perl-base >= 1:5.6
+BuildRequires: python-virtualenv
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.7.4
+BuildRequires: sqlite3-devel >= 3.7.17
 BuildRequires: startup-notification-devel >= 0.8
+BuildRequires: libvpx-devel >= 1.0.0
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: yasm
 BuildRequires: zip
 %if %{with xulrunner}
-BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
+BuildRequires: xulrunner-devel >= %{xulrunner_ver}
+BuildRequires: xulrunner-devel < 2:25
 %else
+Requires:      glib2 >= 1:2.20
+%{!?with_gtk3:Requires:        gtk+2 >= 2:2.14}
+%{?with_gtk3:Requires: gtk+3 >= 3.0.0}
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
 Requires:      nss >= 1:%{nss_ver}
@@ -111,19 +102,22 @@ Requires(post):   mktemp >= 1.5-18
 %if %{with xulrunner}
 %requires_eq_to        xulrunner xulrunner-devel
 %endif
+Requires:      libjpeg-turbo
 Obsoletes:     mozilla-thunderbird
 Obsoletes:     mozilla-thunderbird-dictionary-en-US
+Conflicts:     icedove-lang-resources < %{version}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
 # iceweasel/icedove/iceape provide their own versions
-%define                _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
-# we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
+%if %{without xulrunner}
+# we don't want these to satisfy packages depending on xulrunner
+%define                _noautoprov             libmozalloc.so libmozjs.so libxul.so
 # and as we don't provide them, don't require either
-%define                _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
+%define                _noautoreq              libmozalloc.so libmozjs.so libxul.so
+%endif
 
 %define                topdir          %{_builddir}/%{name}-%{version}
 %define                objdir          %{topdir}/obj-%{_target_cpu}
@@ -149,61 +143,22 @@ Lightning is an calendar extension to Icedove email client.
 Lightning to rozszerzenie do klienta poczty Icedove dodające
 funkcjonalność kalendarza.
 
-%package addon-enigmail
-Summary:       Extension for the authentication and encryption features provided by GnuPG
-Summary(pl.UTF-8):     Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
-License:       MPL/LGPL
-Group:         Applications/Networking
-URL:           http://enigmail.mozdev.org/
-Requires:      %{name} = %{version}-%{release}
-Requires:      gnupg
-Obsoletes:     mozilla-thunderbird-addon-enigmail
-
-%description addon-enigmail
-Enigmail is an extension to the Icedove mail client which allows users
-to access the authentication and encryption features provided by
-GnuPG.
-
-Main Features:
-- Encrypt/sign mail when sending, decrypt/authenticate received mail
-- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
-- Per-Account based encryption and signing defaults
-- Per-Recipient rules for automated key selection, and
-  enabling/disabling encryption and signing
-- OpenPGP key management interface
-
-%description addon-enigmail -l pl.UTF-8
-Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
-użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
-przez GnuPG.
-
-Główne możliwości:
-- szyfrowanie/podpisywanie poczty przy wysyłaniu,
-  odszyfrowywanie/uwierzytelnianie poczty odebranej
-- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
-- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
-- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
-  podpisywania dla każdego adresata
-- interfejs do zarządzania kluczami OpenPGP
-
 %prep
 %setup -qc
-mv comm-release mozilla
+%{__mv} comm-esr31 mozilla
 %setup -q -T -D -a2
 cd mozilla
-%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
 /bin/sh %{SOURCE3}
 %patch0 -p1
-%{?with_enigmail:%patch1 -p1}
-%patch2 -p1
 %patch3 -p1
-%patch4 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
 %patch10 -p2
-%patch11 -p2
 %patch12 -p1
+%patch13 -p1
+%patch15 -p1
+%patch16 -p2
 
 %build
 cd mozilla
@@ -211,14 +166,11 @@ cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
 
-install -d libxul-sdk
-ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
-
 cat << EOF > .mozconfig
 mk_add_options MOZ_OBJDIR=%{objdir}
 
-export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
-export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
+export CFLAGS="%{rpmcflags}"
+export CXXFLAGS="%{rpmcflags}"
 
 %if %{with crashreporter}
 export MOZ_DEBUG_SYMBOLS=1
@@ -257,79 +209,70 @@ ac_add_options --enable-tests
 %else
 ac_add_options --disable-tests
 %endif
-%if %{with gnomeui}
-ac_add_options --enable-gnomeui
-%else
-ac_add_options --disable-gnomeui
-%endif
-%if %{with gnomevfs}
-ac_add_options --enable-gnomevfs
-%else
-ac_add_options --disable-gnomevfs
-%endif
-%if %{with ldap}
-ac_add_options --enable-ldap
-ac_add_options --with-system-ldap
+%if %{with lightning}
+ac_add_options --enable-calendar
 %else
-ac_add_options --disable-ldap
+ac_add_options --disable-calendar
 %endif
 %if %{with crashreporter}
 ac_add_options --enable-crashreporter
 %else
 ac_add_options --disable-crashreporter
 %endif
-ac_add_options --disable-xterm-updates
-ac_add_options --enable-postscript
-%if %{with lightning}
-ac_add_options --enable-calendar
-%else
-ac_add_options --disable-calendar
-%endif
+ac_add_options --disable-elf-dynstr-gc
+ac_add_options --disable-gnomeui
+ac_add_options --disable-gnomevfs
 ac_add_options --disable-installer
-ac_add_options --disable-jsd
+ac_add_options --disable-javaxpcom
+ac_add_options --disable-profilesharing
 ac_add_options --disable-updater
-ac_add_options --disable-xprint
-ac_add_options --disable-permissions
-ac_add_options --disable-pref-extensions
-ac_add_options --enable-canvas
+ac_add_options --disable-xterm-updates
+ac_add_options --enable-application=mail
 ac_add_options --enable-crypto
-ac_add_options --enable-mathml
+ac_add_options --enable-default-toolkit=%{?with_gtk3:cairo-gtk3}%{!?with_gtk3:cairo-gtk2}
+ac_add_options --enable-gio
+%if %{with ldap}
+ac_add_options --enable-ldap
+ac_add_options --with-system-ldap
+%else
+ac_add_options --disable-ldap
+%endif
+ac_add_options --enable-libxul
 ac_add_options --enable-pango
-ac_add_options --enable-reorder
+ac_add_options --enable-postscript
+ac_add_options --enable-shared-js
+ac_add_options --enable-single-profile
 ac_add_options --enable-startup-notification
-ac_add_options --enable-svg
 ac_add_options --enable-system-cairo
 ac_add_options --enable-system-hunspell
 ac_add_options --enable-system-sqlite
-ac_add_options --enable-xft
-ac_add_options --enable-application=mail
-ac_add_options --enable-default-toolkit=cairo-gtk2
-ac_add_options --enable-xinerama
-ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-branding=icedove/branding
+ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
+ac_add_options --with-distribution-id=org.pld-linux
 %if %{with xulrunner}
-#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
+ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
 ac_add_options --with-system-libxul
-ac_add_options --enable-shared
-ac_add_options --enable-libxul
-%else
-ac_add_options --disable-xul
 %endif
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
+ac_add_options --with-system-ffi
 ac_add_options --with-system-jpeg
+ac_add_options --with-system-libevent
+ac_add_options --with-system-libvpx
 ac_add_options --with-system-nspr
 ac_add_options --with-system-nss
 ac_add_options --with-system-png
 ac_add_options --with-system-zlib
-ac_add_options --enable-single-profile
-ac_add_options --disable-profilesharing
-ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
 EOF
 
+mkdir -p %{objdir}/config
+ln -s %{topdir}/mozilla/config/*.mk %{objdir}/config
+
 %{__make} -j1 -f client.mk build \
        STRIP="/bin/true" \
        MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
+       installdir=%{_libdir}/%{name} \
+       XLIBS="-lX11 -lXt" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
@@ -338,15 +281,6 @@ EOF
 %{__make} -j1 -C obj-%{_target_cpu} buildsymbols
 %endif
 
-%if %{with enigmail}
-cd mailnews/extensions/enigmail
-./makemake -r -o %{objdir}
-%{__make} -C %{objdir}/mailnews/extensions/enigmail \
-       STRIP="/bin/true" \
-       CC="%{__cc}" \
-       CXX="%{__cxx}"
-%endif
-
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
@@ -354,10 +288,20 @@ install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_
 cd %{objdir}
 %{__make} -C mail/installer stage-package \
        DESTDIR=$RPM_BUILD_ROOT \
-       MOZ_PKG_DIR=%{_libdir}/%{name} \
+       installdir=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
 
-# Enable crash reporter for Firefox application
+%{__make} -C icedove/branding install \
+       DESTDIR=$RPM_BUILD_ROOT
+
+cp -a mozilla/dist/icedove/* $RPM_BUILD_ROOT%{_libdir}/%{name}/
+%if %{with xulrunner}
+# needed to find mozilla runtime
+ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
+%endif
+# Enable crash reporter for Thunderbird application
 %if %{with crashreporter}
 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
 
@@ -367,36 +311,42 @@ cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $R
 %endif
 
 # copy manually lightning files, somewhy they are not installed by make
-cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
-       mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
+cp -a mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
        $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
 
 # move arch independant ones to datadir
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
-ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
-ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
-ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
-ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
-ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
+ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
 
 # dir for arch independant extensions besides arch dependant extensions
 # see mozilla/xpcom/build/nsXULAppAPI.h
 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
 
+%if %{without xulrunner}
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
+%endif
+
+%{__sed} -e "s|%MOZAPPDIR%|%{_libdir}/%{name}|" \
+        -e "s|%MOZ_APP_DISPLAYNAME%|Icedove|" \
+       %{topdir}/mozilla/mozilla/build/unix/mozilla.in > $RPM_BUILD_ROOT%{_libdir}/%{name}/icedove
 
 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
 
-cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
+# install icons and desktop file
 cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
+for i in 16 32 48 64 128 256; do
+       install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps
+       cp -a %{topdir}/mozilla/icedove/branding/icedove${i}.png \
+               $RPM_BUILD_ROOT%{_iconsdir}/hicolor/${i}x${i}/apps/icedove.png
+done
+install -d $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps
+cp -a %{topdir}/mozilla/icedove/branding/icedove.svg $RPM_BUILD_ROOT%{_iconsdir}/hicolor/scalable/apps/icedove.svg
+
+cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 
 # files created by regxpcom -register in post
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
@@ -414,34 +364,9 @@ rm -rf $t
 EOF
 chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
 
-%if %{with enigmail}
-ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
-install -d $ext_dir/{chrome,components,defaults/preferences}
-cd mozilla/dist/bin
-#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
-#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
-cp -rfLp components/enig* $ext_dir/components
-cp -rfLp components/libenigmime.so $ext_dir/components
-cp -rfLp components/libipc.so $ext_dir/components
-cp -rfLp components/ipc.xpt $ext_dir/components
-cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
-cd -
-cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
-cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
-%endif
-
-# remove unecessary stuff
-#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
-#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
-#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
-
-# never package these. always remove
-# nss
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
-# nspr
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
 # mozldap
-%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
+%{__sed} -i '/lib\(ldap\|ldif\|prldap\)60.so/d' $RPM_BUILD_ROOT%{_libdir}/%{name}/dependentlibs.list
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap}60.so
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -450,7 +375,7 @@ rm -rf $RPM_BUILD_ROOT
 if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
        mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
 fi
-for d in chrome defaults icons isp modules res; do
+for d in chrome defaults icons isp modules res searchplugins; do
        if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
                install -d %{_datadir}/%{name}
                mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
@@ -468,48 +393,43 @@ exit 0
 %attr(755,root,root) %{_bindir}/thunderbird
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/application.ini
-%{_libdir}/%{name}/platform.ini
 %{_libdir}/%{name}/blocklist.xml
 %{_libdir}/%{name}/chrome.manifest
-%{_libdir}/%{name}/greprefs.js
 %dir %{_libdir}/%{name}/components
-%attr(755,root,root) %{_libdir}/%{name}/components/*.so
-%{_libdir}/%{name}/components/*.js
-%{_libdir}/%{name}/components/*.xpt
 %{_libdir}/%{name}/components/components.manifest
-%{_libdir}/%{name}/components/interfaces.manifest
-%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
-#%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
-%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
-#%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
-%attr(755,root,root) %{_libdir}/%{name}/libxul.so
 %attr(755,root,root) %{_libdir}/%{name}/*.sh
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
-%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/icedove
-%attr(755,root,root) %{_libdir}/%{name}/plugin-container
 %attr(755,root,root) %{_libdir}/%{name}/register
+%{_libdir}/%{name}/omni.ja
+%if %{without xulrunner}
+%{_libdir}/%{name}/dependentlibs.list
+%{_libdir}/%{name}/platform.ini
+%attr(755,root,root) %{_libdir}/%{name}/components/*.so
+%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
+%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
+%attr(755,root,root) %{_libdir}/%{name}/libxul.so
+%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
+%attr(755,root,root) %{_libdir}/%{name}/plugin-container
+%endif
 
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
-%{_libdir}/%{name}/dictionaries
-#%%{_libdir}/%{name}/greprefs
 %{_libdir}/%{name}/isp
-%{_libdir}/%{name}/modules
-%{_libdir}/%{name}/res
+%{_libdir}/%{name}/searchplugins
+%if %{with xulrunner}
+%{_libdir}/%{name}/xulrunner
+%else
+%{_libdir}/%{name}/dictionaries
+%endif
 
-%{_pixmapsdir}/*.png
-%{_desktopdir}/*.desktop
+%{_pixmapsdir}/icedove.png
+%{_desktopdir}/icedove.desktop
 
 %dir %{_datadir}/%{name}
-%{_datadir}/%{name}/chrome
-%{_datadir}/%{name}/defaults
-#%%{_datadir}/%{name}/greprefs
-%{_datadir}/%{name}/isp
-%{_datadir}/%{name}/modules
-%{_datadir}/%{name}/res
 %{_datadir}/%{name}/extensions
+%{_datadir}/%{name}/searchplugins
 
 %if %{with crashreporter}
 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
@@ -524,6 +444,8 @@ exit 0
 %ghost %{_libdir}/%{name}/components/compreg.dat
 %ghost %{_libdir}/%{name}/components/xpti.dat
 
+%{_iconsdir}/hicolor/*/apps/icedove.*
+
 %if %{with lightning}
 %files addon-lightning
 %defattr(644,root,root,755)
@@ -541,19 +463,4 @@ exit 0
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
 %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
-%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
-%endif
-
-%if %{with enigmail}
-%files addon-enigmail
-%defattr(644,root,root,755)
-%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
-%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
-%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
-%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
-%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
-%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
-%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
-%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
-%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
 %endif
This page took 0.229453 seconds and 4 git commands to generate.