]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - icedove.spec
- up to 13.0
[packages/thunderbird.git] / icedove.spec
index 37b5e029434f8b5acd39171b823d4f785a3c4a3c..4b0e3786a51151307aa0407536582c18b20ad6be 100644 (file)
@@ -8,7 +8,7 @@
 %bcond_without gnome           # alias for gnomeui
 %bcond_without ldap            # disable e-mail address lookups in LDAP directories
 %bcond_without lightning       # disable Sunbird/Lightning calendar
-%bcond_without xulrunner       # build with xulrunner
+%bcond_with    xulrunner       # system xulrunner
 %bcond_with    crashreporter   # report crashes to crash-stats.mozilla.com
 
 %if %{without gnome}
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.3.5
-%define                nspr_ver        4.8.8
-%define                nss_ver         3.12.10
+%define                enigmail_ver    1.4.2
+%define                nspr_ver        4.9
+%define                nss_ver         3.13.3
 
-# convert thunderbird release number to platform version: 9.0.x -> 9.0.x
-%define                xulrunner_main  10.0
-%define                xulrunner_ver   %(v=%{version}; echo %{xulrunner_main}${v#10.0})
+%define                xulrunner_ver   2:13.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       10.0.2
-Release:       3
+Version:       13.0
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 624bef982d7ac610b1175737d9905150
+# Source0-md5: 0134c67c30e8598f2a64ea004d5bc4bc
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: 1b008b0d106e238c11e4bead08126bc0
+# Source1-md5: ed608e1cd4cd20b96f7f5afdbf081141
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -50,13 +48,14 @@ Source4:    %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
 Patch1:                %{name}-enigmail-shared.patch
+Patch2:                %{name}-system-xulrunner.patch
 Patch3:                %{name}-fonts.patch
 Patch4:                %{name}-install.patch
 Patch5:                %{name}-hunspell.patch
 Patch6:                %{name}-prefs.patch
 Patch7:                system-mozldap.patch
 Patch8:                %{name}-makefile.patch
-
+Patch9:                system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
@@ -82,7 +81,7 @@ BuildRequires:        libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
 BuildRequires: nspr-devel >= 1:%{nspr_ver}
 BuildRequires: nss-devel >= 1:%{nss_ver}
-BuildRequires: pango-devel >= 1:1.1.0
+BuildRequires: pango-devel >= 1:1.14.0
 BuildRequires: perl-base >= 1:5.6
 BuildRequires: pkgconfig
 BuildRequires: python >= 1:2.5
@@ -95,7 +94,7 @@ BuildRequires:        xorg-lib-libXt-devel
 BuildRequires: yasm
 BuildRequires: zip
 %if %{with xulrunner}
-BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
+BuildRequires: xulrunner-devel >= %{xulrunner_ver}
 %else
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
@@ -114,10 +113,12 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # iceweasel/icedove/iceape provide their own versions
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
-# we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libmozjs.so libxpcom.so libxul.so
+%if %{without xulrunner}
+# we don't want these to satisfy packages depending on xulrunner
+%define                _noautoprov             libmozalloc.so libxpcom.so libxul.so
 # and as we don't provide them, don't require either
-%define                _noautoreq              libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq              libmozalloc.so libxpcom.so libxul.so
+%endif
 
 %define                topdir          %{_builddir}/%{name}-%{version}
 %define                objdir          %{topdir}/obj-%{_target_cpu}
@@ -189,11 +190,13 @@ cd mozilla
 /bin/sh %{SOURCE3}
 %patch0 -p1
 %{?with_enigmail:%patch1 -p1}
+%{?with_xulrunner:%patch2 -p1}
 %patch3 -p1
 %patch4 -p1
 %patch6 -p1
 %patch7 -p1
 %patch8 -p2
+%patch9 -p1
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
@@ -204,14 +207,11 @@ cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
 cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
 cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
 
-install -d libxul-sdk
-ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
-
 cat << EOF > .mozconfig
 mk_add_options MOZ_OBJDIR=%{objdir}
 
-export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
-export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
+export CFLAGS="%{rpmcflags}"
+export CXXFLAGS="%{rpmcflags}"
 
 %if %{with crashreporter}
 export MOZ_DEBUG_SYMBOLS=1
@@ -276,7 +276,6 @@ ac_add_options --enable-calendar
 ac_add_options --disable-calendar
 %endif
 ac_add_options --disable-installer
-ac_add_options --disable-jsd
 ac_add_options --disable-updater
 ac_add_options --disable-xprint
 ac_add_options --disable-permissions
@@ -298,12 +297,9 @@ ac_add_options --enable-xinerama
 ac_add_options --with-distribution-id=org.pld-linux
 ac_add_options --with-branding=icedove/branding
 %if %{with xulrunner}
-#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
+ac_add_options --enable-shared-js
+ac_add_options --with-libxul-sdk=$(pkg-config --variable=sdkdir libxul)
 ac_add_options --with-system-libxul
-ac_add_options --enable-shared
-ac_add_options --enable-libxul
-%else
-ac_add_options --disable-xul
 %endif
 ac_add_options --with-pthreads
 ac_add_options --with-system-bz2
@@ -347,7 +343,12 @@ cd %{objdir}
        MOZ_PKG_DIR=%{_libdir}/%{name} \
        PKG_SKIP_STRIP=1
 
-# Enable crash reporter for Firefox application
+%if %{with xulrunner}
+# needed to find mozilla runtime
+ln -s ../xulrunner $RPM_BUILD_ROOT%{_libdir}/%{name}/xulrunner
+%endif
+# Enable crash reporter for Thunderbird application
 %if %{with crashreporter}
 %{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
 
@@ -366,25 +367,28 @@ mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/c
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
-mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
 mv $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins $RPM_BUILD_ROOT%{_datadir}/%{name}/searchplugins
 ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
 ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
 ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
 ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
-ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
 ln -s ../../share/%{name}/searchplugins $RPM_BUILD_ROOT%{_libdir}/%{name}/searchplugins
+%if %{without xulrunner}
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
+ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
+%endif
 
 # dir for arch independant extensions besides arch dependant extensions
 # see mozilla/xpcom/build/nsXULAppAPI.h
 # XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
 
+%if %{without xulrunner}
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
-
 %{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
 ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/hyphenation
+%endif
 
 %{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
 ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
@@ -425,11 +429,6 @@ cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_di
 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
 %endif
 
-# remove unecessary stuff
-#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
-#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
-#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
-
 # never package these. always remove
 # nss
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
@@ -437,6 +436,8 @@ cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ex
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
 # mozldap
 %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
+# testpilot quiz
+%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/distribution/extensions/tbtestpilot@labs.mozilla.com.xpi
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -463,35 +464,41 @@ exit 0
 %attr(755,root,root) %{_bindir}/thunderbird
 %dir %{_libdir}/%{name}
 %{_libdir}/%{name}/application.ini
-%{_libdir}/%{name}/platform.ini
 %{_libdir}/%{name}/blocklist.xml
 %{_libdir}/%{name}/chrome.manifest
-%{_libdir}/%{name}/greprefs.js
 %dir %{_libdir}/%{name}/components
-%attr(755,root,root) %{_libdir}/%{name}/components/*.so
 %{_libdir}/%{name}/components/*.js
 %{_libdir}/%{name}/components/*.xpt
 %{_libdir}/%{name}/components/components.manifest
 %{_libdir}/%{name}/components/interfaces.manifest
+%attr(755,root,root) %{_libdir}/%{name}/*.sh
+%attr(755,root,root) %{_libdir}/%{name}/*-bin
+%attr(755,root,root) %{_libdir}/%{name}/icedove
+%attr(755,root,root) %{_libdir}/%{name}/register
+%if %{without xulrunner}
+%{_libdir}/%{name}/platform.ini
+%{_libdir}/%{name}/greprefs.js
+%attr(755,root,root) %{_libdir}/%{name}/components/*.so
 %attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
 %attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
 %attr(755,root,root) %{_libdir}/%{name}/libxul.so
-%attr(755,root,root) %{_libdir}/%{name}/*.sh
-%attr(755,root,root) %{_libdir}/%{name}/*-bin
 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
-%attr(755,root,root) %{_libdir}/%{name}/icedove
 %attr(755,root,root) %{_libdir}/%{name}/plugin-container
-%attr(755,root,root) %{_libdir}/%{name}/register
+%endif
 
 # symlinks
 %{_libdir}/%{name}/chrome
 %{_libdir}/%{name}/defaults
-%{_libdir}/%{name}/dictionaries
-%{_libdir}/%{name}/hyphenation
 %{_libdir}/%{name}/isp
 %{_libdir}/%{name}/modules
-%{_libdir}/%{name}/res
 %{_libdir}/%{name}/searchplugins
+%if %{with xulrunner}
+%{_libdir}/%{name}/xulrunner
+%else
+%{_libdir}/%{name}/dictionaries
+%{_libdir}/%{name}/hyphenation
+%{_libdir}/%{name}/res
+%endif
 
 %{_pixmapsdir}/icedove.png
 %{_desktopdir}/icedove.desktop
@@ -502,8 +509,10 @@ exit 0
 %{_datadir}/%{name}/extensions
 %{_datadir}/%{name}/isp
 %{_datadir}/%{name}/modules
-%{_datadir}/%{name}/res
 %{_datadir}/%{name}/searchplugins
+%if %{without xulrunner}
+%{_datadir}/%{name}/res
+%endif
 
 %if %{with crashreporter}
 %attr(755,root,root) %{_libdir}/%{name}/crashreporter
This page took 0.049699 seconds and 4 git commands to generate.