]> git.pld-linux.org Git - packages/thunderbird.git/blobdiff - icedove-install.patch
- start de-branding back to thunderbird
[packages/thunderbird.git] / icedove-install.patch
index a62d5a47b65bcb90c0a8c315dbeb3aa08895f5dd..e819c9c6c8bd8a5f5faf0a86f94456a20d217492 100644 (file)
@@ -1,53 +1,98 @@
---- ./mozilla/toolkit/mozapps/installer/packager.mk.org        2010-01-21 21:10:00.234466295 +0100
-+++ ./mozilla/toolkit/mozapps/installer/packager.mk    2010-01-21 21:10:29.847369216 +0100
-@@ -362,13 +362,13 @@
+--- mozilla/mozilla/toolkit/mozapps/installer/packager.mk.orig 2012-03-13 03:43:47.000000000 +0100
++++ mozilla/mozilla/toolkit/mozapps/installer/packager.mk      2012-03-24 21:50:54.171788606 +0100
+@@ -708,41 +708,41 @@
+ endif
+ stage-package: $(MOZ_PKG_MANIFEST) $(MOZ_PKG_REMOVALS_GEN) elfhack
+-      @rm -rf $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
++      @rm -rf $(DIST)/$(PKG_PATH)$(PKG_BASENAME).tar $(DIST)/$(PKG_PATH)$(PKG_BASENAME).dmg $@ $(EXCLUDE_LIST)
+ ifndef MOZ_FAST_PACKAGE
+-      @rm -rf $(DIST)/$(MOZ_PKG_DIR)
++      @rm -rf $(DESTDIR)/$(MOZ_PKG_DIR)
+ endif
  # NOTE: this must be a tar now that dist links into the tree so that we
  # do not strip the binaries actually in the tree.
        @echo "Creating package directory..."
--      @mkdir $(DIST)/$(MOZ_PKG_DIR)
-+      @mkdir -p $(DESTDIR)/$(MOZ_PKG_APPDIR)
+-      if ! test -d $(DIST)/$(MOZ_PKG_DIR) ; then \
+-              mkdir $(DIST)/$(MOZ_PKG_DIR); \
++      if ! test -d $(DESTDIR)/$(MOZ_PKG_DIR) ; then \
++              mkdir $(DESTDIR)/$(MOZ_PKG_DIR); \
+       fi
+ ifndef UNIVERSAL_BINARY
+ # If UNIVERSAL_BINARY, the package will be made from an already-prepared
+ # STAGEPATH
  ifdef MOZ_PKG_MANIFEST
-       $(RM) -rf $(DIST)/xpt
+ ifndef MOZ_FAST_PACKAGE
+       $(RM) -rf $(DIST)/xpt $(DIST)/manifests
+ endif
        $(call PACKAGER_COPY, "$(call core_abspath,$(DIST))",\
--               "$(call core_abspath,$(DIST)/$(MOZ_PKG_DIR))", \
-+               "$(call core_abspath,$(DESTDIR)/$(MOZ_PKG_APPDIR))", \
-               "$(MOZ_PKG_MANIFEST)", "$(PKGCP_OS)", 1, 0, 1)
--      $(PERL) $(MOZILLA_DIR)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
-+      $(PERL) $(MOZILLA_DIR)/xpinstall/packager/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DESTDIR)/$(MOZ_PKG_APPDIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
+-        "$(call core_abspath,$(DIST)/$(MOZ_PKG_DIR))", \
++        "$(call core_abspath,$(DESTDIR)/$(MOZ_PKG_DIR))", \
+         "$(MOZ_PKG_MANIFEST)", "$(PKGCP_OS)", 1, 0, 1)
+-      $(PERL) $(MOZILLA_DIR)/toolkit/mozapps/installer/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
++      $(PERL) $(MOZILLA_DIR)/toolkit/mozapps/installer/xptlink.pl -s $(DIST) -d $(DIST)/xpt -f $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/components -v -x "$(XPIDL_LINK)"
+       $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
+-        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/components/components.manifest \
++        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/components/components.manifest \
+         $(patsubst %,$(DIST)/manifests/%/components,$(MOZ_NONLOCALIZED_PKG_LIST))
+       $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
+-        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/nonlocalized.manifest \
++        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/nonlocalized.manifest \
+         $(patsubst %,$(DIST)/manifests/%/chrome,$(MOZ_NONLOCALIZED_PKG_LIST))
+       $(PYTHON) $(MOZILLA_DIR)/toolkit/mozapps/installer/link-manifests.py \
+-        $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/localized.manifest \
++        $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome/localized.manifest \
+         $(patsubst %,$(DIST)/manifests/%/chrome,$(MOZ_LOCALIZED_PKG_LIST))
+ ifdef MOZ_WEBAPP_RUNTIME
+-      mv $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/$(AB_CD).manifest $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/localized.manifest
+-      sed 's/$(AB_CD)/localized/' $(DIST)/bin/webapprt/chrome.manifest > $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome.manifest
++      mv $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/$(AB_CD).manifest $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome/localized.manifest
++      sed 's/$(AB_CD)/localized/' $(DESTDIR)/bin/webapprt/chrome.manifest > $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/webapprt/chrome.manifest
+ endif
+-      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DIST)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
++      printf "manifest components/interfaces.manifest\nmanifest components/components.manifest\nmanifest chrome/nonlocalized.manifest\nmanifest chrome/localized.manifest\n" > $(DESTDIR)/$(MOZ_PKG_DIR)/$(_BINPATH)/chrome.manifest
  else # !MOZ_PKG_MANIFEST
- ifeq ($(MOZ_PKG_FORMAT),DMG)
- # If UNIVERSAL_BINARY, the package will be made from an already-prepared
-@@ -377,11 +377,11 @@
+ ifeq ($(MOZ_WIDGET_TOOLKIT),cocoa)
  ifndef STAGE_SDK
-       @cd $(DIST) && rsync -auv --copy-unsafe-links $(_APPNAME) $(MOZ_PKG_DIR)
+@@ -741,10 +741,10 @@
+       @$(NSINSTALL) -D $(DIST)/xpt
+       @($(XPIDL_LINK) $(DIST)/xpt/$(MOZ_PKG_APPNAME).xpt $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/*.xpt && rm -f $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/*.xpt && cp $(DIST)/xpt/$(MOZ_PKG_APPNAME).xpt $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components && printf "interfaces $(MOZ_PKG_APPNAME).xpt\n" >$(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/interfaces.manifest) || echo No *.xpt files found in: $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/components/.  Continuing...
  else
 -      @cd $(DIST)/bin && tar $(TAR_CREATE_FLAGS) - * | (cd ../$(MOZ_PKG_DIR); tar -xf -)
-+      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_APPDIR)
- endif
++      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_DIR)
  endif
  else
 -      @cd $(DIST)/bin && tar $(TAR_CREATE_FLAGS) - * | (cd ../$(MOZ_PKG_DIR); tar -xf -)
-+      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_APPDIR)
++      cp -rfLp $(DIST)/bin/* $(DESTDIR)$(MOZ_PKG_DIR)
        @echo "Linking XPT files..."
        @rm -rf $(DIST)/xpt
        @$(NSINSTALL) -D $(DIST)/xpt
+@@ -801,7 +801,7 @@
+ endif # DMG
+ endif # MOZ_PKG_MANIFEST
+ endif # UNIVERSAL_BINARY
+-      $(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR_AB_CD) $(DIST)/bin/chrome $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/chrome
++      $(OPTIMIZE_JARS_CMD) --optimize $(JARLOG_DIR_AB_CD) $(DIST)/bin/chrome $(DESTDIR)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH)/chrome
+ ifndef PKG_SKIP_STRIP
+   ifeq ($(OS_ARCH),OS2)
+               @echo "Stripping package directory..."
+@@ -830,7 +830,7 @@
+       cd $(DIST)/$(STAGEPATH)$(MOZ_PKG_DIR)$(_BINPATH) && $(PACK_OMNIJAR)
+ endif
+       $(NSINSTALL) -D $(DESTDIR)$(installdir)
+-      (cd $(DIST)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
++      (cd $(DESTDIR)/$(MOZ_PKG_DIR) && tar $(TAR_CREATE_FLAGS) - .) | \
+         (cd $(DESTDIR)$(installdir) && tar -xf -)
+       $(NSINSTALL) -D $(DESTDIR)$(bindir)
+       $(RM) -f $(DESTDIR)$(bindir)/$(MOZ_APP_NAME)
 --- comm-1.9.1/mail/app/Makefile.in.orig       2009-12-18 14:49:43.990647725 +0100
 +++ comm-1.9.1/mail/app/Makefile.in    2009-12-18 14:49:53.830739781 +0100
 @@ -48,7 +48,7 @@
- GRE_BUILDID = $(shell $(PYTHON) $(MOZILLA_SRCDIR)/config/printconfigsetting.py $(LIBXUL_DIST)/bin/platform.ini Build BuildID)
  DEFINES += \
--  -DTHUNDERBIRD_ICO=\"$(DIST)/branding/thunderbird.ico\" \
-+  -DTHUNDERBIRD_ICO=\"$(DIST)/branding/$(MOZ_APP_NAME).ico\" -DAB_CD=$(AB_CD) \
    -DAB_CD=$(AB_CD) \
+   -DAPP_VERSION="$(MOZ_APP_VERSION)" \
+-  -DTHUNDERBIRD_ICO=\"$(DIST)/branding/thunderbird.ico\" \
++  -DTHUNDERBIRD_ICO=\"$(DIST)/branding/$(MOZ_APP_NAME).ico\" \
    -DGRE_MILESTONE=$(GRE_MILESTONE) \
    -DGRE_BUILDID=$(GRE_BUILDID) \
-@@ -359,7 +359,7 @@
- endif
-       mkdir -p $(DIST)/$(APP_NAME).app/Contents/Library/Spotlight
-       rsync -a --copy-unsafe-links $(DIST)/package/Thunderbird.mdimporter $(DIST)/$(APP_NAME).app/Contents/Library/Spotlight
--      cp -RL $(DIST)/branding/thunderbird.icns $(DIST)/$(APP_NAME).app/Contents/Resources/thunderbird.icns
-+      cp -RL $(DIST)/branding/thunderbird.icns $(DIST)/branding/$(MOZ_APP_NAME).icns
-       printf APPLMOZM > $(DIST)/$(APP_NAME).app/Contents/PkgInfo
- #       remove CVS dirs from packaged app
-       find $(DIST)/$(APP_NAME).app -type d -name "CVS" -prune -exec rm -rf {} \;
+    $(NULL)
This page took 0.099035 seconds and 4 git commands to generate.