]> git.pld-linux.org Git - packages/thunderbird.git/blame_incremental - icedove.spec
- added libpng patch to fix build with libpng 1.5.x
[packages/thunderbird.git] / icedove.spec
... / ...
CommitLineData
1# TODO:
2# - separate spec for enigmail
3# - build with system mozldap
4# - replace gnome-vfs2 with gio
5# - files:
6# /usr/lib/icedove/hyphenation/hyph_en_US.dic
7# - enigmail - new version needed
8#
9# Conditional builds
10%bcond_without enigmail # don't build enigmail - GPG/PGP support
11%bcond_without gnomeui # disable gnomeui support
12%bcond_without gnomevfs # disable GNOME comp. (gconf+libgnome+gnomevfs) and gnomevfs ext.
13%bcond_without gnome # disable all GNOME components (gnome+gnomeui+gnomevfs)
14%bcond_without ldap # disable e-mail address lookups in LDAP directories
15%bcond_without lightning # disable Sunbird/Lightning calendar
16%bcond_without xulrunner # build with xulrunner
17%bcond_with crashreporter # report crashes to crash-stats.mozilla.com
18
19%if %{without gnome}
20%undefine with_gnomeui
21%undefine with_gnomevfs
22%endif
23
24%if 0%{?_enable_debug_packages} != 1
25%undefine crashreporter
26%endif
27
28%define enigmail_ver 1.3.4
29%define nspr_ver 4.8.8
30%define nss_ver 3.12.10
31
32# convert firefox release number to platform version: 9.0.x -> 9.0.x
33%define xulrunner_main 9.0
34%define xulrunner_ver %(v=%{version}; echo %{xulrunner_main}${v#9.0})
35
36%if %{without xulrunner}
37# The actual sqlite version (see RHBZ#480989):
38%define sqlite_build_version %(pkg-config --silence-errors --modversion sqlite3 2>/dev/null || echo ERROR)
39%endif
40
41Summary: Icedove - email client
42Summary(pl.UTF-8): Icedove - klient poczty
43Name: icedove
44Version: 9.0.1
45Release: 0.1
46License: MPL 1.1 or GPL v2+ or LGPL v2.1+
47Group: X11/Applications/Networking
48Source0: http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
49# Source0-md5: a5904751dbd33074682b438b732fdbab
50Source1: http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
51# Source1-md5: 2b5f188791811d248b6ff1fc51a5806a
52Source2: %{name}-branding.tar.bz2
53# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
54Source3: %{name}-rm_nonfree.sh
55Source4: %{name}.desktop
56Source5: %{name}.sh
57Patch0: %{name}-branding.patch
58Patch1: %{name}-enigmail-shared.patch
59Patch2: %{name}-gcc.patch
60Patch3: %{name}-fonts.patch
61Patch4: %{name}-install.patch
62Patch5: %{name}-hunspell.patch
63Patch6: %{name}-prefs.patch
64Patch7: system-mozldap.patch
65Patch8: %{name}-makefile.patch
66Patch9: %{name}-libpng.patch
67Patch10: %{name}-extensiondir.patch
68Patch11: crashreporter.patch
69Patch12: no-subshell.patch
70URL: http://www.pld-linux.org/Packages/Icedove
71%{?with_gnomevfs:BuildRequires: GConf2-devel >= 1.2.1}
72BuildRequires: alsa-lib-devel
73BuildRequires: automake
74BuildRequires: bzip2-devel
75BuildRequires: cairo-devel >= 1.10
76BuildRequires: dbus-glib-devel >= 0.60
77BuildRequires: freetype-devel >= 1:2.1.8
78%{?with_gnomevfs:BuildRequires: gnome-vfs2-devel >= 2.0}
79BuildRequires: gtk+2-devel >= 2:2.10.0
80BuildRequires: hunspell-devel
81BuildRequires: libIDL-devel >= 0.8.0
82%{?with_gnomevfs:BuildRequires: libgnome-devel >= 2.0}
83%{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
84%{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
85BuildRequires: libiw-devel
86BuildRequires: libjpeg-devel >= 6b
87BuildRequires: libnotify-devel >= 0.4
88BuildRequires: libpng-devel >= 1.4.1
89BuildRequires: libstdc++-devel
90BuildRequires: nspr-devel >= 1:%{nspr_ver}
91BuildRequires: nss-devel >= 1:%{nss_ver}
92BuildRequires: pango-devel >= 1:1.1.0
93BuildRequires: perl-base >= 1:5.6
94BuildRequires: pkgconfig
95BuildRequires: python >= 1:2.5
96BuildRequires: sed >= 4.0
97BuildRequires: sqlite3-devel >= 3.7.4
98BuildRequires: startup-notification-devel >= 0.8
99BuildRequires: xorg-lib-libXext-devel
100BuildRequires: xorg-lib-libXinerama-devel
101BuildRequires: xorg-lib-libXt-devel
102BuildRequires: yasm
103BuildRequires: zip
104%if %{with xulrunner}
105BuildRequires: xulrunner-devel >= 2:%{xulrunner_ver}
106%else
107Requires: myspell-common
108Requires: nspr >= 1:%{nspr_ver}
109Requires: nss >= 1:%{nss_ver}
110Requires: sqlite3 >= %{sqlite_build_version}
111%endif
112Requires(post): mktemp >= 1.5-18
113%if %{with xulrunner}
114%requires_eq_to xulrunner xulrunner-devel
115%endif
116Obsoletes: mozilla-thunderbird
117Obsoletes: mozilla-thunderbird-dictionary-en-US
118BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
119
120%define filterout_cpp -D_FORTIFY_SOURCE=[0-9]+
121
122# iceweasel/icedove/iceape provide their own versions
123%define _noautoreqdep libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
124%define _noautoprovfiles %{_libdir}/%{name}/components
125# we don't want these to satisfy xulrunner-devel
126%define _noautoprov libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
127# and as we don't provide them, don't require either
128%define _noautoreq libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
129
130%define topdir %{_builddir}/%{name}-%{version}
131%define objdir %{topdir}/obj-%{_target_cpu}
132
133%description
134Icedove is an open-source, fast and portable email client.
135
136%description -l pl.UTF-8
137Icedove jest mającym otwarte źródła, szybkim i przenośnym klientem
138poczty.
139
140%package addon-lightning
141Summary: An integrated calendar for Icedove
142Summary(pl.UTF-8): Zintegrowany kalendarz dla Icedove
143License: MPL 1.1 or GPL v2+ or LGPL v2.1+
144Group: Applications/Networking
145Requires: %{name} = %{version}-%{release}
146
147%description addon-lightning
148Lightning is an calendar extension to Icedove email client.
149
150%description addon-lightning -l pl.UTF-8
151Lightning to rozszerzenie do klienta poczty Icedove dodające
152funkcjonalność kalendarza.
153
154%package addon-enigmail
155Summary: Extension for the authentication and encryption features provided by GnuPG
156Summary(pl.UTF-8): Rozszerzenie do uwierzytelniania i szyfrowania zapewnianego przez GnuPG
157License: MPL/LGPL
158Group: Applications/Networking
159URL: http://enigmail.mozdev.org/
160Requires: %{name} = %{version}-%{release}
161Requires: gnupg
162Obsoletes: mozilla-thunderbird-addon-enigmail
163
164%description addon-enigmail
165Enigmail is an extension to the Icedove mail client which allows users
166to access the authentication and encryption features provided by
167GnuPG.
168
169Main Features:
170- Encrypt/sign mail when sending, decrypt/authenticate received mail
171- Support for inline-PGP (RFC 2440) and PGP/MIME (RFC 3156)
172- Per-Account based encryption and signing defaults
173- Per-Recipient rules for automated key selection, and
174 enabling/disabling encryption and signing
175- OpenPGP key management interface
176
177%description addon-enigmail -l pl.UTF-8
178Enigmail to rozszerzenie klienta pocztowego Icedove pozwalające
179użytkownikom na dostęp do uwierzytelniania i szyfrowania zapewnianego
180przez GnuPG.
181
182Główne możliwości:
183- szyfrowanie/podpisywanie poczty przy wysyłaniu,
184 odszyfrowywanie/uwierzytelnianie poczty odebranej
185- obsługa inline-PGP (RFC 2440) i PGP/MIME (RFC 3156)
186- ustawienia domyślne szyfrowania i podpisywania dla każdego konta
187- reguły automatycznego wyboru kluczy i włączenia szyfrowania oraz
188 podpisywania dla każdego adresata
189- interfejs do zarządzania kluczami OpenPGP
190
191%prep
192%setup -qc
193mv comm-release mozilla
194%setup -q -T -D -a2
195cd mozilla
196%{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
197/bin/sh %{SOURCE3}
198%patch0 -p1
199%{?with_enigmail:%patch1 -p1}
200%patch2 -p1
201%patch3 -p1
202%patch4 -p1
203%patch6 -p1
204%patch7 -p1
205%patch8 -p2
206%patch9 -p1
207%patch10 -p2
208%patch11 -p2
209%patch12 -p1
210
211%build
212cd mozilla
213cp -f %{_datadir}/automake/config.* mozilla/build/autoconf
214cp -f %{_datadir}/automake/config.* mozilla/nsprpub/build/autoconf
215cp -f %{_datadir}/automake/config.* ldap/sdks/c-sdk/config/autoconf
216
217install -d libxul-sdk
218ln -snf %{_libdir}/xulrunner-sdk libxul-sdk/sdk
219
220cat << EOF > .mozconfig
221mk_add_options MOZ_OBJDIR=%{objdir}
222
223export CFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
224export CXXFLAGS="%{rpmcflags} -fpermissive -I/usr/include/xulrunner"
225
226%if %{with crashreporter}
227export MOZ_DEBUG_SYMBOLS=1
228%endif
229
230# Options for 'configure' (same as command-line options).
231ac_add_options --prefix=%{_prefix}
232ac_add_options --exec-prefix=%{_exec_prefix}
233ac_add_options --bindir=%{_bindir}
234ac_add_options --sbindir=%{_sbindir}
235ac_add_options --sysconfdir=%{_sysconfdir}
236ac_add_options --datadir=%{_datadir}
237ac_add_options --includedir=%{_includedir}
238ac_add_options --libdir=%{_libdir}
239ac_add_options --libexecdir=%{_libexecdir}
240ac_add_options --localstatedir=%{_localstatedir}
241ac_add_options --sharedstatedir=%{_sharedstatedir}
242ac_add_options --mandir=%{_mandir}
243ac_add_options --infodir=%{_infodir}
244%if %{?debug:1}0
245ac_add_options --disable-optimize
246ac_add_options --enable-debug
247ac_add_options --enable-debug-modules
248ac_add_options --enable-debugger-info-modules
249ac_add_options --enable-crash-on-assert
250%else
251ac_add_options --disable-debug
252ac_add_options --disable-debug-modules
253ac_add_options --disable-logging
254ac_add_options --enable-optimize="%{rpmcflags} -Os"
255%endif
256ac_add_options --disable-strip
257ac_add_options --disable-strip-libs
258%if %{with tests}
259ac_add_options --enable-tests
260%else
261ac_add_options --disable-tests
262%endif
263%if %{with gnomeui}
264ac_add_options --enable-gnomeui
265%else
266ac_add_options --disable-gnomeui
267%endif
268%if %{with gnomevfs}
269ac_add_options --enable-gnomevfs
270%else
271ac_add_options --disable-gnomevfs
272%endif
273%if %{with ldap}
274ac_add_options --enable-ldap
275ac_add_options --with-system-ldap
276%else
277ac_add_options --disable-ldap
278%endif
279%if %{with crashreporter}
280ac_add_options --enable-crashreporter
281%else
282ac_add_options --disable-crashreporter
283%endif
284ac_add_options --disable-xterm-updates
285ac_add_options --enable-postscript
286%if %{with lightning}
287ac_add_options --enable-calendar
288%else
289ac_add_options --disable-calendar
290%endif
291ac_add_options --disable-installer
292ac_add_options --disable-jsd
293ac_add_options --disable-updater
294ac_add_options --disable-xprint
295ac_add_options --disable-permissions
296ac_add_options --disable-pref-extensions
297ac_add_options --enable-canvas
298ac_add_options --enable-crypto
299ac_add_options --enable-mathml
300ac_add_options --enable-pango
301ac_add_options --enable-reorder
302ac_add_options --enable-startup-notification
303ac_add_options --enable-svg
304ac_add_options --enable-system-cairo
305ac_add_options --enable-system-hunspell
306ac_add_options --enable-system-sqlite
307ac_add_options --enable-xft
308ac_add_options --enable-application=mail
309ac_add_options --enable-default-toolkit=cairo-gtk2
310ac_add_options --enable-xinerama
311ac_add_options --with-distribution-id=org.pld-linux
312ac_add_options --with-branding=icedove/branding
313%if %{with xulrunner}
314#ac_add_options --with-libxul-sdk=$(pwd)/libxul-sdk/sdk
315ac_add_options --with-system-libxul
316ac_add_options --enable-shared
317ac_add_options --enable-libxul
318%else
319ac_add_options --disable-xul
320%endif
321ac_add_options --with-pthreads
322ac_add_options --with-system-bz2
323ac_add_options --with-system-jpeg
324ac_add_options --with-system-nspr
325ac_add_options --with-system-nss
326ac_add_options --with-system-png
327ac_add_options --with-system-zlib
328ac_add_options --enable-single-profile
329ac_add_options --disable-profilesharing
330ac_add_options --with-default-mozilla-five-home=%{_libdir}/%{name}
331EOF
332
333%{__make} -j1 -f client.mk build \
334 STRIP="/bin/true" \
335 MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
336 CC="%{__cc}" \
337 CXX="%{__cxx}"
338
339%if %{with crashreporter}
340# create debuginfo for crash-stats.mozilla.com
341%{__make} -j1 -C obj-%{_target_cpu} buildsymbols
342%endif
343
344%if %{with enigmail}
345cd mailnews/extensions/enigmail
346./makemake -r -o %{objdir}
347%{__make} -C %{objdir}/mailnews/extensions/enigmail \
348 STRIP="/bin/true" \
349 CC="%{__cc}" \
350 CXX="%{__cxx}"
351%endif
352
353%install
354rm -rf $RPM_BUILD_ROOT
355install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{name},%{_datadir}/%{name},%{_pixmapsdir},%{_desktopdir}}
356
357cd %{objdir}
358%{__make} -C mail/installer stage-package \
359 DESTDIR=$RPM_BUILD_ROOT \
360 MOZ_PKG_DIR=%{_libdir}/%{name} \
361 PKG_SKIP_STRIP=1
362
363# Enable crash reporter for Firefox application
364%if %{with crashreporter}
365%{__sed} -i -e 's/\[Crash Reporter\]/[Crash Reporter]\nEnabled=1/' $RPM_BUILD_ROOT%{_libdir}/%{name}/application.ini
366
367# Add debuginfo for crash-stats.mozilla.com
368install -d $RPM_BUILD_ROOT%{_exec_prefix}/lib/debug%{_libdir}/%{name}
369cp -a mozilla/dist/%{name}-%{version}.en-US.linux-*.crashreporter-symbols.zip $RPM_BUILD_ROOT%{_prefix}/lib/debug%{_libdir}/%{name}
370%endif
371
372# copy manually lightning files, somewhy they are not installed by make
373cp -a mozilla/dist/bin/extensions/calendar-timezones@mozilla.org \
374 mozilla/dist/bin/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103} \
375 $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions
376
377# move arch independant ones to datadir
378mv $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome $RPM_BUILD_ROOT%{_datadir}/%{name}/chrome
379mv $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults $RPM_BUILD_ROOT%{_datadir}/%{name}/defaults
380mv $RPM_BUILD_ROOT%{_libdir}/%{name}/isp $RPM_BUILD_ROOT%{_datadir}/%{name}/isp
381mv $RPM_BUILD_ROOT%{_libdir}/%{name}/modules $RPM_BUILD_ROOT%{_datadir}/%{name}/modules
382mv $RPM_BUILD_ROOT%{_libdir}/%{name}/res $RPM_BUILD_ROOT%{_datadir}/%{name}/res
383ln -s ../../share/%{name}/chrome $RPM_BUILD_ROOT%{_libdir}/%{name}/chrome
384ln -s ../../share/%{name}/defaults $RPM_BUILD_ROOT%{_libdir}/%{name}/defaults
385ln -s ../../share/%{name}/isp $RPM_BUILD_ROOT%{_libdir}/%{name}/isp
386ln -s ../../share/%{name}/modules $RPM_BUILD_ROOT%{_libdir}/%{name}/modules
387ln -s ../../share/%{name}/res $RPM_BUILD_ROOT%{_libdir}/%{name}/res
388
389# dir for arch independant extensions besides arch dependant extensions
390# see mozilla/xpcom/build/nsXULAppAPI.h
391# XRE_SYS_LOCAL_EXTENSION_PARENT_DIR and XRE_SYS_SHARE_EXTENSION_PARENT_DIR
392install -d $RPM_BUILD_ROOT%{_datadir}/%{name}/extensions
393
394%{__rm} -r $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
395ln -s %{_datadir}/myspell $RPM_BUILD_ROOT%{_libdir}/%{name}/dictionaries
396
397%{__sed} -e 's,@LIBDIR@,%{_libdir},' %{SOURCE5} > $RPM_BUILD_ROOT%{_bindir}/icedove
398ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/thunderbird
399ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
400
401cp -p %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
402cp -p %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
403
404# files created by regxpcom -register in post
405touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
406touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
407cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
408#!/bin/sh
409umask 022
410# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
411# dangerous if you run this with sudo with keep_env += HOME
412# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
413t=$(mktemp -d)
414%{__rm} -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
415TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
416rm -rf $t
417EOF
418chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
419
420%if %{with enigmail}
421ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
422install -d $ext_dir/{chrome,components,defaults/preferences}
423cd mozilla/dist/bin
424#cp -rfLp chrome/enigmail.jar $ext_dir/chrome
425#cp -rfLp chrome/enigmime.jar $ext_dir/chrome
426cp -rfLp components/enig* $ext_dir/components
427cp -rfLp components/libenigmime.so $ext_dir/components
428cp -rfLp components/libipc.so $ext_dir/components
429cp -rfLp components/ipc.xpt $ext_dir/components
430cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
431cd -
432cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
433cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/chrome.manifest $ext_dir/chrome.manifest
434%endif
435
436# remove unecessary stuff
437#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/README.txt
438#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/components/components.list
439#%%{__rm} $RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/components.list
440
441# never package these. always remove
442# nss
443%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{freebl3,nss3,nssckbi,nssdbm3,nssutil3,smime3,softokn3,ssl3}.*
444# nspr
445%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{nspr4,plc4,plds4}.so
446# mozldap
447%{__rm} -f $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{ldap,ldif,prldap,ssldap}60.so
448
449%clean
450rm -rf $RPM_BUILD_ROOT
451
452%pretrans
453if [ -d %{_libdir}/%{name}/dictionaries ] && [ ! -L %{_libdir}/%{name}/dictionaries ]; then
454 mv -v %{_libdir}/%{name}/dictionaries{,.rpmsave}
455fi
456for d in chrome defaults icons isp modules res; do
457 if [ -d %{_libdir}/%{name}/$d ] && [ ! -L %{_libdir}/%{name}/$d ]; then
458 install -d %{_datadir}/%{name}
459 mv %{_libdir}/%{name}/$d %{_datadir}/%{name}/$d
460 fi
461done
462exit 0
463
464%post
465%{_libdir}/%{name}/register || :
466
467%files
468%defattr(644,root,root,755)
469%attr(755,root,root) %{_bindir}/icedove
470%attr(755,root,root) %{_bindir}/mozilla-thunderbird
471%attr(755,root,root) %{_bindir}/thunderbird
472%dir %{_libdir}/%{name}
473%{_libdir}/%{name}/application.ini
474%{_libdir}/%{name}/platform.ini
475%{_libdir}/%{name}/blocklist.xml
476%{_libdir}/%{name}/chrome.manifest
477%{_libdir}/%{name}/greprefs.js
478%dir %{_libdir}/%{name}/components
479%attr(755,root,root) %{_libdir}/%{name}/components/*.so
480%{_libdir}/%{name}/components/*.js
481%{_libdir}/%{name}/components/*.xpt
482%{_libdir}/%{name}/components/components.manifest
483%{_libdir}/%{name}/components/interfaces.manifest
484%attr(755,root,root) %{_libdir}/%{name}/libmozalloc.so
485#%%attr(755,root,root) %{_libdir}/%{name}/libmozjs.so
486%attr(755,root,root) %{_libdir}/%{name}/libxpcom.so
487#%%attr(755,root,root) %{_libdir}/%{name}/libxpcom_core.so
488%attr(755,root,root) %{_libdir}/%{name}/libxul.so
489%attr(755,root,root) %{_libdir}/%{name}/*.sh
490%attr(755,root,root) %{_libdir}/%{name}/*-bin
491%attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
492%attr(755,root,root) %{_libdir}/%{name}/icedove
493%attr(755,root,root) %{_libdir}/%{name}/plugin-container
494%attr(755,root,root) %{_libdir}/%{name}/register
495
496# symlinks
497%{_libdir}/%{name}/chrome
498%{_libdir}/%{name}/defaults
499%{_libdir}/%{name}/dictionaries
500#%%{_libdir}/%{name}/greprefs
501%{_libdir}/%{name}/isp
502%{_libdir}/%{name}/modules
503%{_libdir}/%{name}/res
504
505%{_pixmapsdir}/*.png
506%{_desktopdir}/*.desktop
507
508%dir %{_datadir}/%{name}
509%{_datadir}/%{name}/chrome
510%{_datadir}/%{name}/defaults
511#%%{_datadir}/%{name}/greprefs
512%{_datadir}/%{name}/isp
513%{_datadir}/%{name}/modules
514%{_datadir}/%{name}/res
515%{_datadir}/%{name}/extensions
516
517%if %{with crashreporter}
518%attr(755,root,root) %{_libdir}/%{name}/crashreporter
519%{_libdir}/%{name}/crashreporter.ini
520%{_libdir}/%{name}/Throbber-small.gif
521%endif
522
523%dir %{_libdir}/%{name}/extensions
524%{_libdir}/%{name}/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
525
526# files created by regxpcom -register
527%ghost %{_libdir}/%{name}/components/compreg.dat
528%ghost %{_libdir}/%{name}/components/xpti.dat
529
530%if %{with lightning}
531%files addon-lightning
532%defattr(644,root,root,755)
533%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}
534%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/application.ini
535%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome
536%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/chrome.manifest
537%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/defaults
538%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/install.rdf
539%dir %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components
540%attr(755,root,root) %{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.so
541%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.js
542%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.manifest
543%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/components/*.xpt
544%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/modules
545%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/calendar-js
546%{_libdir}/%{name}/extensions/{e2fda1a4-762b-4020-b5ad-a41df1933103}/timezones.sqlite
547%{_libdir}/%{name}/extensions/calendar-timezones@mozilla.org
548%endif
549
550%if %{with enigmail}
551%files addon-enigmail
552%defattr(644,root,root,755)
553%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}
554%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/defaults
555%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome
556%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/chrome.manifest
557%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/install.rdf
558%dir %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components
559%attr(755,root,root) %{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.so
560%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.xpt
561%{_libdir}/%{name}/extensions/{847b3a00-7ab1-11d4-8f02-006008948af5}/components/*.js
562%endif
This page took 0.117051 seconds and 4 git commands to generate.