]> git.pld-linux.org Git - packages/tesseract.git/blob - tesseract.spec
10a8407aa4bd0a06da6bf0d27641808bddd530e8
[packages/tesseract.git] / tesseract.spec
1 # TODO:
2 # - warnings at compile stage about pointer size on amd64 - needs check
3 # - warning: Installed (but unpackaged) file(s) found:
4 #        /usr/bin/language-specific.sh
5 #        /usr/bin/tesstrain.sh
6 #        /usr/bin/tesstrain_utils.sh
7 #
8 # Conditional build:
9 %bcond_without  openmp  # OpenMP support
10 %bcond_with     opencl  # OpenCL support
11 Summary:        Tesseract Open Source OCR Engine
12 Summary(pl.UTF-8):      Tesseract - silnik OCR o otwartych źródłach
13 Name:           tesseract
14 Version:        4.1.1
15 Release:        1
16 License:        Apache v2.0
17 Group:          Applications/Graphics
18 #Source0Download: https://github.com/tesseract-ocr/tesseract/releases
19 Source0:        https://github.com/tesseract-ocr/tesseract/archive/%{version}/%{name}-%{version}.tar.gz
20 # Source0-md5:  51fe2bcbff1bbce77a25d180fd247f7d
21 URL:            https://github.com/tesseract-ocr/
22 %{?with_opencl:BuildRequires:   OpenCL-devel}
23 BuildRequires:  autoconf >= 2.63
24 BuildRequires:  automake
25 BuildRequires:  cairo-devel
26 BuildRequires:  curl-devel
27 BuildRequires:  leptonlib-devel >= 1.74
28 BuildRequires:  libarchive-devel
29 %{?with_openmp:BuildRequires:   libgomp-devel}
30 BuildRequires:  libicu-devel >= 52.1
31 BuildRequires:  libstdc++-devel >= 6:4.7
32 BuildRequires:  libtiff-devel
33 BuildRequires:  libtool >= 2:2
34 BuildRequires:  pango-devel >= 1:1.22.0
35 Requires:       leptonlib >= 1.74
36 Suggests:       tesseract-data >= 3
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %description
40 A commercial quality OCR engine originally developed at HP between
41 1985 and 1995. In 1995, this engine was among the top 3 evaluated by
42 UNLV. It was open-sourced by HP and UNLV in 2005.
43
44 %description -l pl.UTF-8
45 Silnik OCR o komercyjnej jakości oryginalnie stworzony przez HP w
46 latach 1985-1995. W 1995 roku był jednym z 3 najlepszych wg UNLV.
47 Źródła zostały uwolnione przez HP i UNLV w 2005 roku.
48
49 %package training
50 Summary:        Tesseract training tools
51 Summary(pl.UTF-8):      Narzędzia treningowe Tesseracta
52 Group:          Applications/Graphics
53 Requires:       %{name} = %{version}-%{release}
54 Requires:       pango >= 1:1.22.0
55
56 %description training
57 This package contains the Tesseract training tools.
58
59 %description training -l pl.UTF-8
60 Ten pakiet zawiera programy do trenowania Tesseracta.
61
62 %package devel
63 Summary:        Header files for Tesseract libraries
64 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek Tesseracta
65 Group:          Development/Libraries
66 Requires:       %{name} = %{version}-%{release}
67 Requires:       curl-devel
68 Requires:       leptonlib-devel >= 1.74
69 Requires:       libarchive-devel
70 Requires:       libstdc++-devel >= 6:4.7
71
72 %description devel
73 This package contains the development header files necessary to
74 develop applications using Tesseract API.
75
76 %description devel -l pl.UTF-8
77 Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia programów
78 wykorzystujących API Tesseracta.
79
80 %package static
81 Summary:        Static Tesseract libraries
82 Summary(pl.UTF-8):      Statyczne biblioteki Tesseracta
83 Group:          Development/Libraries
84 Requires:       %{name}-devel = %{version}-%{release}
85
86 %description static
87 Static Tesseract libraries.
88
89 %description static -l pl.UTF-8
90 Statyczne biblioteki Tesseracta.
91
92 %prep
93 %setup -q
94
95 %build
96 %{__libtoolize}
97 %{__aclocal}
98 %{__autoconf}
99 %{__autoheader}
100 %{__automake}
101 %configure \
102         %{?with_opencl:--enable-opencl} \
103         %{!?with_openmp:--disable-openmp}
104 %{__make}
105 %{__make} training
106
107 %install
108 rm -rf $RPM_BUILD_ROOT
109
110 %{__make} install \
111         DESTDIR=$RPM_BUILD_ROOT
112
113 %{__make} training-install \
114         DESTDIR=$RPM_BUILD_ROOT
115
116 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libtesseract.la
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README.md
127 %attr(755,root,root) %{_bindir}/tesseract
128 %attr(755,root,root) %{_libdir}/libtesseract.so.*.*.*
129 %attr(755,root,root) %ghost %{_libdir}/libtesseract.so.4
130 %{_datadir}/tessdata
131 %{_mandir}/man1/tesseract.1*
132
133 %files training
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_bindir}/ambiguous_words
136 %attr(755,root,root) %{_bindir}/classifier_tester
137 %attr(755,root,root) %{_bindir}/cntraining
138 %attr(755,root,root) %{_bindir}/combine_lang_model
139 %attr(755,root,root) %{_bindir}/combine_tessdata
140 %attr(755,root,root) %{_bindir}/dawg2wordlist
141 %attr(755,root,root) %{_bindir}/lstmeval
142 %attr(755,root,root) %{_bindir}/lstmtraining
143 %attr(755,root,root) %{_bindir}/merge_unicharsets
144 %attr(755,root,root) %{_bindir}/mftraining
145 %attr(755,root,root) %{_bindir}/set_unicharset_properties
146 %attr(755,root,root) %{_bindir}/shapeclustering
147 %attr(755,root,root) %{_bindir}/text2image
148 %attr(755,root,root) %{_bindir}/unicharset_extractor
149 %attr(755,root,root) %{_bindir}/wordlist2dawg
150 %{_mandir}/man1/ambiguous_words.1*
151 %{_mandir}/man1/classifier_tester.1*
152 %{_mandir}/man1/cntraining.1*
153 %{_mandir}/man1/combine_lang_model.1*
154 %{_mandir}/man1/combine_tessdata.1*
155 %{_mandir}/man1/dawg2wordlist.1*
156 %{_mandir}/man1/lstmeval.1*
157 %{_mandir}/man1/lstmtraining.1*
158 %{_mandir}/man1/merge_unicharsets.1*
159 %{_mandir}/man1/mftraining.1*
160 %{_mandir}/man1/set_unicharset_properties.1*
161 %{_mandir}/man1/shapeclustering.1*
162 %{_mandir}/man1/text2image.1*
163 %{_mandir}/man1/unicharset_extractor.1*
164 %{_mandir}/man1/wordlist2dawg.1*
165
166 %files devel
167 %defattr(644,root,root,755)
168 %attr(755,root,root) %{_libdir}/libtesseract.so
169 %{_includedir}/%{name}
170 %{_pkgconfigdir}/tesseract.pc
171 %{_mandir}/man5/unicharambigs.5*
172 %{_mandir}/man5/unicharset.5*
173
174 %files static
175 %defattr(644,root,root,755)
176 %{_libdir}/libtesseract.a
This page took 0.054922 seconds and 2 git commands to generate.