]> git.pld-linux.org Git - packages/tepl.git/blob - tepl.spec
9674468cfb75bce538c6beeaa73ffd1f85213913
[packages/tepl.git] / tepl.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs         # API documentation
4 %bcond_without  static_libs     # static library
5 #
6 Summary:        Tepl - Text editor product line
7 Summary(pl.UTF-8):      Tepl (Text editor product line) - linia produkcyjna edytorów
8 Name:           tepl
9 Version:        6.8.0
10 Release:        1
11 License:        LGPL v2.1+
12 Group:          Libraries
13 Source0:        https://download.gnome.org/sources/tepl/6.8/%{name}-%{version}.tar.xz
14 # Source0-md5:  5d29b2c9032a1ba2d33ef9c9c9c7de79
15 URL:            https://wiki.gnome.org/Projects/Tepl
16 BuildRequires:  gettext-tools >= 0.19.6
17 BuildRequires:  glib2-devel >= 1:2.74
18 BuildRequires:  gobject-introspection-devel >= 1.42.0
19 BuildRequires:  gsettings-desktop-schemas-devel
20 BuildRequires:  gtk+3-devel >= 3.22
21 %{?with_apidocs:BuildRequires:  gtk-doc >= 1.25}
22 BuildRequires:  libgedit-amtk-devel >= 5.8
23 BuildRequires:  libgedit-gtksourceview-devel >= 299.0.4
24 BuildRequires:  libicu-devel
25 BuildRequires:  libxml2-devel >= 1:2.5
26 BuildRequires:  meson >= 0.64
27 BuildRequires:  ninja >= 1.5
28 BuildRequires:  pkgconfig
29 BuildRequires:  rpm-build >= 4.6
30 BuildRequires:  rpmbuild(macros) >= 1.752
31 #BuildRequires: vala
32 Requires:       glib2 >= 1:2.74
33 Requires:       gtk+3 >= 3.22
34 Requires:       libgedit-gtksourceview >= 299.0.4
35 Requires:       libxml2 >= 1:2.5
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Tepl is a library that eases the development of GtkSourceView-based
40 text editors and IDEs.
41
42 Tepl was previously named Gtef (GTK+ text editor framework). The
43 project has been renamed in June 2017 to have a more beautiful name.
44
45 %description -l pl.UTF-8
46 Tepl to biblioteka ułatawiająca tworzenie edytorów tekstu i IDE
47 opartych na GtkSourceView.
48
49 Tepl wcześniej nazywał się Gtef (GTK+ text editor framework - skielet
50 edytorów tekstu GTK+); nazwa została zmieniona w czerwcu 2017 na
51 ładniej brzmiącą.
52
53 %package devel
54 Summary:        Header files for Tepl library
55 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki Tepl
56 Group:          Development/Libraries
57 Requires:       %{name} = %{version}-%{release}
58 Requires:       glib2-devel >= 1:2.74
59 Requires:       gsettings-desktop-schemas-devel
60 Requires:       gtk+3-devel >= 3.22
61 Requires:       libgedit-amtk-devel >= 5.8
62 Requires:       libgedit-gtksourceview-devel >= 299.0.4
63 Requires:       libicu-devel
64 Requires:       libxml2-devel >= 1:2.5
65 # temporary? no vapi in 2.99.2
66 Obsoletes:      vala-tepl < 2.99.2
67
68 %description devel
69 Header files for Tepl library.
70
71 %description devel -l pl.UTF-8
72 Pliki nagłówkowe biblioteki Tepl.
73
74 %package static
75 Summary:        Static Tepl library
76 Summary(pl.UTF-8):      Statyczna biblioteka Tepl
77 Group:          Development/Libraries
78 Requires:       %{name}-devel = %{version}-%{release}
79
80 %description static
81 Static Tepl library.
82
83 %description static -l pl.UTF-8
84 Statyczna biblioteka Tepl.
85
86 %package -n vala-tepl
87 Summary:        Vala API for Tepl library
88 Summary(pl.UTF-8):      API języka Vala do biblioteki Tepl
89 Group:          Development/Libraries
90 Requires:       %{name}-devel = %{version}-%{release}
91 Requires:       vala
92 BuildArch:      noarch
93
94 %description -n vala-tepl
95 Vala API for Tepl library.
96
97 %description -n vala-tepl -l pl.UTF-8
98 API języka Vala do biblioteki Tepl.
99
100 %package apidocs
101 Summary:        API documentation for Tepl library
102 Summary(pl.UTF-8):      Dokumentacja API biblioteki Tepl
103 Group:          Documentation
104 BuildArch:      noarch
105
106 %description apidocs
107 API documentation for Tepl library.
108
109 %description apidocs -l pl.UTF-8
110 Dokumentacja API biblioteki Tepl.
111
112 %prep
113 %setup -q
114
115 %build
116 %meson build \
117         %{!?with_static_libs:--default-library=shared} \
118         %{?with_apidocs:-Dgtk_doc=true}
119
120 %ninja_build -C build
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %ninja_install -C build
126
127 %find_lang tepl-6
128
129 %clean
130 rm -rf $RPM_BUILD_ROOT
131
132 %post   -p /sbin/ldconfig
133 %postun -p /sbin/ldconfig
134
135 %files -f tepl-6.lang
136 %defattr(644,root,root,755)
137 %doc NEWS README.md
138 %attr(755,root,root) %{_libdir}/libtepl-6.so.4
139 %{_libdir}/girepository-1.0/Tepl-6.typelib
140
141 %files devel
142 %defattr(644,root,root,755)
143 %attr(755,root,root) %{_libdir}/libtepl-6.so
144 %{_includedir}/tepl-6
145 %{_datadir}/gir-1.0/Tepl-6.gir
146 %{_pkgconfigdir}/tepl-6.pc
147
148 %if %{with static_libs}
149 %files static
150 %defattr(644,root,root,755)
151 %{_libdir}/libtepl-6.a
152 %endif
153
154 %if 0
155 %files -n vala-tepl
156 %defattr(644,root,root,755)
157 %{_datadir}/vala/vapi/tepl-6.deps
158 %{_datadir}/vala/vapi/tepl-6.vapi
159 %endif
160
161 %if %{with apidocs}
162 %files apidocs
163 %defattr(644,root,root,755)
164 %{_gtkdocdir}/tepl-6
165 %endif
This page took 0.10223 seconds and 3 git commands to generate.