]> git.pld-linux.org Git - packages/telepathy-qt4.git/commitdiff
- updated to 0.9.7 auto/th/telepathy-qt4-0.9.7-1
authorJakub Bogusz <qboosh@pld-linux.org>
Wed, 22 Jun 2016 19:55:28 +0000 (21:55 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Wed, 22 Jun 2016 19:55:28 +0000 (21:55 +0200)
- updated warnings patch
- added qt4 patch (disable one qt5-specific test when building for qt4)
- added link patch (fix libtelepathy-qt?-service linking)

telepathy-qt-link.patch [new file with mode: 0644]
telepathy-qt-qt4.patch [new file with mode: 0644]
telepathy-qt-warnings.patch
telepathy-qt4.spec

diff --git a/telepathy-qt-link.patch b/telepathy-qt-link.patch
new file mode 100644 (file)
index 0000000..3ac0376
--- /dev/null
@@ -0,0 +1,10 @@
+--- telepathy-qt-0.9.7/TelepathyQt/CMakeLists.txt.orig 2016-06-12 13:04:05.000000000 +0200
++++ telepathy-qt-0.9.7/TelepathyQt/CMakeLists.txt      2016-06-21 22:05:40.686973292 +0200
+@@ -989,6 +989,7 @@
+     target_link_libraries(telepathy-qt${QT_VERSION_MAJOR}-service
+         ${QT_QTDBUS_LIBRARY}
+         ${QT_QTCORE_LIBRARY}
++        telepathy-qt${QT_VERSION_MAJOR}
+         ${TP_QT_LIBRARY_LINKER_FLAGS})
+     # Set the correct version number
diff --git a/telepathy-qt-qt4.patch b/telepathy-qt-qt4.patch
new file mode 100644 (file)
index 0000000..8d8dcc0
--- /dev/null
@@ -0,0 +1,12 @@
+--- telepathy-qt-0.9.7/tests/dbus/CMakeLists.txt.orig  2016-06-12 13:04:05.000000000 +0200
++++ telepathy-qt-0.9.7/tests/dbus/CMakeLists.txt       2016-06-18 15:54:56.271798442 +0200
+@@ -93,7 +93,9 @@
+ if(ENABLE_SERVICE_SUPPORT)
+     tpqt_add_dbus_unit_test(BaseConnectionManager base-cm telepathy-qt${QT_VERSION_MAJOR}-service)
+     tpqt_add_dbus_unit_test(BaseProtocol base-protocol telepathy-qt${QT_VERSION_MAJOR}-service)
++    if (${QT_VERSION_MAJOR} GREATER 4)
+     tpqt_add_dbus_unit_test(BaseChannelFileTransferType base-filetransfer telepathy-qt${QT_VERSION_MAJOR}-service)
++    endif (${QT_VERSION_MAJOR} GREATER 4)
+ endif(ENABLE_SERVICE_SUPPORT)
+ # Make check target. In case of check, output on failure and put it into a log
index 990aa6578625dacc3d60d04deabfbb9c2d9bd09b..38e271057f1694a8639adc114662533714c0ae8f 100644 (file)
@@ -1,21 +1,10 @@
---- telepathy-qt-0.9.6.1/cmake/modules/TelepathyDefaults.cmake.orig    2015-05-24 21:33:18.000000000 +0200
-+++ telepathy-qt-0.9.6.1/cmake/modules/TelepathyDefaults.cmake 2015-05-29 18:06:23.916014194 +0200
-@@ -108,7 +108,7 @@
-     endif(${NOT_RELEASE} EQUAL 1)
-     if(CMAKE_SYSTEM_NAME MATCHES Linux)
--        add_definitions(-D_BSD_SOURCE)
-+        add_definitions(-D_DEFAULT_SOURCE)
-     endif(CMAKE_SYSTEM_NAME MATCHES Linux)
-     # Compiler coverage
 --- telepathy-qt-0.9.6.1/tests/dbus/stream-tube-chan.cpp.orig  2015-05-24 21:33:18.000000000 +0200
 +++ telepathy-qt-0.9.6.1/tests/dbus/stream-tube-chan.cpp       2015-05-29 18:55:05.122558269 +0200
 @@ -118,6 +118,7 @@
          g_object_unref(localAddress);
  
          Q_ASSERT(success);
-+      (void)success;
++        (void)success;
      }
  
      return clientSocket;
index cd7450f2132b2bb10d6c3508bf376070363028d1..121928c3d749372c7d257b349b43d64caccc9691 100644 (file)
 Summary:       Library for Qt4-based Telepathy clients
 Summary(pl.UTF-8):     Biblioteka dla klientów Telepathy opartych na Qt4
 Name:          telepathy-qt4
-Version:       0.9.6.1
+Version:       0.9.7
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://telepathy.freedesktop.org/releases/telepathy-qt/%{orgname}-%{version}.tar.gz
-# Source0-md5: bebebfbe29d194a9ba00b4f422a44f74
+Source0:       https://telepathy.freedesktop.org/releases/telepathy-qt/%{orgname}-%{version}.tar.gz
+# Source0-md5: 86470dd3d7f6de8b8f4f36165486d42f
 Patch0:                telepathy-qt-warnings.patch
-URL:           http://telepathy.freedesktop.org/wiki/Telepathy-Qt4
-BuildRequires: cmake >= 2.6
+Patch1:                telepathy-qt-qt4.patch
+Patch2:                telepathy-qt-link.patch
+URL:           https://telepathy.freedesktop.org/wiki/Telepathy-Qt4
+BuildRequires: cmake >= 2.8.12
 BuildRequires: dbus-devel
 BuildRequires: dbus-glib-devel
 BuildRequires: farstream-devel >= 0.2.0
-BuildRequires: glib2-devel >= 2.0
+BuildRequires: glib2-devel >= 1:2.16
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: pkgconfig
 BuildRequires: python-dbus
@@ -137,6 +139,8 @@ Pliki nagłówkowe biblioteki telepathy-qt5.
 %prep
 %setup -q -n %{orgname}-%{version}
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
 
 %build
 %if %{with qt4}
@@ -193,13 +197,15 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4.so.2
 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farstream.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4-farstream.so.2
+%attr(755,root,root) %{_libdir}/libtelepathy-qt4-service.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4-service.so.0
 
 %files devel
 %defattr(644,root,root,755)
 %doc doc/html
 %attr(755,root,root) %{_libdir}/libtelepathy-qt4.so
 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farstream.so
-%{_libdir}/libtelepathy-qt4-service.a
+%attr(755,root,root) %{_libdir}/libtelepathy-qt4-service.so
 %{_libdir}/cmake/TelepathyQt4
 %{_libdir}/cmake/TelepathyQt4Farstream
 %{_libdir}/cmake/TelepathyQt4Service
@@ -221,12 +227,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5.so.0
 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5-farstream.so.0
+%attr(755,root,root) %{_libdir}/libtelepathy-qt5-service.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5-service.so.0
 
 %files -n telepathy-qt5-devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so
 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so
-%{_libdir}/libtelepathy-qt5-service.a
+%attr(755,root,root) %{_libdir}/libtelepathy-qt5-service.so
 %{_libdir}/cmake/TelepathyQt5
 %{_libdir}/cmake/TelepathyQt5Farstream
 %{_libdir}/cmake/TelepathyQt5Service
This page took 0.06367 seconds and 4 git commands to generate.