]> git.pld-linux.org Git - packages/telepathy-qt4.git/blob - telepathy-qt4.spec
99b119dd6ecf943be103e01141ad0186b78eeeee
[packages/telepathy-qt4.git] / telepathy-qt4.spec
1 #
2 # Conditional build:
3 %bcond_without  qt4     # Qt4 interface
4 %bcond_without  qt5     # Qt5 interface
5
6 # "telepathy_qt" name is occupied by earlier work under the same name from different project;
7 # thus spec and repo stick to original "telepathy-qt4" name of this project (used before 0.9.0 release)
8 %define         orgname telepathy-qt
9 %define         qt4_ver         4.8.2
10 %define         qt5_ver         5.0.0
11
12 Summary:        Library for Qt4-based Telepathy clients
13 Summary(pl.UTF-8):      Biblioteka dla klientów Telepathy opartych na Qt4
14 Name:           telepathy-qt4
15 Version:        0.9.5
16 Release:        2
17 License:        LGPL v2.1+
18 Group:          Libraries
19 Source0:        http://telepathy.freedesktop.org/releases/telepathy-qt/%{orgname}-%{version}.tar.gz
20 # Source0-md5:  22c0daa7e4f7e48e779f703c9b27b816
21 URL:            http://telepathy.freedesktop.org/wiki/Telepathy-Qt4
22 BuildRequires:  cmake >= 2.6
23 BuildRequires:  dbus-devel
24 BuildRequires:  dbus-glib-devel
25 BuildRequires:  farstream-devel >= 0.2.0
26 BuildRequires:  glib2-devel >= 2.0
27 BuildRequires:  libxml2-devel >= 2.0
28 BuildRequires:  pkgconfig
29 BuildRequires:  python-dbus
30 BuildRequires:  python-devel >= 1:2.5
31 BuildRequires:  python-modules >= 1:2.5
32 BuildRequires:  python-pygobject
33 BuildRequires:  rpmbuild(macros) >= 1.293
34 BuildRequires:  telepathy-farstream-devel >= 0.6.0
35 BuildRequires:  telepathy-glib-devel >= 0.18.0
36 %if %{with qt4}
37 BuildRequires:  QtCore-devel >= %{qt4_ver}
38 BuildRequires:  QtDBus-devel >= %{qt4_ver}
39 BuildRequires:  QtGui-devel >= %{qt4_ver}
40 BuildRequires:  QtHelp >= %{qt4_ver}
41 BuildRequires:  QtNetwork-devel >= %{qt4_ver}
42 BuildRequires:  QtXml-devel >= %{qt4_ver}
43 BuildRequires:  QtTest-devel >= %{qt4_ver}
44 BuildRequires:  qt4-build >= %{qt4_ver}
45 BuildRequires:  qt4-qmake >= %{qt4_ver}
46 %endif
47 %if %{with qt5}
48 BuildRequires:  Qt5Core-devel >= %{qt5_ver}
49 BuildRequires:  Qt5DBus-devel >= %{qt5_ver}
50 BuildRequires:  Qt5Gui-devel >= %{qt5_ver}
51 BuildRequires:  Qt5Network-devel >= %{qt5_ver}
52 BuildRequires:  Qt5Test-devel >= %{qt5_ver}
53 BuildRequires:  Qt5Widgets-devel >= %{qt5_ver}
54 BuildRequires:  Qt5Xml-devel >= %{qt5_ver}
55 BuildRequires:  qt5-assistant >= %{qt5_ver}
56 BuildRequires:  qt5-build >= %{qt5_ver}
57 BuildRequires:  qt5-qmake >= %{qt5_ver}
58 %endif
59 Requires:       QtCore >= %{qt4_ver}
60 Requires:       QtDBus >= %{qt4_ver}
61 Requires:       QtNetwork >= %{qt4_ver}
62 Requires:       QtXml >= %{qt4_ver}
63 Requires:       telepathy-farstream >= 0.6.0
64 Requires:       telepathy-glib >= 0.18.0
65 Obsoletes:      telepathy-qt4-yell
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %description
69 Library for Qt4-based Telepathy clients.
70
71 %description -l pl.UTF-8
72 Biblioteka dla klientów Telepathy opartych na Qt4.
73
74 %package devel
75 Summary:        Header files for telepathy-qt4 library
76 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki telepathy-qt4
77 Group:          Development/Libraries
78 Requires:       %{name} = %{version}-%{release}
79 Requires:       QtCore-devel >= %{qt4_ver}
80 Requires:       QtDBus-devel >= %{qt4_ver}
81 Requires:       QtNetwork-devel >= %{qt4_ver}
82 Requires:       QtXml-devel >= %{qt4_ver}
83 Obsoletes:      telepathy-qt4-yell-devel
84
85 %description devel
86 Header files for telepathy-qt4 library.
87
88 %description devel -l pl.UTF-8
89 Pliki nagłówkowe biblioteki telepathy-qt4.
90
91 %package apidocs
92 Summary:        API documentation for telepathy-qt4 and telepathy-qt5 libraries
93 Summary(pl.UTF-8):      Dokumentacja API bibliotek telepathy-qt5 i telepathy-qt5
94 Group:          Documentation
95
96 %description apidocs
97 API documentation for telepathy-qt4 and telepathy-qt5 libraries.
98
99 %description apidocs -l pl.UTF-8
100 Dokumentacja API bibliotek telepathy-qt5 i telepathy-qt5.
101
102 %package -n telepathy-qt5
103 Summary:        Library for Qt5-based Telepathy clients
104 Summary(pl.UTF-8):      Biblioteka dla klientów Telepathy opartych na Qt5
105 Group:          Libraries
106 Requires:       Qt5Core >= %{qt5_ver}
107 Requires:       Qt5DBus >= %{qt5_ver}
108 Requires:       Qt5Network >= %{qt5_ver}
109 Requires:       Qt5Xml >= %{qt5_ver}
110 Requires:       telepathy-farstream >= 0.6.0
111 Requires:       telepathy-glib >= 0.18.0
112
113 %description -n telepathy-qt5
114 Library for Qt5-based Telepathy clients.
115
116 %description -n telepathy-qt5 -l pl.UTF-8
117 Biblioteka dla klientów Telepathy opartych na Qt5.
118
119 %package -n telepathy-qt5-devel
120 Summary:        Header files for telepathy-qt5 library
121 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki telepathy-qt5
122 Group:          Development/Libraries
123 Requires:       telepathy-qt5 = %{version}-%{release}
124 Requires:       Qt5Core-devel >= %{qt5_ver}
125 Requires:       Qt5DBus-devel >= %{qt5_ver}
126
127 %description -n telepathy-qt5-devel
128 Header files for telepathy-qt5 library.
129
130 %description -n telepathy-qt5-devel -l pl.UTF-8
131 Pliki nagłówkowe biblioteki telepathy-qt5.
132
133 %prep
134 %setup -q -n %{orgname}-%{version}
135
136 %build
137 %if %{with qt4}
138 install -d build-qt4
139 cd build-qt4
140 %cmake .. \
141         -DENABLE_FARSTREAM:BOOL=ON \
142         -DDESIRED_QT_VERSION=4 \
143         -DQT_QMAKE_EXECUTABLE_FINDQT=%{_libdir}/qt4/bin/qmake
144
145 %{__make}
146 cd ..
147 %endif
148
149 %if %{with qt5}
150 install -d build-qt5
151 cd build-qt5
152 %cmake .. \
153         -DENABLE_FARSTREAM:BOOL=ON \
154         -DDESIRED_QT_VERSION=5 \
155         -DQT_QMAKE_EXECUTABLE_FINDQT=%{_libdir}/qt5/bin/qmake
156
157 %{__make}
158 cd ..
159 %endif
160
161 %install
162 rm -rf $RPM_BUILD_ROOT
163
164 %if %{with qt4}
165 %{__make} -C build-qt4 install \
166         DESTDIR=$RPM_BUILD_ROOT
167 %endif
168
169 %if %{with qt5}
170 %{__make} -C build-qt5 install \
171         DESTDIR=$RPM_BUILD_ROOT
172 %endif
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p /sbin/ldconfig
178 %postun -p /sbin/ldconfig
179
180 %post   -n telepathy-qt5 -p /sbin/ldconfig
181 %postun -n telepathy-qt5 -p /sbin/ldconfig
182
183 %if %{with qt4}
184 %files
185 %defattr(644,root,root,755)
186 %doc AUTHORS ChangeLog NEWS README
187 %attr(755,root,root) %{_libdir}/libtelepathy-qt4.so.*.*.*
188 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4.so.2
189 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farstream.so.*.*.*
190 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt4-farstream.so.2
191
192 %files devel
193 %defattr(644,root,root,755)
194 %doc doc/html
195 %attr(755,root,root) %{_libdir}/libtelepathy-qt4.so
196 %attr(755,root,root) %{_libdir}/libtelepathy-qt4-farstream.so
197 %{_libdir}/libtelepathy-qt4-service.a
198 %{_libdir}/cmake/TelepathyQt4
199 %{_libdir}/cmake/TelepathyQt4Farstream
200 %{_libdir}/cmake/TelepathyQt4Service
201 %{_includedir}/telepathy-qt4
202 %{_pkgconfigdir}/TelepathyQt4.pc
203 %{_pkgconfigdir}/TelepathyQt4Farstream.pc
204 %{_pkgconfigdir}/TelepathyQt4Service.pc
205 %endif
206
207 %files apidocs
208 %defattr(644,root,root,755)
209 %doc doc/html/*
210
211 %if %{with qt5}
212 %files -n telepathy-qt5
213 %defattr(644,root,root,755)
214 %doc AUTHORS ChangeLog NEWS README
215 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so.*.*.*
216 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5.so.0
217 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so.*.*.*
218 %attr(755,root,root) %ghost %{_libdir}/libtelepathy-qt5-farstream.so.0
219
220 %files -n telepathy-qt5-devel
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_libdir}/libtelepathy-qt5.so
223 %attr(755,root,root) %{_libdir}/libtelepathy-qt5-farstream.so
224 %{_libdir}/libtelepathy-qt5-service.a
225 %{_libdir}/cmake/TelepathyQt5
226 %{_libdir}/cmake/TelepathyQt5Farstream
227 %{_libdir}/cmake/TelepathyQt5Service
228 %{_includedir}/telepathy-qt5
229 %{_pkgconfigdir}/TelepathyQt5.pc
230 %{_pkgconfigdir}/TelepathyQt5Farstream.pc
231 %{_pkgconfigdir}/TelepathyQt5Service.pc
232 %endif
This page took 0.069463 seconds and 2 git commands to generate.