]> git.pld-linux.org Git - packages/tdb.git/commitdiff
- initial versions
authortommat <tommat@pld-linux.org>
Fri, 12 Nov 2004 09:54:50 +0000 (09:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    tdb-Makefile-extras.patch -> 1.1
    tdb-tdb_store.patch -> 1.1

tdb-Makefile-extras.patch [new file with mode: 0644]
tdb-tdb_store.patch [new file with mode: 0644]

diff --git a/tdb-Makefile-extras.patch b/tdb-Makefile-extras.patch
new file mode 100644 (file)
index 0000000..5da4ed6
--- /dev/null
@@ -0,0 +1,11 @@
+--- tdb-1.0.6/Makefile.am.orig 2001-12-11 05:05:13.000000000 +0100
++++ tdb-1.0.6/Makefile.am      2004-11-12 00:33:16.133127976 +0100
+@@ -14,7 +14,7 @@
+ endif
+ noinst_PROGRAMS=tdbspeed tdbiterate $(TDBTEST) $(TDBTORTURE)
+-bin_PROGRAMS=tdbtool tdbdump
++bin_PROGRAMS=tdbtool tdbdump $(noinst_PROGRAMS)
+ lib_LTLIBRARIES=libtdb.la
diff --git a/tdb-tdb_store.patch b/tdb-tdb_store.patch
new file mode 100644 (file)
index 0000000..e4d12ef
--- /dev/null
@@ -0,0 +1,27 @@
+--- tdb-1.0.6/tdb.c    Tue Dec 11 14:39:51 2001
++++ tdb-1.0.6-lbw/tdb.c        Mon Dec  2 14:50:37 2002
+@@ -1303,6 +1303,9 @@
+       char *p = NULL;
+       int ret = 0;
++      /* do not allow a store to read-only database */
++      if (tdb->read_only) return -1;
++
+       /* find which hash bucket it is in */
+       hash = tdb_hash(&key);
+       if (!tdb_keylocked(tdb, hash))
+--- tdb-1.0.6/tdb_open.3       Tue May  8 23:35:46 2001
++++ tdb-1.0.6-lbw/tdb_open.3   Mon Dec  2 14:53:03 2002
+@@ -20,10 +20,8 @@
+ .TP
+ .B TDB_INTERNAL
+ Don't use a file, instead store the data in memory. The 
+-.I pathname
+-,
+-.I open_flags
+-, and
++.I pathname 
++and
+ .I mode
+ are ignored in
+ this case. This is useful if you need a quick associative array or map.
This page took 0.032814 seconds and 4 git commands to generate.