]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
- added include patch (tdb.h requires stdbool.h)
[packages/tdb.git] / tdb.spec
1 Summary:        TDB - Trivial Database
2 Summary(pl.UTF-8):      TDB - prosta baza danych
3 Name:           tdb
4 Version:        1.3.1
5 Release:        1
6 Epoch:          2
7 License:        LGPL v3+
8 Group:          Libraries
9 Source0:        http://www.samba.org/ftp/tdb/%{name}-%{version}.tar.gz
10 # Source0-md5:  f597190451d976fe013dfae9934fb9ad
11 Patch0:         %{name}-include.patch
12 URL:            http://tdb.samba.org/
13 BuildRequires:  python-devel >= 2
14 BuildRequires:  rpm-pythonprov
15 Obsoletes:      tdb-extras
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 TDB is a Trivial Database. In concept, it is very much like GDBM, and
20 BSD's DB except that it allows multiple simultaneous writers and uses
21 locking internally to keep writers from trampling on each other. TDB
22 is also extremely small.
23
24 %description -l pl.UTF-8
25 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
26 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
27 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
28 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
29 ekstremalnie mała.
30
31 %package devel
32 Summary:        Header files for TDB library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
34 Group:          Development/Libraries
35 Requires:       %{name} = %{epoch}:%{version}-%{release}
36 Obsoletes:      tdb-static
37
38 %description devel
39 Header files for TDB library.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe biblioteki TDB.
43
44 %package -n python-tdb
45 Summary:        Python bindings for TDB
46 Summary(pl.UTF-8):      Pythonowy interfejs do TDB
47 Group:          Libraries/Python
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49 %pyrequires_eq  python-libs
50
51 %description -n python-tdb
52 Python bindings for TDB.
53
54 %description -n python-tdb -l pl.UTF-8
55 Pythonowy interfejs do TDB.
56
57 %prep
58 %setup -q
59 %patch0 -p1
60
61 %build
62 # note: configure in fact is waf call
63 CC="%{__cc}" \
64 CFLAGS="%{rpmcflags}" \
65 PYTHONDIR=%{py_sitedir} \
66 ./configure \
67         --prefix=%{_prefix} \
68         --libdir=%{_libdir}
69
70 %{__make} \
71         V=1
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %triggerpostun -p /sbin/postshell -- tdb < 2:1.2.9-2
86 -rm -f %{_libdir}/libtdb.so.1
87 /sbin/ldconfig
88
89 %files
90 %defattr(644,root,root,755)
91 %doc docs/{README,mutex.txt,tracing.txt}
92 %attr(755,root,root) %{_bindir}/tdbbackup
93 %attr(755,root,root) %{_bindir}/tdbdump
94 %attr(755,root,root) %{_bindir}/tdbrestore
95 %attr(755,root,root) %{_bindir}/tdbtool
96 %attr(755,root,root) %{_libdir}/libtdb.so.*.*.*
97 %attr(755,root,root) %ghost %{_libdir}/libtdb.so.1
98 %{_mandir}/man8/tdbbackup.8*
99 %{_mandir}/man8/tdbdump.8*
100 %{_mandir}/man8/tdbrestore.8*
101 %{_mandir}/man8/tdbtool.8*
102
103 %files devel
104 %defattr(644,root,root,755)
105 %attr(755,root,root) %{_libdir}/libtdb.so
106 %{_includedir}/tdb.h
107 %{_pkgconfigdir}/tdb.pc
108
109 %files -n python-tdb
110 %defattr(644,root,root,755)
111 %attr(755,root,root) %{py_sitedir}/tdb.so
This page took 0.10838 seconds and 4 git commands to generate.