]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
c934ff302a66fc6ba2f48218c59ea07516a34f6a
[packages/tdb.git] / tdb.spec
1 Summary:        TDB - Trivial Database
2 Summary(pl.UTF-8):      TDB - prosta baza danych
3 Name:           tdb
4 Version:        1.3.7
5 Release:        1
6 Epoch:          2
7 License:        LGPL v3+
8 Group:          Libraries
9 Source0:        https://www.samba.org/ftp/tdb/%{name}-%{version}.tar.gz
10 # Source0-md5:  e3741a19c427255acd1e92c5e09d9df7
11 URL:            http://tdb.samba.org/
12 BuildRequires:  python-devel >= 2
13 BuildRequires:  rpm-pythonprov
14 BuildRequires:  rpmbuild(macros) >= 1.219
15 Obsoletes:      tdb-extras
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 TDB is a Trivial Database. In concept, it is very much like GDBM, and
20 BSD's DB except that it allows multiple simultaneous writers and uses
21 locking internally to keep writers from trampling on each other. TDB
22 is also extremely small.
23
24 %description -l pl.UTF-8
25 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
26 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
27 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
28 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
29 ekstremalnie mała.
30
31 %package devel
32 Summary:        Header files for TDB library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
34 Group:          Development/Libraries
35 Requires:       %{name} = %{epoch}:%{version}-%{release}
36 Obsoletes:      tdb-static
37
38 %description devel
39 Header files for TDB library.
40
41 %description devel -l pl.UTF-8
42 Pliki nagłówkowe biblioteki TDB.
43
44 %package -n python-tdb
45 Summary:        Python bindings for TDB
46 Summary(pl.UTF-8):      Pythonowy interfejs do TDB
47 Group:          Libraries/Python
48 Requires:       %{name} = %{epoch}:%{version}-%{release}
49 %pyrequires_eq  python-libs
50
51 %description -n python-tdb
52 Python bindings for TDB.
53
54 %description -n python-tdb -l pl.UTF-8
55 Pythonowy interfejs do TDB.
56
57 %prep
58 %setup -q
59
60 %build
61 # note: configure in fact is waf call
62 CC="%{__cc}" \
63 CFLAGS="%{rpmcflags}" \
64 PYTHONDIR=%{py_sitedir} \
65 ./configure \
66         --prefix=%{_prefix} \
67         --libdir=%{_libdir} \
68         --disable-rpath
69
70 %{__make} \
71         V=1
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 %{__make} install \
77         DESTDIR=$RPM_BUILD_ROOT
78
79 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
80 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
81 %py_postclean
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %post   -p /sbin/ldconfig
87 %postun -p /sbin/ldconfig
88
89 %triggerpostun -p /sbin/postshell -- tdb < 2:1.2.9-2
90 -rm -f %{_libdir}/libtdb.so.1
91 /sbin/ldconfig
92
93 %files
94 %defattr(644,root,root,755)
95 %doc docs/{README,mutex.txt,tracing.txt}
96 %attr(755,root,root) %{_bindir}/tdbbackup
97 %attr(755,root,root) %{_bindir}/tdbdump
98 %attr(755,root,root) %{_bindir}/tdbrestore
99 %attr(755,root,root) %{_bindir}/tdbtool
100 %attr(755,root,root) %{_libdir}/libtdb.so.*.*.*
101 %attr(755,root,root) %ghost %{_libdir}/libtdb.so.1
102 %{_mandir}/man8/tdbbackup.8*
103 %{_mandir}/man8/tdbdump.8*
104 %{_mandir}/man8/tdbrestore.8*
105 %{_mandir}/man8/tdbtool.8*
106
107 %files devel
108 %defattr(644,root,root,755)
109 %attr(755,root,root) %{_libdir}/libtdb.so
110 %{_includedir}/tdb.h
111 %{_pkgconfigdir}/tdb.pc
112
113 %files -n python-tdb
114 %defattr(644,root,root,755)
115 %attr(755,root,root) %{py_sitedir}/tdb.so
116 %{py_sitedir}/_tdb_text.py[co]
This page took 0.023482 seconds and 2 git commands to generate.