]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
- disable rpath; release 2
[packages/tdb.git] / tdb.spec
1 Summary:        TDB - Trivial Database
2 Summary(pl.UTF-8):      TDB - prosta baza danych
3 Name:           tdb
4 Version:        1.3.5
5 Release:        2
6 Epoch:          2
7 License:        LGPL v3+
8 Group:          Libraries
9 Source0:        https://www.samba.org/ftp/tdb/%{name}-%{version}.tar.gz
10 # Source0-md5:  8f8566d2a995ff1f01df556aa279f68f
11 URL:            http://tdb.samba.org/
12 BuildRequires:  python-devel >= 2
13 BuildRequires:  rpm-pythonprov
14 Obsoletes:      tdb-extras
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16
17 %description
18 TDB is a Trivial Database. In concept, it is very much like GDBM, and
19 BSD's DB except that it allows multiple simultaneous writers and uses
20 locking internally to keep writers from trampling on each other. TDB
21 is also extremely small.
22
23 %description -l pl.UTF-8
24 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
25 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
26 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
27 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
28 ekstremalnie mała.
29
30 %package devel
31 Summary:        Header files for TDB library
32 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
33 Group:          Development/Libraries
34 Requires:       %{name} = %{epoch}:%{version}-%{release}
35 Obsoletes:      tdb-static
36
37 %description devel
38 Header files for TDB library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki TDB.
42
43 %package -n python-tdb
44 Summary:        Python bindings for TDB
45 Summary(pl.UTF-8):      Pythonowy interfejs do TDB
46 Group:          Libraries/Python
47 Requires:       %{name} = %{epoch}:%{version}-%{release}
48 %pyrequires_eq  python-libs
49
50 %description -n python-tdb
51 Python bindings for TDB.
52
53 %description -n python-tdb -l pl.UTF-8
54 Pythonowy interfejs do TDB.
55
56 %prep
57 %setup -q
58
59 %build
60 # note: configure in fact is waf call
61 CC="%{__cc}" \
62 CFLAGS="%{rpmcflags}" \
63 PYTHONDIR=%{py_sitedir} \
64 ./configure \
65         --prefix=%{_prefix} \
66         --libdir=%{_libdir} \
67         --disable-rpath
68
69 %{__make} \
70         V=1
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %{__make} install \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %post   -p /sbin/ldconfig
82 %postun -p /sbin/ldconfig
83
84 %triggerpostun -p /sbin/postshell -- tdb < 2:1.2.9-2
85 -rm -f %{_libdir}/libtdb.so.1
86 /sbin/ldconfig
87
88 %files
89 %defattr(644,root,root,755)
90 %doc docs/{README,mutex.txt,tracing.txt}
91 %attr(755,root,root) %{_bindir}/tdbbackup
92 %attr(755,root,root) %{_bindir}/tdbdump
93 %attr(755,root,root) %{_bindir}/tdbrestore
94 %attr(755,root,root) %{_bindir}/tdbtool
95 %attr(755,root,root) %{_libdir}/libtdb.so.*.*.*
96 %attr(755,root,root) %ghost %{_libdir}/libtdb.so.1
97 %{_mandir}/man8/tdbbackup.8*
98 %{_mandir}/man8/tdbdump.8*
99 %{_mandir}/man8/tdbrestore.8*
100 %{_mandir}/man8/tdbtool.8*
101
102 %files devel
103 %defattr(644,root,root,755)
104 %attr(755,root,root) %{_libdir}/libtdb.so
105 %{_includedir}/tdb.h
106 %{_pkgconfigdir}/tdb.pc
107
108 %files -n python-tdb
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{py_sitedir}/tdb.so
This page took 0.128675 seconds and 3 git commands to generate.