]> git.pld-linux.org Git - packages/tdb.git/blob - tdb.spec
8052765767fdb673843624b8441ba6097461dcae
[packages/tdb.git] / tdb.spec
1 %define snap    20080818
2 Summary:        TDB - Trivial Database
3 Summary(pl.UTF-8):      TDB - prosta baza danych
4 Name:           tdb
5 Version:        1.1.2
6 Release:        0.%{snap}.3
7 License:        GPL
8 Group:          Libraries
9 Source0:        %{name}-%{snap}.tar.bz2
10 # Source0-md5:  128dfb4865c2fcabf36d8cfbb1d20d06
11 URL:            http://tdb.samba.org/
12 BuildRequires:  gdbm-devel
13 BuildRequires:  python-devel
14 BuildRequires:  rpm-pythonprov
15 Obsoletes:      tdb-extras
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 TDB is a Trivial Database. In concept, it is very much like GDBM, and
20 BSD's DB except that it allows multiple simultaneous writers and uses
21 locking internally to keep writers from trampling on each other. TDB
22 is also extremely small.
23
24 %description -l pl.UTF-8
25 TDB to Trivial Database, czyli prosta baza danych. W założeniach jest
26 bardzo podobna do GDBM lub DB z BSD z wyjątkiem tego, że pozwala na
27 zapis wielu procesom jednocześnie i używa wewnętrznie blokowania, aby
28 nie pozwolić piszącym na zadeptanie się nawzajem. TDB jest ponadto
29 ekstremalnie mała.
30
31 %package devel
32 Summary:        Header files for TDB library
33 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki TDB
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}-%{release}
36
37 %description devel
38 Header files for TDB library.
39
40 %description devel -l pl.UTF-8
41 Pliki nagłówkowe biblioteki TDB.
42
43 %package static
44 Summary:        Static TDB library
45 Summary(pl.UTF-8):      Statyczna biblioteka TDB
46 Group:          Development/Libraries
47 Requires:       %{name}-devel = %{version}-%{release}
48
49 %description static
50 Static TDB library.
51
52 %description static -l pl.UTF-8
53 Statyczna biblioteka TDB.
54
55 %package -n python-tdb
56 Summary:        Python bindings for TDB
57 Group:          Libraries/Python
58 Requires:       %{name} = %{version}-%{release}
59 %pyrequires_eq  python-libs
60
61 %description -n python-tdb
62 Python bindings for TDB.
63
64 %prep
65 %setup -q -n %{name}
66
67 %build
68 %configure
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73
74 %{__make} install \
75         DESTDIR=$RPM_BUILD_ROOT
76
77 # it's a symlink
78 cp -a libtdb.so $RPM_BUILD_ROOT%{_libdir}
79
80 %py_comp $RPM_BUILD_ROOT
81 %py_ocomp $RPM_BUILD_ROOT
82 %py_postclean
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %post   -p /sbin/ldconfig
88 %postun -p /sbin/ldconfig
89
90 %files
91 %defattr(644,root,root,755)
92 %doc docs/README
93 %attr(755,root,root) %{_bindir}/tdbbackup
94 %attr(755,root,root) %{_bindir}/tdbdump
95 %attr(755,root,root) %{_bindir}/tdbtool
96 %attr(755,root,root) %{_libdir}/lib*.so.*.*.*
97
98 %files devel
99 %defattr(644,root,root,755)
100 %attr(755,root,root) %{_libdir}/lib*.so
101 %{_includedir}/tdb.h
102 %{_pkgconfigdir}/*.pc
103
104 %files static
105 %defattr(644,root,root,755)
106 %{_libdir}/lib*.a
107
108 %files -n python-tdb
109 %defattr(644,root,root,755)
110 %attr(755,root,root) %{py_sitedir}/*.so
111 %{py_sitescriptdir}/*.py[co]
This page took 0.126349 seconds and 3 git commands to generate.