- force libpcap 1.4.0, enable capability dropping via libcap-ng auto/th/tcpdump-4.4.0-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 6 Jun 2013 20:52:29 +0000 (22:52 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Thu, 6 Jun 2013 20:52:29 +0000 (22:52 +0200)
tcpdump.spec

index cbbf3c03c613dcaab9905afe5aaa0fd5614b8670..ba2896b25ab51686bb2eb71187b143ad41e2b1cc 100644 (file)
@@ -23,11 +23,12 @@ Source0:    http://www.tcpdump.org/release/%{name}-%{version}.tar.gz
 Patch0:                libpcap-m4.patch
 URL:           http://www.tcpdump.org/
 BuildRequires: autoconf >= 2.50
-BuildRequires: libpcap-devel >= 2:1.3.0
+BuildRequires: libcap-ng-devel
+BuildRequires: libpcap-devel >= 2:1.4.0
 %{?with_libsmi:BuildRequires:  libsmi-devel}
 BuildRequires: openssl-devel >= 0.9.7d
 BuildRequires: rpmbuild(macros) >= 1.202
-Requires:      libpcap >= 2:1.3.0
+Requires:      libpcap >= 2:1.4.0
 Provides:      user(tcpdump)
 Requires(postun):      /usr/sbin/userdel
 Requires(pre): /bin/id
@@ -88,7 +89,8 @@ Tcpdump виводить хедери пакетів, що проходять ч
        --with-user=tcpdump \
        --with-chroot=/usr/share/empty \
 %endif
-       --enable-ipv6
+       --enable-ipv6 \
+       --with-crypto
 %{__make}
 
 %install
This page took 0.085569 seconds and 4 git commands to generate.