]> git.pld-linux.org Git - packages/tar.git/commitdiff
- updated to 1.26 auto/th/tar-1_26-1 auto/ti/tar-1_26-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 13 Mar 2011 15:00:35 +0000 (15:00 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- updated pl.po-update patch (from TP)
- removed obsolete listed-incremental patch

Changed files:
    tar-listed-incremental.patch -> 1.2
    tar-pl.po-update.patch -> 1.21
    tar.spec -> 1.134

tar-listed-incremental.patch [deleted file]
tar-pl.po-update.patch
tar.spec

diff --git a/tar-listed-incremental.patch b/tar-listed-incremental.patch
deleted file mode 100644 (file)
index a92758d..0000000
+++ /dev/null
@@ -1,123 +0,0 @@
-From 065cf0958c39600f2062cbeeb5b76929d03c207b Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Tue, 23 Nov 2010 06:50:58 +0000
-Subject: * src/names.c: tar: fix bug with --one-file-system --listed-incremental
-
-Problem (and idea for fix) reported by Martin Weigel
-<http://lists.gnu.org/archive/html/bug-tar/2010-11/msg00071.html>.
-* src/common.h (is_individual_file): Remove decl.
-* src/create.c (dump_file0): Replace "is_individual_file (p)"
-with "top_level".
-* src/incremen.c (procdir): Replace "!is_individual_file
-(name_buffer)" with "st->parent".  Fix bug with --one-file-system
-and --listed-incremental.
-* src/names.c (individual_file_table, register_individual_file):
-(is_individual_file): Remove.  All uses removed.
----
-diff --git a/src/common.h b/src/common.h
-index 35e056e..9444fd7 100644
---- a/src/common.h
-+++ b/src/common.h
-@@ -680,7 +680,6 @@ bool excluded_name (char const *name);
- void add_avoided_name (char const *name);
- bool is_avoided_name (char const *name);
--bool is_individual_file (char const *name);
- bool contains_dot_dot (char const *name);
-diff --git a/src/create.c b/src/create.c
-index a1e90a3..e8de6b9 100644
---- a/src/create.c
-+++ b/src/create.c
-@@ -1678,9 +1678,9 @@ dump_file0 (struct tar_stat_info *st, char const *name, char const *p)
-      put in the archive.
-      This check is omitted if incremental_option is set *and* the
--     requested file is not explicitely listed in the command line. */
-+     requested file is not explicitly listed in the command line.  */
--  if (!(incremental_option && !is_individual_file (p))
-+  if (! (incremental_option && ! top_level)
-       && !S_ISDIR (st->stat.st_mode)
-       && OLDER_TAR_STAT_TIME (*st, m)
-       && (!after_date_option || OLDER_TAR_STAT_TIME (*st, c)))
-diff --git a/src/incremen.c b/src/incremen.c
-index 628ff29..2b33c5d 100644
---- a/src/incremen.c
-+++ b/src/incremen.c
-@@ -426,7 +426,6 @@ procdir (const char *name_buffer, struct tar_stat_info *st,
- {
-   struct directory *directory;
-   struct stat *stat_data = &st->stat;
--  dev_t device = st->parent ? st->parent->stat.st_dev : 0;
-   bool nfs = NFS_FILE_STAT (*stat_data);
-   if ((directory = find_directory (name_buffer)) != NULL)
-@@ -540,11 +539,8 @@ procdir (const char *name_buffer, struct tar_stat_info *st,
-       }
-     }
--  /* If the directory is on another device and --one-file-system was given,
--     omit it... */
--  if (one_file_system_option && device != stat_data->st_dev
--      /* ... except if it was explicitely given in the command line */
--      && !is_individual_file (name_buffer))
-+  if (one_file_system_option && st->parent
-+      && stat_data->st_dev != st->parent->stat.st_dev)
-     /* FIXME:
-       WARNOPT (WARN_XDEV,
-                (0, 0,
-diff --git a/src/names.c b/src/names.c
-index 6e214bf..ba4d509 100644
---- a/src/names.c
-+++ b/src/names.c
-@@ -47,8 +47,6 @@ static char *cached_no_such_gname;
- static uid_t cached_no_such_uid;
- static gid_t cached_no_such_gid;
--static void register_individual_file (char const *name);
--
- /* Given UID, find the corresponding UNAME.  */
- void
- uid_to_uname (uid_t uid, char **uname)
-@@ -360,8 +358,6 @@ name_next_elt (int change_dirs)
-       {
-         if (unquote_option)
-           unquote_string (name_buffer);
--        if (incremental_option)
--          register_individual_file (name_buffer);
-         entry.type = ep->type;
-         entry.v.name = name_buffer;
-         return &entry;
-@@ -1152,28 +1148,6 @@ excluded_name (char const *name)
-   return excluded_file_name (excluded, name + FILE_SYSTEM_PREFIX_LEN (name));
- }
\f
--static Hash_table *individual_file_table;
--
--static void
--register_individual_file (char const *name)
--{
--  struct stat st;
--
--  if (deref_stat (name, &st) != 0)
--    return; /* Will be complained about later */
--  if (S_ISDIR (st.st_mode))
--    return;
--
--  hash_string_insert (&individual_file_table, name);
--}
--
--bool
--is_individual_file (char const *name)
--{
--  return hash_string_lookup (individual_file_table, name);
--}
--
--\f
- /* Return the size of the prefix of FILE_NAME that is removed after
-    stripping NUM leading file name components.  NUM must be
---
-cgit v0.8.3.2
index cb902eef5e9a8d801f7da3a1882d3e7188938d26..4c4359bf982c4b51fb348ed754ea940c3d43eba8 100644 (file)
@@ -1,41 +1,41 @@
---- tar-1.25/po/pl.po.orig     2010-11-07 16:08:01.000000000 +0100
-+++ tar-1.25/po/pl.po  2010-11-11 08:12:58.587095747 +0100
-@@ -2,17 +2,16 @@
- # Copyright (C) 1996, 1997, 2000, 2001, 2003, 2004, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
+--- tar-1.26/po/pl.po.orig     2011-03-12 10:53:55.000000000 +0100
++++ tar-1.26/po/pl.po  2011-03-13 15:16:38.063410428 +0100
+@@ -1,15 +1,15 @@
+ # Polish translation of GNU tar
+-# Copyright (C) 1996, 1997, 2000, 2001, 2003, 2004, 2006, 2007, 2008, 2009, 2010 Free Software Foundation, Inc.
++# Copyright (C) 1996, 1997, 2000, 2001, 2003, 2004, 2006, 2007, 2008, 2009, 2010, 2011 Free Software Foundation, Inc.
  # This file is distributed under the same license as the tar package.
- # Rafał Maszkowski <rzm@icm.edu.pl>, 1996, 1997, 2000, 2001, 2003, 2004, 2006-2010.  „”
--# Thanks to Jakub Bogusz for remarks and corrections, 2003, 2004, 2007, 2008
-+# Thanks to Jakub Bogusz for remarks and corrections, 2003, 2004, 2007, 2008, 2010
+-# Rafał Maszkowski <rzm@icm.edu.pl>, 1996, 1997, 2000, 2001, 2003, 2004, 2006-2010.  „”
+-# Thanks to Jakub Bogusz for remarks and corrections, 2003, 2004, 2007, 2008, 2010
++# Rafał Maszkowski <rzm@icm.edu.pl>, 1996, 1997, 2000, 2001, 2003, 2004, 2006-2011.  „”
++# Thanks to Jakub Bogusz for remarks and corrections, 2003, 2004, 2007, 2008, 2010.
  #: src/create.c:1552
  msgid ""
  msgstr ""
--"Project-Id-Version: tar 1.23.90\n"
-+"Project-Id-Version: tar 1.24\n"
+-"Project-Id-Version: tar 1.24\n"
++"Project-Id-Version: tar 1.26\n"
  "Report-Msgid-Bugs-To: bug-tar@gnu.org\n"
- "POT-Creation-Date: 2010-11-07 17:07+0200\n"
--"PO-Revision-Date: 2010-07-13 14:50+0200\n"
-+"PO-Revision-Date: 2010-10-25 23:10+0200\n"
+ "POT-Creation-Date: 2011-03-12 11:53+0200\n"
+-"PO-Revision-Date: 2010-10-25 23:10+0200\n"
++"PO-Revision-Date: 2011-03-12 18:25+0100\n"
  "Last-Translator: Rafał Maszkowski <rzm@icm.edu.pl>\n"
  "Language-Team: Polish <translation-team-pl@lists.sourceforge.net>\n"
--"Language: pl\n"
- "MIME-Version: 1.0\n"
- "Content-Type: text/plain; charset=UTF-8\n"
- "Content-Transfer-Encoding: 8-bit\n"
-@@ -1274,9 +1273,8 @@
- msgstr "Tworzony jest katalog:"
+ "Language: pl\n"
+@@ -879,9 +879,8 @@
+ msgstr "Archiwum zawiera nazwy plików bez początkowych elementów ścieżek."
  
- #: src/misc.c:298
+ #: src/compare.c:526
 -#, fuzzy
- msgid "Cannot get working directory"
--msgstr "Nie można zmienić katalogu"
-+msgstr "Nie można odczytać bieżącego katalogu"
+ msgid "Archive contains transformed file names."
+-msgstr "Archiwum zawiera przestarzałe nagłówki base64"
++msgstr "Archiwum zawiera zmienione nazwy plików."
  
- #: src/misc.c:571
- #, c-format
-@@ -2760,6 +2758,3 @@
+ #: src/compare.c:531
+ msgid "Verification may fail to locate original files."
+@@ -2759,6 +2758,3 @@
  #, c-format
  msgid "--stat requires file names"
  msgstr "--stat wymaga podania nazwy pliku"
 -
--#~ msgid "Cannot save working directory"
--#~ msgstr "Nie można zapisać bieżącego katalogu"
+-#~ msgid "%s: Directory removed before we read it"
+-#~ msgstr "%s: Katalog usunięty zanim został przeczytany"
index d0b9195f4cca004acb453d0b47558143f12a6b62..c59c58390fbd992cdb45e4ac0f9de819d27535da 100644 (file)
--- a/tar.spec
+++ b/tar.spec
@@ -10,19 +10,18 @@ Summary(pl.UTF-8):  Program do archiwizacji (GNU)
 Summary(pt_BR.UTF-8):  GNU Tape Archiver (tar)
 Summary(tr.UTF-8):     Yaygın kullanılan yedekleyici
 Name:          tar
-Version:       1.25
-Release:       2
+Version:       1.26
+Release:       1
 Epoch:         1
 License:       GPL v3+
 Group:         Applications/Archiving
 Source0:       http://ftp.gnu.org/gnu/tar/%{name}-%{version}.tar.bz2
-# Source0-md5: 6e497f861c77bbba2f7da4e10270995b
+# Source0-md5: 2cee42a2ff4f1cd4f9298eeeb2264519
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: 4e4b1655fe42c27a4eb5d7bcd82e74ac
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-pl.po-update.patch
 Patch2:                %{name}-zero-block.patch
-Patch3:                %{name}-listed-incremental.patch
 URL:           http://www.gnu.org/software/tar/tar.html
 BuildRequires: autoconf >= 2.63
 BuildRequires: automake >= 1:1.11
@@ -143,7 +142,6 @@ z pakietu dump.
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
 
 %{__rm} po/stamp-po
 
This page took 0.044796 seconds and 4 git commands to generate.