]> git.pld-linux.org Git - packages/talloc.git/blob - talloc.spec
- updated URL
[packages/talloc.git] / talloc.spec
1 Summary:        The talloc library - a hierarchical pool based memory system
2 Summary(pl.UTF-8):      Biblioteka talloc - system przydzielania pamięci oparty na hierarchicznej puli
3 Name:           talloc
4 Version:        2.3.1
5 Release:        1
6 Epoch:          2
7 License:        LGPL v3+
8 Group:          Libraries
9 Source0:        https://www.samba.org/ftp/talloc/%{name}-%{version}.tar.gz
10 # Source0-md5:  ce40593428c0de6b85946189dcc37b5e
11 URL:            https://talloc.samba.org/
12 BuildRequires:  docbook-dtd42-xml
13 BuildRequires:  docbook-style-xsl
14 BuildRequires:  libxslt-progs
15 BuildRequires:  python3 >= 1:3.2
16 BuildRequires:  python3-devel >= 1:3.2
17 BuildRequires:  python3-modules >= 1:3.2
18 BuildRequires:  rpm-pythonprov
19 Provides:       libtalloc = 2:%{version}-%{release}
20 Obsoletes:      libtalloc < 2:2.0.7-2
21 # talloc 2.2+ dropped python2 support
22 Obsoletes:      python-talloc
23 Obsoletes:      python-talloc-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 The talloc library implements a hierarchical allocator with
28 destructors.
29
30 %description -l pl.UTF-8
31 Biblioteka talloc jest implementacją systemu zarządzania pamięcią
32 opartego na hierarchicznej puli wraz z destruktorami.
33
34 %package devel
35 Summary:        Development files for the talloc library
36 Summary(pl.UTF-8):      Pliki programistyczne biblioteki talloc
37 Group:          Development/Libraries
38 Requires:       %{name} = %{epoch}:%{version}-%{release}
39 Provides:       libtalloc-devel = 2:%{version}-%{release}
40 Obsoletes:      libtalloc-devel < 2:2.0.7-2
41 Obsoletes:      libtalloc-static
42
43 %description devel
44 Development files needed to create programs that link against the
45 talloc library.
46
47 %description devel -l pl.UTF-8
48 Pliki programistyczne potrzebne do tworzenia programów używających
49 biblioteki talloc.
50
51 %package -n python3-talloc
52 Summary:        Python 3 binding for talloc library
53 Summary(pl.UTF-8):      Wiązanie Pythona 3 do biblioteki talloc
54 Group:          Libraries/Python
55 Requires:       %{name} = %{epoch}:%{version}-%{release}
56 Requires:       python3-libs >= 1:3.2
57
58 %description -n python3-talloc
59 Python 2 binding for talloc library.
60
61 %description -n python3-talloc -l pl.UTF-8
62 Wiązanie Pythona 3 do biblioteki talloc.
63
64 %package -n python3-talloc-devel
65 Summary:        Development files for Python 3 pytalloc-util library
66 Summary(pl.UTF-8):      Pliki programistyczne biblioteki pytalloc-util dla Pythona 3
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
69 Requires:       python3-devel >= 1:3.2
70 Requires:       python3-talloc = %{epoch}:%{version}-%{release}
71
72 %description -n python3-talloc-devel
73 Development files for Python 3 pytalloc-util library.
74
75 %description -n python3-talloc-devel -l pl.UTF-8
76 Pliki programistyczne biblioteki pytalloc-util dla Pythona 3.
77
78 %prep
79 %setup -q
80
81 %build
82 # threading breaks waf
83 export JOBS=1
84
85 CC="%{__cc}" \
86 CFLAGS="%{rpmcflags}" \
87 %{__python3} buildtools/bin/waf configure \
88         --prefix=%{_prefix} \
89         --libdir=%{_libdir} \
90         --disable-rpath
91
92 %{__make} \
93         V=1
94
95 %install
96 rm -rf $RPM_BUILD_ROOT
97
98 %{__make} install \
99         DESTDIR=$RPM_BUILD_ROOT
100
101 %clean
102 rm -rf $RPM_BUILD_ROOT
103
104 %post   -p /sbin/ldconfig
105 %postun -p /sbin/ldconfig
106
107 %triggerpostun -p /sbin/postshell -- libtalloc < 2:2.0.1-5
108 -rm -f %{_libdir}/libtalloc.so.2
109 /sbin/ldconfig
110
111 %post   -n python3-talloc -p /sbin/ldconfig
112 %postun -n python3-talloc -p /sbin/ldconfig
113
114 %files
115 %defattr(644,root,root,755)
116 %attr(755,root,root) %{_libdir}/libtalloc.so.*.*.*
117 %attr(755,root,root) %ghost %{_libdir}/libtalloc.so.2
118
119 %files devel
120 %defattr(644,root,root,755)
121 %doc talloc_guide.txt
122 %attr(755,root,root) %{_libdir}/libtalloc.so
123 %{_includedir}/talloc.h
124 %{_pkgconfigdir}/talloc.pc
125 %{_mandir}/man3/talloc.3*
126
127 %files -n python3-talloc
128 %defattr(644,root,root,755)
129 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so.*.*.*
130 %attr(755,root,root) %ghost %{_libdir}/libpytalloc-util.cpython-3*.so.2
131 %attr(755,root,root) %{py3_sitedir}/talloc.cpython-3*.so
132
133 %files -n python3-talloc-devel
134 %defattr(644,root,root,755)
135 %attr(755,root,root) %{_libdir}/libpytalloc-util.cpython-3*.so
136 %{_includedir}/pytalloc.h
137 %{_pkgconfigdir}/pytalloc-util.cpython-3*.pc
This page took 0.120878 seconds and 3 git commands to generate.